[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Can't Receive Email from Internet - Exchange Server 2010

Posted on 2011-02-22
6
Medium Priority
?
1,265 Views
Last Modified: 2012-05-11
Hello,

We recently moved from Exchange 2003 to 2010. We successfully configured and remove 2003 server. Suddenly last night, we can't receive inbound e-mails. When I verify the issue, the server is down and it shows blue screen error. I restarted the server and I'm able to send and receive e-mail on local and send e-mail to internet.

But not receive mail from internet.

II ran the troubleshooter and it shows:
mail submission failed error message the smtp host was not specified

When I verify the Client Send Connector, the FQDN is empty. Then I specified FQDN as mail.mydomain.com

After that I found this:

In the event log:
Microsoft Exchange could not find a certificate that contains the domain name mail.mydomain.com in the personal store on the local computer. Therefore, it is unable to support the STARTTLS SMTP verb for the connector Client EXCHANGE2 with a FQDN parameter of mail.mydomain.com. If the connector's FQDN is not specified, the computer's FQDN is used. Verify the connector configuration and the installed certificates to make sure that there is a certificate with a domain name for that FQDN. If this certificate exists, run Enable-ExchangeCertificate -Services SMTP to make sure that the Microsoft Exchange Transport service has access to the certificate key.

I'm sure that network is working fine. Any further help would be greatly appreciated. Thanks.

0
Comment
Question by:SrinathS
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
6 Comments
 
LVL 9

Assisted Solution

by:dexIT
dexIT earned 1400 total points
ID: 34953523
Check:
1) DNS (dcdiag/test:dns,dcdiag/fix)
2) Make sure you review your receive connector configuration
3) Make sure that anonymous is checked
0
 

Author Comment

by:SrinathS
ID: 34953675
DNS Settings are correct. Do I need to specify FQDN for both Client and Default Receive Connector? If yes, Do i need to specify internal exchange server url or public url? i.e., exchange2.flup.local or mail.mydomain.com

Also I followed these instructions: http://support.microsoft.com/kb/555855

Still the same error message.
0
 

Author Comment

by:SrinathS
ID: 34953722
Currently these are settings in Receive Connectors:

Client Default Receive Connector: NO FQDN specified - also tried to specify mail.mydomain.com
Default Receive Connector: exchange2.flup.local - it won't let me change it. When I try to change it shows the following error message:

--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
The following error(s) occurred while saving changes:

Set-ReceiveConnector
Failed
Error:
If the AuthMechanism attribute on a Receive connector contains the value ExchangeServer, you must set the FQDN parameter on the Receive connector to one of the following values: the FQDN of the transport server "exchange2.FLUP.local", the NetBIOS name of the transport server "EXCHANGE2", or $null.
------------------------------------------------------------
0
Q2 2017 - Latest Malware & Internet Attacks

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out our latest Quarterly Internet Security Report!

 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 600 total points
ID: 34953929
Have you redirected your firewall to deliver mail from the 2003 server to the 2010 server?
0
 

Author Comment

by:SrinathS
ID: 34954035
I already remove Exchange 2003 Server. Also we are using Edge-water networks router. I removed the references to 2003 and created references (local exchange server ip address and ports) in the router.

Everything is fine until last night. The Exchange Server crashed by showing blue-screen death error.There are some errors in event log. Exchnage Server 2010 Crash
0
 

Author Comment

by:SrinathS
ID: 34954619
This issue has been temp resolved by restarting System Attendant and Transport services.
0

Featured Post

Veeam Task Manager for Hyper-V

Task Manager for Hyper-V provides critical information that allows you to monitor Hyper-V performance by displaying real-time views of CPU and memory at the individual VM-level, so you can quickly identify which VMs are using host resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I don't pretend to be an expert at this, but I have found a few things that are useful. I hope that sharing them here will help others, so they will not have to face some rather hard choices. Since I felt this to be a topic of enough importance and…
By default Outlook 2016 displays only one time zone in the Calendar. The following article explains how to display two time zones in one calendar view.
This video discusses moving either the default database or any database to a new volume.
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question