Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1036
  • Last Modified:

Mount

I am trying to mount from my RedHat server to another RedHat server across the network.

I am running mount -t ext3 server.remote.location:/gevol /mnt/gedev

But I am getting a special device server.remote.location:/gevol does not exist

The directory does exist.  I just need to copy a directory from that server to my sever.  Is there an easy way?
0
StrongD1
Asked:
StrongD1
  • 6
  • 5
  • 2
  • +2
1 Solution
 
KCarney81Commented:
Try using samba shares instead of direct mapping
0
 
arnoldCommented:
Use nfs instead of samba for linux to linux share.

define the shares in /etc/exports
mount -t nfs server:/sharename
0
 
KCarney81Commented:
Either method will work, nfs or samba is a matter of preference
0
Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

 
rysicCommented:
If you need just copy directory, you can use ssh connection.
Have a look at SCP
http://pl.wikipedia.org/wiki/Secure_copy

or winscp if client is using Windows.
0
 
rysicCommented:
SORRY! English version http://en.wikipedia.org/wiki/Secure_copy
(I'm from Poland :D )
0
 
StrongD1Author Commented:
smbclient \\\\server.remote.location\\gevol --user=root

Connection to ge.edwards.af.mil failed (Error NT_STATUS_CONNECTION_REFUSED)

Can you guys give to the syntax for smb stuff?
0
 
rysicCommented:
Why samba?? It isn't Windows server...
0
 
StrongD1Author Commented:
I am doing what someone suggested...  

If you have an easy way to do this, let me know.  

0
 
rysicCommented:
W wroto you - SCP
0
 
rysicCommented:
If you connected to server via SSH, you can use SCP.
0
 
KCarney81Commented:
rysic's solutions will also work.  It's basically connecting via FTP on port 22
0
 
rysicCommented:
Well not exacly... it is secure and you don't need FTP server setting up. Just OpenSSH daemon started.
0
 
KCarney81Commented:
Correct, just functionally the same
0
 
lnkevinCommented:
Here are the complete steps:

Let's assume the source (server.remote.location) server is serverA and the other server is ServerB.

On serverA do the following:

vi /etc/exports
then add the following save and exit
/gevol *(rw,sync)
then you run this on serverA:
/etc/init.d/nfs restart

From serverB:
mkdir /mnt/gedev

then
mount ServerA:/gevol /mnt/gedev

if you want your mount point existed after serverB reboot, you set the mount point in fstab:
vi /etc/fstab
add the following line then save and exit
ServerA:/gevol           /mnt/gedev        nfs       defaults      0 0

Done!

K







0
 
lnkevinCommented:
NO SAMBA for Linux to Linux mounting!

K
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

  • 6
  • 5
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now