DHCP Relay not working

I am running two Checkpoint UTM-1 270s running NGX R65 in a HA cluster.  On the external interface, besides my primary ISP (not a VLAN) I have 5 other VLANs, including another ISP and 3 private connections from our ISP (COX) on MetroE.  Two of these MetroE connections are with partners, and are completely NATted, with no internal access.  The third is with a new branch office. DHCP requests from the new office are not being forwarded to the Windows AD DC.

I have turned on DHCP relay in the Expert Mode of both firewalls, and enabled it both on the External and the External.210 interfaces, but no luck.  Seems like this should be pretty straight forward, but I am beating my head against the wall here.

David Griswold
david_griswoldAsked:
Who is Participating?
 
david_griswoldAuthor Commented:
There is only one helper in the path.  I already ruled that one out.

I figured it out.  I had DHCP relay turned on the Internal interface, but not the interface that the DHCP response was returning on, which was Internal.30.  Once I enabled DHCP relay on that interface, it started working.

Now I just need to figure out why stateful connections, like SQL and others are getting reset periodically, but that is another question...
0
 
david_griswoldAuthor Commented:
After reading a bit more, I realized I didn't have a firewall rule to allow the DHCP broadcasts, requests and responses, so I setup a wide open one, just to get the requests forwarded.  I see in the logs that they are being forwarded to the server, and the server is getting back to the firewall, but that's where it ends.  The client never gets the response back.

David
0
 
Rick_at_ptscintiCommented:
I am not a Checkpoint guy but on most routers you just have to specify a helper address on LAN interface of the far router.  (the helper address is the IP address of the DHCP server)  You shouldn't have to do anything on the server side network.  I know on some routers you can't have DHCP running on the router as well as use helper addresses.
0
 
david_griswoldAuthor Commented:
closed
0
 
david_griswoldAuthor Commented:
I figured it out on my own.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.