Solved

How do I set the default zoom in Word 2010 upon startup?

Posted on 2011-02-22
14
6,774 Views
Last Modified: 2012-06-27
Hello,

I have an issue with Word 2010 not loading the default zoom when starting the program.  First, I understand that Normal.dotm is loaded when you start up Word.  Per instructions found while googling, I applied an AutoNew() and AutoOpen() macro to the template which is supposed to set the document to print view and 100% zoom.

The instructions I followed were from here.

However, when I start up Word, the document zoom is still 75%.  But the strange thing is, if I close that document but do not close Word, and then go to File, New Document, then the view is 100% like it should be.  Also, if I open an existing document, the view is also 100% like it should be.  If I double-click on Normal.dotm in the Templates folder, then it also works correctly.

So the problem lies with starting up word via it's shortcut in the start menu.

What I have do so far is apply the macro to Normal.dotm:

Sub AutoOpen()
  ActiveWindow.View.Type = 3
  ActiveWindow.View.Zoom.Percentage = 100
End Sub

Sub AutoNew()
  ActiveWindow.View.Type = 3
  ActiveWindow.View.Zoom.Percentage = 100
End Sub

I have also tried saving over Normal.dotm with the settings applied.  Still no effect.  There are other addin dot files that run on startup, but I confirmed that they were not the issue.

So the question is, how do I set the zoom to be 100% when opening Word from the start menu?
0
Comment
Question by:bigeven2002
  • 6
  • 3
  • 3
  • +1
14 Comments
 
LVL 31

Expert Comment

by:Paul Sauvé
ID: 34956501
Have you tried modifying the Normal.dotm (or Normal.dotx) file. Simply set the Zoom to 100% and save it. I have done this in the past. Much easier than using macros.
0
 
LVL 1

Expert Comment

by:KevJLaw
ID: 34956529
This information doesn't appear to be stored within normal.dotm.  However, I can change the default zoom for Word 2010 by modifying the registry value:

HKCU\Software\Microsoft\Office\14.0\Word\Data\Settings

The value is REG_BINARY.  Change the byte 02A6 to the desired zoom level in hex (64 = 100%, C8 = 200%, etc.).  Then open Word 2010 and the default zoom should be whatever you set it to.


0
 
LVL 76

Expert Comment

by:GrahamSkan
ID: 34956769
The AutoNew and the AutoOpen macros do not fire when Word is opened be calling the executable directly.

AutoExec will, though.
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 34956951
Thanks for the responses so far.  I will try the registry hack and AutoExec tomorrow and report back.  I already tried modifying Normal.dotm but it had no effect when opening up the program from start menu.
0
 
LVL 31

Expert Comment

by:Paul Sauvé
ID: 34956983


I already tried modifying Normal.dotm but it had no effect...

Yes - but please try modifying Normal.dotx also...
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 34957004
OK will do.
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 34961958
Ok, so I attempted to update the regular Normal.dot template (I don't have a Normal.dotx template) and it opens at 100% when I double-click the dot file.  But still when opening Word from start menu, it still opens at 75%.

I tried using AutoExec() in the Normal.dotm global template and it gives
"Run-time error 4248 This command is not available because no document is open."

For the registry hack, I don't have a 02A6 byte, it starts at 02A0 and then next is 02A8.

0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 
LVL 31

Expert Comment

by:Paul Sauvé
ID: 34962383
OK - I've figured it out...

1. Open Word

2. Open Normal.dotm (C:\Users\[i][b]YourUserName[/b][/i]\AppData\Roaming\Microsoft\Templates)

3. Set the zoom at 100%

4. Use [i][b]Save as[/b][/i], rather than Save, to save the Normal.dotm

It worked for me in Vista Home Premium x64...
0
 
LVL 1

Expert Comment

by:KevJLaw
ID: 34962538
For the registry change, look at the row 02A0.  There should be eight bytes in that row.  02A6 is the 7th byte (1st from the right).  Change that value to 64 and the zoom will be at 100%.  Change it to C8 and it will be at 200%.  Change it to 85 and it will be at 133%.

0
 
LVL 17

Author Comment

by:bigeven2002
ID: 34964141
Well...this is odd, I did both saving as Normal.dotm with zoom at 100%...no effect.  If I go to the templates directory and double-click the file, it will open at 100%, but if I open Word from start menu, it will still open at 75%.

Also, the 7th byte in the registry on 02A0 is showing 64 which should be 100%.

Sorry I forgot to mention, this is XP Pro 32-bit.  So there is still something overriding these settings.  Should I try repair install?
0
 
LVL 1

Expert Comment

by:KevJLaw
ID: 34964336
In your Start Menu shortcut properties, do you see it using any command-line switches, or anything else out of the ordinary?  For instance, the /t switch would open Word using an alternative template file.
0
 
LVL 17

Author Comment

by:bigeven2002
ID: 34965757
Nothing that I can see, I attached a screenshot of that page.
Word 2010 Shortcut Properties Screenshot
0
 
LVL 76

Accepted Solution

by:
GrahamSkan earned 500 total points
ID: 34965922
You may have a corrupt installation, especially with regard to the Word registry keys. See this article from Microsoft:

http://support.microsoft.com/kb/921541
0
 
LVL 17

Author Closing Comment

by:bigeven2002
ID: 34970970
Killing the Normal.dot* templates resolved the issue.  We had a customized template that caused the issue so I'll need to look through its macros to see why it's only 75%.  For now, the issue has been resolved.

Thanks everyone!
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Over the years I have built up my own little library of code snippets that I refer to when programming or writing a script.  Many of these have come from the web or adaptations from snippets I find on the Web.  Periodically I add to them when I come…
Shortcuts in Word Just the other day I had a training for Microsoft and they wanted me to show how well the new Windows and Office behaved on a touch device, which by the way is great, but it was only then that I realized that using keyboard shortc…
In this video, we show how to convert an image-only PDF file into a PDF Searchable Image file, that is, a file with both the image (typically from scanning) and text, which is created in an automated fashion with Optical Character Recognition (OCR) …
This video walks the viewer through the process of creating Hyperlinks for the web and other documents. Select the "Insert" tab: Click "Hyperlink":  Type "http://" followed by a web address to reference a website or navigate to a document to ref…

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now