Solved

Website doesn't load on first request.

Posted on 2011-02-22
4
641 Views
Last Modified: 2012-05-11
I'm going totally nuts here and I really need you help! … Please :)

When I first connect to my website, browser just spins and never loads the website. This is in the TMG log:

Time: 21:51:26
Protocol: HTTPS
Action: Initiated Connection

Time: 21:51:29
Protocol: HTTPS
Action: Closed Connection

So in 3ms it closes the connection.


If I a couple of seconds after try again, webpage loads perfectly and I get this in TMG log:

Time: 22:11:33
Protocol: HTTPS
Action: Initiated Connection

Time: 22:11:33
Protocol: HTTPS
Action: Allowed Connection
Rule: Publish HTTPS sites


So first request fails and subsequent requests are fine … but if I leave the website for like 30 minutes and go back, the problem starts all over.

On my website I've set this:  "Idle time-out" to 0 and Recycling "Regular time interval" to 0.

I only see this on my HTTPS sites … all my HTTP sites are working perfectly.

My servers:
All my servers are running Win2008R2x64 and all windows update has been applied.
I have three servers:
* DC1 (the domain controller / sql / file)
* EXCHANGE1 (Exchange server)
* TMG1 (TMG server)

Any idea?

Thanks!

:)
Mojo

 
0
Comment
Question by:M_O_J_O
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 15

Expert Comment

by:pcsmitpra
ID: 34960026
You need to to enable the HTTP keep-alive response header  , Steps are :
> Open IIS -> In Features View, double-click HTTP Response Headers
-> On the HTTP Response Headers page, in the Actions  pane ->  click Set Common Headers
-> In the Set Common HTTP Response Headers dialog box
-> select the Enable HTTP keep-alive check box
-> click OK
This is the only requirement,  Hope this will help you.
0
 

Author Comment

by:M_O_J_O
ID: 34960064
Hi,

Thank you for your answer.

They are already enabled.

:(

Thanks anyway.

Mojo
0
 

Accepted Solution

by:
M_O_J_O earned 0 total points
ID: 34979707
0
 

Author Closing Comment

by:M_O_J_O
ID: 35015409
Because I solved it myself.
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Logparser is the smartest tool I have ever used in parsing IIS log files and there are many interesting things I wanted to share with everyone one of the  real-world  scenario from my current project. Let's get started with  scenario - How do w…
Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
In this video, viewers will be given step by step instructions on adjusting mouse, pointer and cursor visibility in Microsoft Windows 10. The video seeks to educate those who are struggling with the new Windows 10 Graphical User Interface. Change Cu…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …

695 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question