Solved

Friend has changed his email provider

Posted on 2011-02-22
25
282 Views
Last Modified: 2012-05-11
This is pretty simple I'm sure, but couldn't find it in the searches.

A friend has changed his domain name to work through google apps now. If I send him an email it still goes to his paradise email account and not through his google app account.
If I then send him an email to from my gmail account it goes through fine to his google app account


Where do I update the server details to reflect his new settings? I would of thought that this would be automatic

I am guessing that there is some config issue on my dns possibly?
0
Comment
Question by:parimp
  • 13
  • 11
25 Comments
 
LVL 3

Expert Comment

by:KCarney81
ID: 34956091
I don't believe there would be any changes for you to make, could be that the change will take some time to replicate across the internet.  You have no control over his email unless you actually host it.
0
 
LVL 1

Author Comment

by:parimp
ID: 34956172
I understand what you are saying but he says he is getting all emails correctly from everyone else and just seems to have the problem with us.
0
 
LVL 32

Expert Comment

by:aleghart
ID: 34956287
Your (or your ISP's) DNS records may be stale.  Or your mail server may have a route set up to forward mail.  Are you using the same ISP as your friend's old mail service?  If so, their SMTP relay may still be receiving for that email address, and not forwarding properly to Google.
0
 
LVL 32

Expert Comment

by:aleghart
ID: 34956299
Can you give the following?:

1. domain name (not email address, no www)
2. your public DNS server (usually an ISP, unless you run your own)

Or, paste this in a web browser (leave the "ftp"...it's just pointing to a web server, not actually using FTP):

http://ftp.menandmice.com/knowledgehub/tools/dig

Look up the MX record for that domain (DNS server = blank).
Then, type in your DNS server and see if the results are the same.
0
 
LVL 1

Author Comment

by:parimp
ID: 34956494
; <<>> DiG 9.2.3 <<>> @dns1.menandmice.com pierson.net.nz A
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58960
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0
;; QUESTION SECTION:
;pierson.net.nz. IN A
;; ANSWER SECTION:
pierson.net.nz.       28800       IN       A 174.129.25.161      
;; AUTHORITY SECTION:
pierson.net.nz.       86399       IN       NS ns.freeparking.co.nz.      
pierson.net.nz.       86399       IN       NS ns2.freeparking.co.nz.      
;; Query time: 2382 msec
;; SERVER: 217.151.171.7#53(dns1.menandmice.com)
;; WHEN: Tue Feb 22 22:45:43 2011
;; MSG SIZE rcvd: 98
0
 
LVL 1

Author Comment

by:parimp
ID: 34956505
That above is his domain name that he is using
0
 
LVL 32

Expert Comment

by:aleghart
ID: 34956566
Now do it with your name server in the first field and compare.
0
 
LVL 32

Expert Comment

by:aleghart
ID: 34956571
When you leave it blank, it uses MenAndMice's DNS serverby default (dns1.menandmice.com)
0
 
LVL 1

Author Comment

by:parimp
ID: 34956632
I see that the second one has come up as refused

; <<>> DiG 9.2.3 <<>> @202.27.184.3 pierson.net.nz A
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25277
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
;; QUESTION SECTION:
;pierson.net.nz. IN A
;; ANSWER SECTION:
pierson.net.nz.       28800       IN       A 174.129.25.161      
;; Query time: 168 msec
;; SERVER: 202.27.184.3#53(202.27.184.3)
;; WHEN: Tue Feb 22 23:01:35 2011
;; MSG SIZE rcvd: 48


; <<>> DiG 9.2.3 <<>> @203.97.33.1 pierson.net.nz A
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 27084
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; QUESTION SECTION:
;pierson.net.nz. IN A
;; Query time: 153 msec
;; SERVER: 203.97.33.1#53(203.97.33.1)
;; WHEN: Tue Feb 22 23:07:44 2011
;; MSG SIZE rcvd: 32
0
 
LVL 1

Author Comment

by:parimp
ID: 34956649
Our internet connection is also on the clear.net.nz - we use 203.97.33.1 and our servers address as the DNS servers for the clients. These are provided through DHCP on our server
Any ideas how to resolve the problem now?
0
 
LVL 32

Expert Comment

by:aleghart
ID: 34956653
First one seems to be pointing to Google's mail servers.  What's the second one?

And, more importantly, what is your mail server using?
0
 
LVL 1

Author Comment

by:parimp
ID: 34956742
The second one is using clear.net.nz which is the DNS server that we use on our network along with our own servers DNS.How would you like me to check what DNS the mail server is using, is this just the DNS results using ipconfig/all? If not, please tell me what you would like me to do.
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 
LVL 32

Expert Comment

by:aleghart
ID: 34956804
Is the mail server in-house or out-of-house?  If it's in-house, I would assume that it's using the same name servers as everything else (but not always).

Did you answer about whether you were sending through the ISP's SMTP relay?
0
 
LVL 1

Author Comment

by:parimp
ID: 34956844
It is an inhouse SBS2003 Exchange Server - I just checked the servers network card and it is using the 203.97.33.1 and the servers IP as the DNS options, same as the options the clients get.

We are using our own server for SMTP

Hope that helps
0
 
LVL 32

Expert Comment

by:aleghart
ID: 34956990
can you send a test message to invalid@domain.tld ... get a bounce message, or at least watch the Exchange server connecting?  See if it's talking to the new server or the old.
0
 
LVL 1

Author Comment

by:parimp
ID: 34957172
Your message did not reach some or all of the intended recipients.

      Subject:      
      Sent:      23/02/11 1:50 p.m.

The following recipient(s) cannot be reached:

      invalid@domain.tld on 23/02/11 1:44 p.m.
            No route was found for the recipient server.  Please contact your system administrator.
            <smtp3.clear.net.nz (tcp-daemon) #5.4.4>
0
 
LVL 32

Expert Comment

by:aleghart
ID: 34957228
So your Exchange server is using an old MX(DNS) record?  Is ClearNet the old mail host?
0
 
LVL 1

Author Comment

by:parimp
ID: 34957275
Hi, yes it appears to be using an old record, and yes the clear.net.nz is the old host.
I cant find a place to change this.
0
 
LVL 32

Accepted Solution

by:
aleghart earned 250 total points
ID: 34957364
SBS has its own DNS server (and cache).  Try clearing that first.  I'm not on 2003 any more, but should be here:

Start > Administrative Tools > DNS

Navigate the hierarchy on the left side:
 DNS > [SBS server]

Right-click the server.  Clear cache.

0
 
LVL 1

Author Closing Comment

by:parimp
ID: 34957493
Thanks for your help!
0
 
LVL 32

Expert Comment

by:aleghart
ID: 34957514
Did it work?
0
 
LVL 1

Author Comment

by:parimp
ID: 34957542
Well yes and no, I think I have narrowed the real issue down to a problem with his ISP and that its cache is not updated, but during this process I have reconfigured our DHCP server to just use the local DNS server and not the external one as a secondary which appears to be working more efficiently now.

This is the results of the MX Record Search, which show the MX records should be google, however when I do message tracking on Exchange it says "Message transferred to smtp5.clear.net.nz through SMTP"

The above is what still has me confused as he cannot recieve mail that I am sending to him unless he uses his old settings.

; <<>> DiG 9.2.3 <<>> @dns1.menandmice.com pierson.net.nz MX
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 35905
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 2, ADDITIONAL: 0
;; QUESTION SECTION:
;pierson.net.nz. IN MX
;; ANSWER SECTION:
pierson.net.nz.       15720       IN       MX 10 ASPMX.L.GOOGLE.COM.      
pierson.net.nz.       15720       IN       MX 10 ALT1.ASPMX.L.GOOGLE.COM.      
pierson.net.nz.       15720       IN       MX 10 ALT2.ASPMX.L.GOOGLE.COM.      
;; AUTHORITY SECTION:
pierson.net.nz.       72710       IN       NS ns2.freeparking.co.nz.      
pierson.net.nz.       72710       IN       NS ns.freeparking.co.nz.      
;; Query time: 212 msec
;; SERVER: 217.151.171.7#53(dns1.menandmice.com)
;; WHEN: Wed Feb 23 02:33:45 2011
;; MSG SIZE rcvd: 158


I do feel that you did answer my questions through our discussion and therefore the points are justified.
If you would like to discuss further I am happy to provide you with any info you need.

0
 
LVL 1

Author Comment

by:parimp
ID: 34957560
Just had a thought, our firewall guy enabled Smarthost on our Exchange server which I believe uses smtp.clear.net.nz - could this be affecting it?
0
 
LVL 1

Author Comment

by:parimp
ID: 34957608
On the default SMTPConnector I changed to the setting, "use DNS to route each address space on this connector" and now the mail is routing correctly through his gmail servers, so I guess there must be an issue on their DNS.
0
 
LVL 32

Expert Comment

by:aleghart
ID: 34957889
Most likely a caching issue.  TTL values are supposed to be honored.  Sometimes a configuration will use a longer value, so will be behind until the cache is cleared, or until the DNS server expires the entry.

This was a perpetual problem with AOL user who complained about sites not found even days after DNS propagation should have occured.

Could also have been a very long TTL value before the last round of DNS changes...set for days instead of hours or minutes.

In any case, as you've seen, if it's somebody elae's DNS server problem, it's easiest to just stop using their server.

Good job.
0

Featured Post

Don't lose your head updating email signatures!

Do your end users still have the wrong email signature? Do email signature updates bore you or fill you with a sense of dread? You can make this a whole lot easier on yourself by trusting an Exclaimer email signature management solution. Over 50 million users do...so should you!

Join & Write a Comment

Suggested Solutions

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
how to add IIS SMTP to handle application/Scanner relays into office 365.

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now