Cisco Valet, Sonicwall GVC performance degradation - dropped connections

I have a home office trying to VPN pass-through to a Sonicwall router at company HQ.  The user (my wife) then Remote Desktops to her system at the office.

She can connect with Sonicwall, and even connect with MSTSC, but she regularly will lose the connection.  It has been incredibly frustrating.

We have upgraded the desktop from Vista to Win7.

We've upgraded the Sonicwall from 4.2.6 to 4.6.4.

I've removed the Cisco Valet router from the home setup - and direct connected to the cable modem.  Wow - that works great, but now no one in the house can connect!
This seems to point to the Cisco Router as having problems.

I'm happy to provide more information to anyone interested in helping out.

I'm wondering if I need to configure some items on the Router to force TCP hold or something like that.

Thanks.
birchtree123Asked:
Who is Participating?
 
digitapConnect With a Mentor Commented:
OK...your subnets are the same and you need to change one of them.  i'd suggest changing the cisco unit as it would be easier than changing the sonicwall unit.  of course, if you decide to change the sonicwall unit, check out this KB i wrote for doing that.


http://www.experts-exchange.com/viewArticle.jsp?articleID=4160
0
 
digitapCommented:
on the sonicwall, go to vpn > advanced.  is Enable NAT Traversal enabled?
0
 
digitapCommented:
if not, enable it and try the connection again.
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
birchtree123Author Commented:
On Sonicwall router at HQ - NAT Traversal is set to YES.  Keep alive set ot 240s.

On another note:  I've disconnected the home Cisco router, plugging directly into the home cable modem.  When I do that, things go swimmingly.  Are there some specific setting on the home router (a Cisco Valet (read Linksys))?  I've used it pretty much out of the box -- so haven't messed around with port forwarding and the such...
0
 
digitapCommented:
typically, making sure NAT traversal is the only thing to enable when behind a NAT'ing device.  is the private subnet provided by the cisco the same as the subnet provided to GVC hosts?  this would certainly cause issues.

if the connection is being dropped by the cisco, there's a possibility that you're cisco is dropping packets.  this can be caused by a misconfigured speed/duplex config on the WAN of the cisco or by a misconfigured MTU on the cisco.
0
 
birchtree123Author Commented:
HQ Sonicwall network ranges use 192.168.1.x

Home Cisco Valet network ranger use 192.168.1.x

Can be confusing sometimes :)  I'll load IE,  go to 192.168.1.1 to administer the Cisco router (forgetting I've VPN'ed in) and up pops the Sonicwall Admin login screen.

I'll work on this more this evening. Will return with more data by tomorrow.  Fun stuff...
0
 
digitapCommented:
and, yes, it can get confusing.
0
 
birchtree123Author Commented:
Simple change - big results.  She has been logged on for over an hour - happily typing away and exercising the connection.  No drops, no real slowness - pretty much the way it is supposed to be.

I've set my IP range on the home Cisco Valet to be 192.169.1.x

The Sonicwall IP range remains at 192.168.1.x

That seems to have been the trick.  If only I had known this before the Vista upgrade, Router upgrade, Sonicwall GVC upgrade, blah, blah, blah.  As you can tell -- I sure am happy this is finally wrapped. (knock on wood).

Thanks again digitap.

0
 
birchtree123Author Commented:
Simple solution  - the best type.
0
 
digitapCommented:
thanks for the points!  please remember to vote for my article if you found it useful...unless you already did, of course.

http://www.experts-exchange.com/viewArticle.jsp?articleID=4160
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.