[Last Call] Learn how to a build a cloud-first strategyRegister Now


Characters Repeat When Working with VMware Guest OS From vSphere Console

Posted on 2011-02-22
Medium Priority
Last Modified: 2012-05-11
When I connect to my ESX 4.0 server using VMware vSphere Client 4.0.0 I cannot work with any of my VMs using the console tab because the characters I am typing repeat.  The repeating prevents me from logging on because I have very complex passwords. I do have one server with a very basic password and can logon to it.  When I do I can open Notepad and type and see the characters repeating there.

I have been trying to solve this problem for months now - 500 points is the max that EE allows or I would make it more.  The below fix from VMware suggest this is a bandwidth issue - I have a gigabit network so that is not likely.

This KB article from VMware was of no help and did not solve the problem:


Here are the details from the KB:

Repeated Characters when Typing in Remote Console

When I type into the remote console, I see unintended repeated characters. What is wrong?

If you are using a wide-area or low-bandwidth connection, the time delay over the network may be long enough to cause the virtual machine to start auto-repeat.

To reduce these effects, increase the time threshold necessary for auto-repeat in the remote console.
Power off the virtual machine.

Add a line, similar to the following, at the end of your virtual machine's configuration (.vmx) file.

keyboard.typematicMinDelay = "2000000"

The delay is specified in micro-seconds, so the line in the example above increases the repeat time to 2 seconds. This should ensure that you never get auto-repeat unless you intend it.

Power on the virtual machine.
Question by:dmcoop
LVL 29

Expert Comment

ID: 34956587

Is definitely sounds like bandwidth to me also. Not what you want to hear. Have you checked the speed and duplex settings for the uplinks (physical NICs) connecting your ESX host to the network? You should be able to check the speed and duplex that they are currently running at via "vicfg-nics".

Did you implement the parameter as per the VMKB?
LVL 124
ID: 34956652
Is VMware Tools installed?

You are not using the vSphere client through Citrix, Terminal Services or RDP?

Author Comment

ID: 34956837
mass2612: I have ten NICs on this ESX server. One of which is dedicated to the ESX host (vmnic0). All ten NICs are UP, connecting at 1000Mbps, and are FULL duplex. I ran the "esxcfg-nics -l" command to get this information since I am using ESX not ESXi.  Also we use What's Up Gold to monitor this network closely for congestion - I see no signs of network congestion at all in WUG or in performance with servers.

hancocka: Yes VMware Tools is installed and running the latest version. I am running the vSphere client through RDP. Do you think that could be the problem? It would not be hard for me to test this - I can install vSphere on my workstation and see if the problem goes away.  I will give that a try and report back tomorrow. When I was on ESX 3.5 it never caused this issue. The problem started about 6 months ago when I upgraded to ESX 4.0 from 3.5.

Thank you both for your suggestions.
Put Machine Learning to Work--Protect Your Clients

Machine learning means Smarter Cybersecurity™ Solutions.
As technology continues to advance, managing and analyzing massive data sets just can’t be accomplished by humans alone. It requires huge amounts of memory and storage, as well as the high-speed power of the cloud.

LVL 124

Accepted Solution

Andrew Hancock (VMware vExpert / EE MVE^2) earned 2000 total points
ID: 34956888
Yes, it's definately the issue.

We tried to install the vSphere Client for Administrators using RDP and Citrix, to save installing on everyones admin workstations, cut's down the rollout, every time VMware change the client.

But unfortunately everything works, but the console, mouse and keyboard is unreliable.

It's something to do with the console not be able to track key presses and mouse movements.

We've always had issues back to 3.0.

Try a local install of vSphere client on workstation.
LVL 28

Expert Comment

ID: 34957016
I too have had various issues with using the client over rdp, for the fix you are trying add


no quotes around the number, no spaces around = sign - and make sure it is the very last line (at the end) of the .vmx file.

Author Comment

ID: 34963145
hanccocka: Works perfectly when I am running vSphere local on my workstation.  Problem solved.  Thank you.  Hope they work that out eventually.

bgoering: I tried without the spaces and the quotes and it sill had the same issue.  Thank you for trying.

Author Closing Comment

ID: 34963149
Running the vSphere client on a local workstation (vs RDP) solved the problem.

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If we need to check who deleted a Virtual Machine from our vCenter. Looking this task in logs can be painful and spend lot of time, so the best way to check this is in the vCenter DB. Just connect to vCenter DB(default DB should be VCDB and using…
If your vDisk VHD file gets deleted from the image store accidentally or on purpose, you won't be able to remove the vDisk from the PVS console. There is a known workaround that is solid.
Teach the user how to use configure the vCenter Server storage filters Open vSphere Web Client:  Navigate to vCenter Server Advanced Settings: Add the four vCenter Server storage filters: Review the advanced settings: Modify the values of the four v…
This course is ideal for IT System Administrators working with VMware vSphere and its associated products in their company infrastructure. This course teaches you how to install and maintain this virtualization technology to store data, prevent vuln…
Suggested Courses

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question