• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2678
  • Last Modified:

Exchange 2010 Install problem

I am installing Exchange 2010 for the first time on a new domain (testing for a roll-out in 6 months).  I have run all of the prerequisite scripts, however am coming up with the following errors:
Summary: 4 item(s). 1 succeeded, 3 failed.
Elapsed time: 00:00:32


Languages Prerequisites
Completed

Elapsed Time: 00:00:12


Hub Transport Role Prerequisites
Failed

Error:
Setup encountered a problem while validating the state of Active Directory: Active Directory server DC-NAME.DOMAIN.TLDN is not available. Error message: A local error occurred.

Error:
Setup cannot continue because one or more SMTP/Send connectors have invalid settings: Active Directory server DC-NAME.DOMAIN.TLDN is not available. Error message: A local error occurred.

Elapsed Time: 00:00:07


Client Access Role Prerequisites
Failed

Error:
Setup encountered a problem while validating the state of Active Directory: Active Directory server DC-NAME.DOMAIN.TLDN is not available. Error message: A local error occurred.

Error:
The start mode for the Net.Tcp Port Sharing service must be set to Automatic before Setup can continue.

Elapsed Time: 00:00:06


Mailbox Role Prerequisites
Failed

Error:
Setup encountered a problem while validating the state of Active Directory: Active Directory server DC-NAME.DOMAIN.TLDN is not available. Error message: A local error occurred.

Elapsed Time: 00:00:06

I have double- and triple-checked all the steps in installing...  anyone run into this before?
0
brianpettyjohn
Asked:
brianpettyjohn
  • 6
  • 2
  • 2
1 Solution
 
brianpettyjohnAuthor Commented:
And I have checked to make sure the DC is running and reachable from the server to which I am attempting to install exchange.
0
 
pitchfordCommented:
Check your DNS settings. AD relies heavily on DNS. Make sure you can ping DOMAIN.TLDN as well as DC-NAME.DOMAIN.TLDN. Is your Exchange box also a domain controller?

I guess I should also step back and as, is the Exchange server a member of the domain? =) I'm going to assume it is.

If your DNS is good check this out:

It is caused by stored username/passwords (probably from browser sessions) that cause .NET's RPC interfaces to fail and has nothing to do with DNS.  Here is how to fix it without deleting admin profiles etc.

1. Click Start, click Run, type "control keymgr.dll" , and the click OK.
2. Delete any entry that matches the names of the Exchange servers or domain controllers in your organization.

If in doubt clear all entries present.


Best of luck!
0
 
brianpettyjohnAuthor Commented:
Yes, I can ping DOMAIN.TLDN as well as DC-NAME-DOMAIN.TLDN.  

I went through and checked cached credentials, still no-go.  Good tips, though.  Never thought of the keymgr
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
pitchfordCommented:
Check your FISMO roles. I'd have to assume that you have only 1 DC and it is the master for all 5.

Foregive me, I don't know your expertise with AD but if you need help: http://en.wikipedia.org/wiki/Active_Directory
0
 
brianpettyjohnAuthor Commented:
Checked all the roles.  Yes, I have only the 1 DC, it holds all the roles.  setup/ps completed successfully.  

One thing I am going to try is this:  These machines (VMs) were once a part of another domain (the template).  On the exchange server, I changed the machine from domain 1 to domain 2 (directly).  I am going to try and disjoin from domain 1, change to workgroup, then add to domain 2.  Will try in the morning.  Thank you for your help, I'll let you know the results.
0
 
MegaNuk3Commented:
"The start mode for the Net.Tcp Port Sharing service must be set to Automatic" is it?
Reboot the server, after setting the above to automatic and try the install again.
0
 
brianpettyjohnAuthor Commented:
I saw the "The start mode for the Net.Tcp Port Sharing service must be set to Automatic"  message, changed the setting, rebooted, and it still failed (although that particular message didn't show up again).  Am beginning to work on this issue again this morning, by removing from the domain and re-adding.  Will post results shortly.
0
 
brianpettyjohnAuthor Commented:
Solved it.  I removed the new exchange server from the domain, and into a workgroup.  Rebooted.  Changed back to the new domain.  Rebooted.  Was then able to successfully install exchange from that point.

Thank you for all your help!
0
 
MegaNuk3Commented:
Thanks for the solution
0
 
brianpettyjohnAuthor Commented:
Began disecting the error messages.  Although the DC was reachable from the exchange computer, there seemed to be aproblem in AD reconciliation.  Therefore, i backed out of the domain and went back in.  SUCCESS!
0

Featured Post

Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

  • 6
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now