Solved

Terminal Services home Profile not mapping

Posted on 2011-02-23
4
760 Views
Last Modified: 2012-06-27
I have some users that when they log onto a terminal server their Terminal Services Home Folder is not mapping.

Its Windows Server 2003 (with AD installed). Users AD account is setup as follws:
Terminal Services Profile
Terminal Services Gome Folder
H:
\\server\Shares\Userdata\%username%

Once the above is entered %username% is replace by the users username. I checked the share and the new folder has been created and the user has Full Control.

When I log in as the user they get no H:. This is massive problems as thje application on that terminal server references files on the uesrs H: and if not mapped no application.

Any ideas?

Thanks
Mark
0
Comment
Question by:Mark Galvin
  • 3
4 Comments
 
LVL 11

Accepted Solution

by:
Tasmant earned 500 total points
ID: 34960003
Have you looked your events to see if you have errors?
You could too use a GPO on your TSE server with loopback processing mode on and assign a logon script which map a network drive to H:  (net use h: \\server\share\%username%)
it's a spare way to map the network drive.
0
 
LVL 13

Author Comment

by:Mark Galvin
ID: 34960113
HI

Nothing in the EVENT LOGS for this.

We use KIX in our main site for all mapped drives. I didnt want to use that in this site. I wanted AD to do it, as its just one drive.

I will go down route of scripts.

Thanks
Mark
0
 
LVL 13

Author Comment

by:Mark Galvin
ID: 34960226
OK so did that and the script maps the drive:

"C:\Documents and Settings\usert>net use h: \\-server\shares\userda
ta\user
The command completed successfully.


C:\Documents and Settings\user>pause
Press any key to continue . . ." - I put a pause into the BAT file so I could see results.

However, the application still isnt working. So checked My Computer. The drive is there buts its in a Disconnected state. There is a red X on the drive icon. When I click on the drive it opens without error and the application then works.

I dont want use to have to this (its an easy step but not for this user!!).

Any ideas?

Thanks
Mark
0
 
LVL 13

Author Comment

by:Mark Galvin
ID: 34960285
Hi

Now working. Script is:
"net use H: /delete
net use H: \\-server\shares\userdata\%username%".

Thanks for help. Points on the way!!

Mark
0

Join & Write a Comment

Check out this infographic on what you need to make a good email signature that will work perfectly for your organization.
Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles from a Windows Server 2008 domain controller to a Windows Server 2012 domain controlle…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now