Solved

Cannot RDP into Windows 7 PC on SBS 2003 network

Posted on 2011-02-23
9
1,203 Views
Last Modified: 2012-06-22
Hi Experts,

I have a Windows 7 PC running on a SBS 2003 network.    It is the first machine with Windows 7 which I have added to SBS 2003.   All seemed to be working okay until we tried to connect remotely to the desktop through the Remote Web Workplace.   I assumed something in the firewall was blocking the connection so I went to check and found 2 red crosses over the remote desktop inbound connection.   The problem is that the system won't allow me to alter either rule.   it seems to think that there is a group policy in place which is overriding the local settings. RDP errror
However, I have been through the Group Policy in detail and cannot find anywhere where I might be blocking this and RDP via Remote Web Workplace is working fine for all the Windows XP Pro machines.

Thnaks in advance
Jon
0
Comment
Question by:JonYen
  • 5
  • 2
  • 2
9 Comments
 
LVL 11

Expert Comment

by:Old User
ID: 34959969
Windows 7 has two methods of modifying the firewall settings, the basic one through control panel and advanced through mmc.

open gpedit.msc on the windows 7 PC and see if you can modify the setting there
0
 

Author Comment

by:JonYen
ID: 34960007
thanks dpreston - i'm not hugely familiar with the workings of group policy so could you point me exactly (or even roughly) where to look?
0
 
LVL 11

Expert Comment

by:Old User
ID: 34960078
Expand Administrative Templates, Network, Network Connections, then Windows Firewall

From there you should be able to find it, i am not near a windows 7 pc at the moment so can't be more specific. When i get to one if you haven' t found it i will post again.
0
U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

 
LVL 7

Expert Comment

by:Boilermaker85
ID: 34972034
doreston68 is correct in the path to the Firewall GP setting for RDP. Under Windows Firewall, there are two profiles (Domain and Standard). Under there, the setting is "Windows Firewall: Allow Inbound Remote Desktop exceptions. But you have to specify what IPs can access this PC when you enable this setting.
0
 
LVL 11

Expert Comment

by:Old User
ID: 34973957
Boilermaker is also correct but you can enter * to allow RDP connections from any IP

Have you managed to change the setting?
0
 

Author Comment

by:JonYen
ID: 34974905
Hi - Yes I have managed to change the setting both in the domain and standard profile but I still can't connect via remote desktop (either through the remote web workplace or using another PC on the LAN).   It's bizarre because when I take a look at the advanced firewall settings there are 4 remote desktop settings - and both the inbound connections are enabled.  there is also no other form of firewall on the machine and I can accept incoming remote desktop connections through the router


SnipImage.JPG
0
 
LVL 11

Expert Comment

by:Old User
ID: 34975111
Remote Web Workplace uses TCP port 4125 for its remote desktop feature, you need to open this port on your firewall
0
 
LVL 11

Accepted Solution

by:
Old User earned 500 total points
ID: 34975117
0
 
LVL 7

Expert Comment

by:Boilermaker85
ID: 34979422
Looking at your screen print, it appears that there are 2 manually created Block Rules for Domain and Private networks on port 3389 (RDP). Immediately following these block rules are the built in Remote desktop rules again for Domain and Private, allowing ANY for inbound port 3389.But rules are processed in order and the Block Rules are probably geting met first.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

By default the complete memory dump option is disabled in windows . If we want to enable the complete memory dump for a diagnostic purpose, we have a solution for it. here we are using the registry method to enable this.
In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This Micro Tutorial will go in depth within Systems and Security in Windows 7 and will go into detail regarding Action Center, Windows Firewall, System, etc. This will be demonstrated using Windows 7 operating system.

679 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question