.net framework 4

Over time my xp sp3 computers have the following .net framework versions installed on them by various methods (other software, MSI, WSUS):
1.1
2.0 sp2
3.0 sp2
3.5 sp1
4

This all seems a bit crazy, can I get rid of some of these, or will software stop working if I do? Doesn't version 4 (client profile and extended) include everything?

LVL 1
PeteAsked:
Who is Participating?
 
*** Hopeleonie ***IT ManagerCommented:
Hi

when you install .net framework 3,5 it will still install all older versions. That means still all are neaded. I would not uninstall any of them. Yes some software may stop but maybe the software is having an update to work with  .net framework 4.
0
 
Carl TawnSystems and Integration DeveloperCommented:
If you have an application installed that needs a particular version then you need to keep that version installed. It would be safest just to leave them, otherwise you are liable to break an application.
0
 
John ClaesSenior .Net Consultant & Technical AnalistCommented:
PetBen030 :

.Net Framework exists out of the folowing versions :

 .Net Versions
Version 1.0 and 1.1 are Made First and were a entirly new framework.

Starting again at a new version 2.0 Microsft decided to seperate the to frameworks so they could stay both installed.

so now we have 2 seperate installations (1.1 and 2.0)

Then we got 3.0, 3.5 and 4.0 that are build UPON the previous version and using that version.
so 3.0 is an extention above 2.0
so 3.5 is an extention above 3.0
so 4.0 is an extention above 3.5
 The .NET Framework stack.
So
If you have app's still working under .Net 1.1 ? then you must keep that else It's absolete

So
If you have app's working under 2.0, 3.0, 3.5 OR 4.0 then you must keep all those versions

regards

poor beggar
0
 
PeteAuthor Commented:
Thanks for the replies, so to clarify. I need to keep previous versions on exsisting machines and I even need to install all previous versions on new machines.
0
 
Carl TawnSystems and Integration DeveloperCommented:
Well, you only actually need to keep the older versions if you have anything that needs them, the difficult part is identifying which app needs which version.

You should only need 3.5 (which will install 2.0 anyway) and possibly 4.0 on newer machines. Although most apps that need a version of the framework should add it themselves as part of the installation process.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.