Jquery easing function / hover effect issue

I cannot figure out why the hover on the "kmac" is working on my old site, but not on the new site I am currently building.  Please take a look and let me know:

www.k-mac.ca  (This one is working)

www.k-mac.ca/Test  (this one is not)

I don't know what I'm missing...any help would be great, thanks!

Please note I asked this yesterday and thought the problem was because a tag wasn't closed in the HTML.  But this problem has poped up again...and the HTML Validates so I don't know what it could be.
leena42Asked:
Who is Participating?
 
Chad HaneyChief Technology OfficerCommented:
Looks like the jquery is actually not properly written in the RollOverEffect.js.   Not sure why it was working in the first place.  


Try this code, I got it to work running it on your page, when I couldn't get your current version to work.
$('#M a').css('backgroundPosition', '0px 0px')
	.hover(function(){
		$(this).stop().animate({
			backgroundPosition:'-326px 0px'
		}, 300);
	},function(){
		$(this).stop().animate({
			backgroundPosition:'0px 0px'
		}, 300, function(){
			$(this).css('backgroundPosition', '0px 0px');
		});
	});

Open in new window

0
 
Shinesh PremrajanEngineering ManagerCommented:
Both of them are not working, in the working URL- that you gave it seems to have some image path issues.
0
 
Shinesh PremrajanEngineering ManagerCommented:
reset.css
text.css
960.css
default.css
are missing in the server.Similarly there are couple of images that are missing.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.