Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Unable to launch applications through xenapp 6 web interface

Posted on 2011-02-23
11
Medium Priority
?
1,246 Views
Last Modified: 2013-11-21
Hi

I've just recently built a xenapp 6 farm consisting of 4 xenapp servers.
I connect via CSG server. I can connect to the WI and log in successfully but when I launch an app, it give me an error stating that it was unable to connect to the xenapp server.
if I re-install my client, it then works but if I reboot my machine, it dont work again and I need to reinstall again.
my current citrix environment is totally separate and runs on PS 4.5. I also connect via a CSG to this environment and it works fine.
I've picked up this problem on another machine and am getting worried that it may affect more people later on.
the weird thing though is that my colleagues, about 5 of them sitting next to me, do not have this problem.

Any ideas ?

Regards
Brad
0
Comment
Question by:ablsysadmin
  • 5
  • 2
  • 2
11 Comments
 
LVL 19

Expert Comment

by:basraj
ID: 34960830
Is it specific to machine or users? Did you try with a different client version and different web browser?
0
 

Author Comment

by:ablsysadmin
ID: 34967760
Hi Bas

I've tried with different versions (v11 and v12) on IE and Firefox, both dont work.
only thing that works is to re-install the client and it works until the laptop is rebooted.

0
 
LVL 19

Expert Comment

by:basraj
ID: 34967904
did you try from a different machine?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:ablsysadmin
ID: 34967935
yes, its works from other machines.
there are 5 other guys sitting next to me, all of their machines work, same client, same o/s.
myself and another user (I'm using win7 and she is using winXP) seem to be having this problem.
and she is the only other person I know of. I havent tested with anybody else to see how many people are being affected
0
 

Author Comment

by:ablsysadmin
ID: 34968052
what I've also picked up is that the PNAgent loads the apps on my local machine but they also dont launch. only after a re-install will they launch
0
 
LVL 6

Expert Comment

by:Melannk24
ID: 35121888
You state that others don't have the same issue, but are they running the same machine image as you?  When you re-install the client, are you running in admin approval mode, do you have UAC enabled?  

Be aware that Citix and Microsoft just released a list of recommended hotfixes to address a range of issues with Xenapp6 and Microsoft operating systems.  Please see Citrix's article, maybe it could help you out.  http://forums.citrix.com/thread.jspa?threadID=282924

I have always had issues with UAC even with Microsoft's own products!  So, I thought that may be a good place to initially explore if it applies to you.
0
 

Author Comment

by:ablsysadmin
ID: 35126960
Hi

I am a local admin on my laptop and on the domain so I am running in admin mode when installing.
UAC is set to never Notify.
I had a look at the article you provided and already have most of those hotfixes installed.

a little more background here, I have 2 separate citrix environments.
my old environment works fine. from my machine, I can launch apps even after a reboot of my laptop.
on the new environment, apps dont launch after I reboot my laptop.
there are now 3 different people I know of that are being affected by this and about 7 others that are not. there are no all O/S levels and clients levels are different across all the machines.

because of the above findings, I believe the problem is on the server side.
and for some reason, I cant find any solutions on the net.

Regards
0
 
LVL 6

Accepted Solution

by:
Melannk24 earned 2000 total points
ID: 35129301
This may be a bit difficult to diagnose, especially since you state that the images and clients are not uniform.  So, there is no base to start from to try to pinpoint an anomaly.   Okay, so let's backup a bit, is the new server farm a complete upgrade from the old, meaning all the apps are new, upgraded, etc?  Your old environment works fine, so I am just trying to get a comparison from one side to the other.  If the connection is good upon initial install, I wonder if there is a negotiation issue between the client and the server, something is getting dropped between the two??  I find that in these issues, it's something so little that I want to kick myself later for not recognizing it right off!  :-)  I'll keep thinking about it and see if I get any other ideas....
0
 

Author Comment

by:ablsysadmin
ID: 35137219
Hi

I'm now really confused and frustrated with this issue.
my machine since yesterday evening has started working correctly.
I've rebooted a couple of times and it still works.
I did not change anything on my machine.
I've tested with another user that was experiencing the problem and it still dont work.
I'm going to start pulling out my hair now.

0

Featured Post

Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Last article we focus in how to VMware: How to create and use VMs TAGs – Part 1 so before follow this article and perform the next tasks, you should read the first article how to create the TAG before using them in Veeam Backup Jobs.
Eseutil Hard Recovery is part of exchange tool and ensures Exchange mailbox data recovery when mailbox gets corrupt due to some problem on Exchange server.
In this video tutorial I show you the main steps to install and configure  a VMware ESXi6.0 server. The video has my comments as text on the screen and you can pause anytime when needed. Hope this will be helpful. Verify that your hardware and BIO…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Suggested Courses

972 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question