(Not) Opening a Subreport

I have a subreport on my main report that is intended to display a single field.  When the user views the report, a link "finger" appears when the user mouses over the subreport/field.  If the user then clicks the link, the subreport appears.

How do I stop this from happening?

The viewer in question is part of a third party (Spectrum Construction Software) application.
LVL 10
ClifAsked:
Who is Participating?
 
mlmccConnect With a Mentor Commented:
Try this idea

Add a textbox to the report.
SIze it to be slightly largeer than the subreport image
Put it over the subreport
Right click the textbox
Click FORMAT TEXTBOX
On the COMMON TAB
Click READONLY
Click LOCK SIZE AND POSITION

The textbox will "hide" the subreport from being clicked but allow the data to show.
y making it readonly and locking the user can click on it but nothing happens

mlmcc
0
 
peter57rCommented:
is the report set as an on-demand subreport (although that doesn't sound like the correct pointer for it)?
0
 
ClifAuthor Commented:
No.  The "On Demand" box is unchecked.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
mlmccCommented:
Does it display the number correctly?

Subreports can be drilled into in the manner you are describing.

mlmcc
0
 
ClifAuthor Commented:
Well, there is no number/value to display, which it doesn't display, so I guess you could say it's correct.

The point is that I don't want the user to drill down.  The subreport is a single field with a single value (per main report) on the main report.  I want the subreport to be displayed just like the main report field next to it.  That is, not allow the user to click on it to bring up the subreport.
0
 
peter57rCommented:
What is is that you can see to click  then?
0
 
ClifAuthor Commented:
peter57r:
What is is that you can see to click  then?
The area where the subreport is located.  Just because it's blank (no data) doesn't mean it doesn't exist.
0
 
ClifAuthor Commented:
That did it.

Thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.