Solved

Time moved backwards error HELP on my server help?

Posted on 2011-02-23
11
548 Views
Last Modified: 2012-06-21
dovecot: Fatal: Time just moved backwards by 6 seconds. This might cause a lot of problems, so I'll just kill myself now. http://wiki.dovecot.org/TimeMovedBackwards: 1 Time(s)

I received the above so I went to the link to find out how to fix it.
The thing I don't undstand is ntpdate periodically.
How do I know if I am running it and how can I change it?


Time moved backwards error

Dovecot isn't very forgiving if your system's time moves backwards. There are usually two possibilities why it's moving backwards:

   1.

      You're running ntpdate periodically. This isn't a g
ood idea
0
Comment
Question by:sobeservices2
  • 4
  • 4
  • 2
  • +1
11 Comments
 
LVL 6

Accepted Solution

by:
t-max earned 375 total points
ID: 34961908
Hi,
You can try something like "chkconfig --list | grep ntp" to see if you have it activated on boot.
Also this "ps aux | grep ntp" will say if there's any process related to ntp running on the system.

My guess is that you don't have it configured. You should use a ntp server to have the time synchronized across different servers and storage. Check "Time synchronization" in the link you provided for more help on that.
0
 
LVL 9

Assisted Solution

by:meko72
meko72 earned 125 total points
ID: 34961936
Here is a command line for ntpdate.  http://www.go2linux.org/ntpdate-linux-command-line

Here is a cron job that updates 1 - 2 hours



Install as cronjob
To avoid stepping the clock you must run ntpdate every 1 or 2 hours using cronjob:

crontab -e

Now add hourly job:

#NTPDATE
@hourly /etc/network/if-up.d/ntpdate

Save and close the file.

Easy way.

RIGHT CLICK on  desktop clock and select “set date / time” there’s an option to automatically set the time, and select the ntp.ubuntu.com servers so you don’t load the pub servers.
0
 

Author Comment

by:sobeservices2
ID: 34962160
I did this and received

The below

Looks like its off how do I turn it back on
ntpd            0:off   1:off   2:off   3:off   4:off   5:off   6:off
root@server [~]#

Open in new window

root@server [~]# chkconfig --list | grep ntp
ntpd            0:off   1:off   2:off   3:off   4:off   5:off   6:off

Open in new window

0
Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

 
LVL 6

Assisted Solution

by:t-max
t-max earned 375 total points
ID: 34962263
Indeed it's off. You can start the service with "/etc/init.d/ntpd start" and enable it to be run on boot with "chkconfig ntpd on".
That's the "daemon" method. The other method is as suggested above, adding ntpdate to root's crontab.
If you give more details on what Linux distribution you have, I'll give exact instructions.
0
 

Author Comment

by:sobeservices2
ID: 34962313
what should I use

nptd

or
ntupdate

A little confused here
0
 
LVL 6

Assisted Solution

by:t-max
t-max earned 375 total points
ID: 34962379
For me, using ntpd is easier, because it's a service and you can easily start/stop it with /etc/init.d/ntpd
The other can't be managed that way, you must edit crontab to change when it's executed.
0
 
LVL 12

Expert Comment

by:mccracky
ID: 34962410
Linux doesn't really need ntpdate, but ntp.  

ntpdate is run periodically through cron like meko72 said above, but that's not really good practice for a server that will be on most all the time.  ntpdate is a one-shot update.  It sets the time to the current time all at once.

ntp, on the other hand, is a daemon that runs continually and slews the clock rate to keep the time correct all the time.  There usually aren't big jumps in time all at once.

The error would be from something jumping the clock all at once.  check cron for ntpdate or sntp and remove it.  Then set up and run ntp.
0
 

Author Comment

by:sobeservices2
ID: 34963554
Iam getting one of these what do I do

: Excessive resource usage: ntp (7326)

Time:         Wed Feb 23 13:46:00 2011 -0500
Account:      ntp
Resource:     Process Time
Exceeded:     7318 > 1800 (seconds)
Executable:   /usr/sbin/ntpd
Command Line: ntpd -u ntp:ntp -p /var/run/ntpd.pid -g
PID:          7326
Killed:       No
0
 
LVL 12

Expert Comment

by:mccracky
ID: 34963952
Are you running on bare hardware or on VMWare or other virtual environment?

If you are on VMWare, you probably want to read this:
http://kb.vmware.com/kb/1006427
0
 

Author Comment

by:sobeservices2
ID: 34964134
Nop regular
0
 
LVL 6

Expert Comment

by:t-max
ID: 35286981
Thanks!
0

Featured Post

Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question