Solved

Twitter.com will not display in browser

Posted on 2011-02-23
4
627 Views
Last Modified: 2012-05-11
This issue has been killing me.  I am working on a network where Twitter.com will not display in a web browser anywhere inside the network.  I can ping it, I can tracert to it, but I cannot view it on port 80.  This will be a long post since I've tried a lot of things and seem to have narrowed the issue a bit.

Environment:  Corporate network with a Sonicwall Pro 2040 and a Cisco router.  Router seems to be a non-issue in this case because when I plug a laptop directly into the router (same port the firewall plugs into) twitter.com works correctly.  The issue seems to be with the Sonicwall.  DNS is using Google's servers as forwarders, no strange entries there.  No AV or web filtering in effect on the LAN or WAN interfaces and nothing explicit that I can find in the Sonicwall config that would affect this.

Testing:  I tested a number of connections to Twitter.com from inside the network and outside.  Here is what I found:

Outside the network:  When I ping twitter.com and www.twitter.com, I get a random address from Twitter's block.  If I take any of those addresses and enter them in a browser, they resolve to twitter.com and the page loads.

Inside the network:  When I ping www.twitter.com, I get a random address from Twitter's block.  If I take any of those addresses and enter them in a browser, I get the generic 'cannot display the webpage' error.  However, I can ping and tracert to all of the addresses.  This makes me think the issue is with http (port 80) traffic only.  Attempting to telnet to twitter.com on port 80 seems to confirm this- it does nothing.    The odd piece is this: when I ping twitter.com, as opposed to www.twitter.com, I get the same address every time.  It's a valid Twitter address, but it does not resolve to their domain name.  If I put it in a browser, it maintains its IP address as the URL name and the site works.  This particular IP address behaves the same way outside the network- if I enter it in my browser at home, it will not resolve, it will simply display Twitter.com's website using the IP address as the URL.  

We then tried putting in a custom host entry so that a computer would use the IP address that actually works as the destination for www.twitter.com.  Putting that in the browser again resulted in 'cannot display the webpage'.  We changed the host entry to point cnn.com to the same Twitter IP address and it resolves to the Twitter site and displays it.

So my mystery at this point is this:  What could be filtering out any port 80 traffic to twitter.com (apparently based on the domain name)? Also, why do they get the same IP address every time they ping twitter.com when every other computer we test this on gets a random one?
0
Comment
Question by:Joel-LogicNet
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 33

Accepted Solution

by:
digitap earned 500 total points
ID: 34962484
try this and report back the results.

Log in to the firewall, then go to https://firewallip/diag.html,
go to  Internal Settings.
Scoll down to a checkbox labeled Enforce Host Tag Search with for CFS
uncheck it
scroll up and hit Apply
Then Close button on the bottom left.
0
 
LVL 33

Expert Comment

by:digitap
ID: 34962493
if that's the issue, here's a KB explaining it:

https://www.fuzeqna.com/sonicwallkb/consumer/kbdetail.asp?kbid=3582
0
 
LVL 1

Author Comment

by:Joel-LogicNet
ID: 34962747
Good recommendation, but that wasn't the issue.  It did point me in the right direction though- I finally found the solution in the logs with mention of IPS and IM.  After doing some reading, it turns out that IPS was enabled on the WAN and IM traffic was being blocked.  Apparently Twitter's website gets grouped into IM traffic.  It didn't stick out at me before because 1) the IP address it was blocking was not the twitter.com address that DNS was reporting (that whole twitter.com vs www.twitter.com issue) and 2) I was looking for an explicit mention of Twitter versus a group restriction.  We turned off IM filtering in the IPS settings on the Sonicwall and we're up and running.
0
 
LVL 33

Expert Comment

by:digitap
ID: 34963469
excellent! good information and thx for the pts!
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Palo Alto Networks User Account That Only Permits "show" commands? 2 52
Dedicated I.P., VPN, both, neither, or what? 12 58
IP range 6 59
DHCP Lease/Reservations 3 32
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
Configuring network clients can be a chore, especially if there are a large number of them or a lot of itinerant users.  DHCP dynamically manages this process, much to the relief of users and administrators alike!
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question