Solved

This is in AIX5.3..We are getting this error Dependent module libcrypto.a(libcrypto.so.0.9.8) could not be loaded. Member libcrypto.so.0.9.8 is not found in archive

Posted on 2011-02-23
12
3,666 Views
Last Modified: 2012-10-01
This is in AIX 5.3..we are getting this error..This is in AIX5.3..We are getting this error Dependent module libcrypto.a(libcrypto.so.0.9.8) could not be loaded. Member libcrypto.so.0.9.8 is not found in archive

with the application owner user id  when we are trying to do an ssh we are getting this error...but with other user id's I am able to do ssh..We cant change the env for that user as the application will stop working ..we  are running informatica on it..Please let me know as how this can be eliminated and ssh can be done through that user

i am tring to exchange keys with user on that server to other server..As I am not able to ssh..I am not able to exchange keys..let me know how it can be removed for that user

rpm -qa | egrep '(openssl|openssh|prng)'
openssl-0.9.6m-2
openssl-devel-0.9.7g-2
openssl-doc-0.9.7g-2
prngd-0.9.29-1
0
Comment
Question by:aixtutorial
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 6
12 Comments
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 34963179
Hi again,

this is clearly a LIBPATH problem.

I assume that the application user has a particular LIBPATH setting in their .profile (or in one of their own initialization files).

libcrypto comes with OpenSSL. Which OpenSSL implementation do you use? Which ssh implementation?

Normally libcrypto should be linked to /usr/lib from /opt/freeware/lib, but we should first try to find out where your libcrypto actually is.

Issue (as root):
find / -name "libcrypto*"
and tell us what you found.

Please don't confuse libcrypto with libcrypt - that's an AIX library!

Further, please log in as the application user and issue

echo $LIBPATH
which ssh

When logged in as root issue:

lslpp -l | grep -i ssl
lslpp -l | grep -i ssh
rpm -qa | grep -i ssh
rpm -qa | grep -i ssl


Please post the output of the above commands.

As a first check you could log in as the application user and issue

unset LIBPATH
and
ssh -V

Does it work now?

wmp
0
 

Author Comment

by:aixtutorial
ID: 34964980
Please find the below output
Could not load program ssh:
        Dependent module /informatica/PowerCenter8.6.0/server/bin/libcrypto.a(libcrypto.so.0.9.8) could not be loaded.
        Member libcrypto.so.0.9.8 is not found in archive
  and then I did
unset LIBPATH
ssh -V
OpenSSH_5.2p1, OpenSSL 0.9.8k 25 Mar 2009


and after  that I ran the commands


# lslpp -l | grep -i ssl
  gskjs.rte                 7.0.3.18  COMMITTED  AIX Certificate and SSL Java
  gskjt.rte                 7.0.3.18  COMMITTED  AIX Certificate and SSL Java
  gsksa.rte                 7.0.4.11  COMMITTED  AIX Certificate and SSL Base
  gskta.rte                 7.0.4.11  COMMITTED  AIX Certificate and SSL Base
  openssl.base            0.9.8.1102  COMMITTED  Open Secure Socket Layer
  openssl.license         0.9.8.1102  COMMITTED  Open Secure Socket License
  openssl.man.en_US       0.9.8.1102  COMMITTED  Open Secure Socket Layer
  pware53.openssl.rte        0.9.8.8  COMMITTED  OpenSSL 0.9.8h
  openssl.base            0.9.8.1102  COMMITTED  Open Secure Socket Layer
# lslpp -l | grep -i ssh
  openssh.base.client     5.2.0.5300  COMMITTED  Open Secure Shell Commands
  openssh.base.server     5.2.0.5300  COMMITTED  Open Secure Shell Server
  openssh.license         5.2.0.5300  COMMITTED  Open Secure Shell License
  openssh.man.en_US       5.2.0.5300  COMMITTED  Open Secure Shell
  openssh.msg.en_US       5.2.0.5300  COMMITTED  Open Secure Shell Messages -
  openssh.base.client     5.2.0.5300  COMMITTED  Open Secure Shell Commands
  openssh.base.server     5.2.0.5300  COMMITTED  Open Secure Shell Server
# rpm -qa | grep -i ssh
# rpm -qa | grep -i ssl
openssl-0.9.7l-1
openssl-devel-0.9.7l-1
openssl-doc-0.9.7l-1


But the libpath is needed for my applicaton to work.please let me know as how this can be done keeping the libpath and ssh to work at the same time
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 34965473
Please log in with a userid where ssh works and issue
echo $LIBPATH
and
ldd $(which ssh)

Now log in as the application user (where it doesn't work) and issue
echo $LIBPATH

Please post the output of all the commands above!




0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 

Author Comment

by:aixtutorial
ID: 34965722

echo $LIBPATH /informatica/PowerCenter8.6.0/server/bin:/usr/java5_64/jre/bin:/usr/java5_64/jre/bin/classic:/usr/lib:/lib:/u00/app/oracle/lib:/u00/app/oracle/lib32:.

ssh

Could not load program ssh:
        Dependent module /informatica/PowerCenter8.6.0/server/bin/libcrypto.a(libcrypto.so.0.9.8) could not be loaded.
        File /informatica/PowerCenter8.6.0/server/bin/libcrypto.a is not an
          archive or the file could not be read properly.


ldd $(which ssh)

/usr/bin/ssh needs:
         /usr/lib/libc.a(shr.o)
         /informatica/PowerCenter8.6.0/server/bin/libcrypto.a(libcrypto.so.0.9.8)
ar: 0707-108 File /informatica/PowerCenter8.6.0/server/bin/libcrypto.a is not an archive file.
dump: /tmp/tmpdir401560/extract/libcrypto.so.0.9.8: 0654-106 Cannot open the specified file.
         /informatica/PowerCenter8.6.0/server/bin/libz.a(libz.so.1)
ar: 0707-108 File /informatica/PowerCenter8.6.0/server/bin/libz.a is not an archive file.
dump: /tmp/tmpdir401560/extract/libz.so.1: 0654-106 Cannot open the specified file.
         /unix
         /usr/lib/libcrypt.a(shr.o)





for the other user with which I am able to do ssh has this




didnt gave any output as libpath is not set for that user


echo $LIBPATH

and

ldd $(which ssh)

/usr/bin/ssh needs:
         /usr/lib/libc.a(shr.o)
         /usr/lib/libcrypto.a(libcrypto.so.0.9.8)
         /usr/lib/libz.a(libz.so.1)
         /unix
         /usr/lib/libcrypt.a(shr.o)
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 34965919
Yep, I see.

I had the same problem with some other third party software (not Informatica).

I think you can't tell me if /informatica/PowerCenter8.6.0/server/bin/libcrypto.a and libz.a have really to be present (are used by Informatica)?
If you could find out that it's not needed it would make things easier! Maybe you could ask an Informatica support person?

But anyway, the only solution I found in those days was this:

Write a script, put it into a common directory and set an alias "ssh" to it!

The script:

#!/bin/ksh
export OLIBPATH=$LIBPATH
unset LIBPATH
/usr/bin/ssh "$@"
export LIBPATH=$OLIBPATH
exit


Call this script e.g. "myssh", put it into e.g. /usr/local/bin (create this directory with "mkdir -p /usr/local/bin" if it's not there), and issue
chmod +x /usr/local/bin/myssh

Now add the line

alias ssh='/user/local/bin/myssh'

to $HOME/.profile of all users whose ssh doesn't work.

Logout and login again, and you will have a working ssh.

Please note that you will have to do the same with "scp" if you use this program!

wmp

0
 

Author Comment

by:aixtutorial
ID: 34966032
wmp Thanks a lot Sir..You are the master of AIX..It worked .I wanted to know what does woolmilkproc means anyway
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 34966080
See my EE profile!
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 34966081
See my EE profile!
0
 

Author Comment

by:aixtutorial
ID: 34966365
I am now able to ssh to other server and execute commands on the remote by

ssh user@host "ls -al"

but when i am trying to do scp it throws a weird error
scp -pr test user@host:/informatica  
it gives this error
Bad port 'r'

I am getting this error  even when I am doing scp -pr  or scp -pr or directly scp test  user@host:/informatica  

0
 
LVL 68

Accepted Solution

by:
woolmilkporc earned 500 total points
ID: 34968060
OK, sorry for not having been clear enough!

What I meant to say with "do the same with scp":

Write a second script for scp and set the "scp" alias to this script!

The "scp" script "myscp":

#!/bin/ksh
export OLIBPATH=$LIBPATH
unset LIBPATH
/usr/bin/scp "$@"
export LIBPATH=$OLIBPATH
exit


Put this script "myscp" into the same /usr/local/bin directory and issue
chmod +x /usr/local/bin/myscp

Now add another line

alias scp='/user/local/bin/myscp'

to $HOME/.profile of the concerned users.

Logout and login again, to make it work.

Sorry again for the mistakable wording!

wmp
0
 

Author Comment

by:aixtutorial
ID: 34972078
Thanks,,It worked.
0
 

Author Closing Comment

by:aixtutorial
ID: 38451663
it worked
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

FreeBSD on EC2 FreeBSD (https://www.freebsd.org) is a robust Unix-like operating system that has been around for many years. FreeBSD is available on Amazon EC2 through Amazon Machine Images (AMIs) provided by FreeBSD developer and security office…
The purpose of this article is to demonstrate how we can use conditional statements using Python.
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
In a previous video, we went over how to export a DynamoDB table into Amazon S3.  In this video, we show how to load the export from S3 into a DynamoDB table.

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question