• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 580
  • Last Modified:

Shift key stops working in Visual Studio 2010 code pane

From time to time, while working in the code editor of Visual Studio 2010, the shift key stops working for certain keys. For example, Shift + . (dot) should produce a greater than symbol (>) but today it refused to recognize the shift and insisted on typing a dot. I also noticed that when I pressed the single quote (') key nothing happened until I pressed another key. Pressing a single quote again resulted in two back=quote characters (``)

It's almost as if I mistakingly hit a key combination that puts the keyboard in international language mode or something. My culture is set to en-CA.

If I switch to an other program, the keyboard works as I would expect.

Is there a keystroke combination I can use to reset the keyboard. Currently, I have to exit VS 2010 and restart to get the keyboard to behave.

Thanks.
0
ou81aswell
Asked:
ou81aswell
  • 6
  • 4
1 Solution
 
Bob LearnedCommented:
Do you have any VS.NET 2010 extensions installed?
0
 
ou81aswellAuthor Commented:
Not that I am aware of. I believe it to be a pretty stock install. How can I check?

0
 
Bob LearnedCommented:
The menu option is Tools | Extension Manager...

I have seen some extensions mess with the code window, but I haven't heard of the problem that you have described.
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
ou81aswellAuthor Commented:
Extension manager indicates that there are no extension installed.

I just noticed this behaviour in a completely separate program and so it must have something to do with Windows 7 and not VS 2010.

Thanks for your help. I'll award the points to you and the repost this question in a Windows related area.
0
 
ou81aswellAuthor Commented:
I meant to assign points to TheLearnedOne and not to myself.
0
 
ou81aswellAuthor Commented:
Turned out to be not related to VS 2010.
0
 
Bob LearnedCommented:
You know, I just noticed that I have the same behavior, and I just ignored it for a long time, and I have Windows 7.  I would be interested to know what you found out.
0
 
ou81aswellAuthor Commented:
I got an answer by creating a thread in the Windows OS section.

It is related to switching the input language on machines with multiple input languages installed.

I must have mashed the keys (I do that often). Here are the keystrokes:

Left Alt+Shift - Switch the input language when multiple input languages are enabled

Ctrl+Shift - Switch the keyboard layout when multiple keyboard layouts are enabled

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Q_26849478.html?cid=239#a34986315
0
 
Bob LearnedCommented:
Thank you very much!!  That'll teach me not to ignore an annoying problem!!
0
 
ou81aswellAuthor Commented:
I ignored it for a few months as it only happens once a week or so!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 6
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now