Solved

Exchange 2010 SMTP outbound connector not flowing

Posted on 2011-02-23
17
2,433 Views
Last Modified: 2012-05-11
I have a SBS 2011/ Exchange 2010 set up. Incoming mail from the hosted domain (xxxx.edu) is fine. I used the wizards for the inernet connection and internet mail, etc. It set up the SMTP send connector just fine. FixMyNetwork says there are no errors with the network.

On the Windows SBS connector properties I have FQDN as remote.xxxx.edu, Address Space is  "smtp   *"  scoped box unchecked,    Network is Use DNS, Enable DNS security unchecked, No smart host, Use External DNS of transport box unchecked,   Sourceserver is the server.

All the normal stuff the wizard sets up for you.  When I connect to exchange from an Outlook 2010 client I can receive emai, but no email goes out. It leaves the Outbox but never shows up at the destination.

What could be causing the SMTP connector to not send the mail?    THANKS!
0
Comment
Question by:dgrenda
  • 9
  • 7
17 Comments
 
LVL 76

Expert Comment

by:Alan Hardisty
Comment Utility
Are you able to telnet from a command prompt to my mail server on port 25?

telnet mail.mydomain.co.uk 25

or

telnet 188.220.xxx.xxx 25

Please try both and post the results.

Alan
0
 
LVL 38

Assisted Solution

by:Hypercat (Deb)
Hypercat (Deb) earned 50 total points
Comment Utility
In additionl to using the telnet test mentioned by alandhardisty, have you checked the emails queues on your SBS server? The Queue Viewer can be opened by opening the Exchange Management Console, clicking on Tools and then Queue Viewer. When you look at the Queue Viewer, do you see the mail building up in the queues? What queue is showing the buildup? What error messages are being shown there, if any?
0
 

Author Comment

by:dgrenda
Comment Utility
Tried both telnet and both failed. Unable to open connection.

Trying Queue thing now.
0
 

Author Comment

by:dgrenda
Comment Utility
They are stacked up in the Queue:  SCL is -1 and it sayd message delayed  Error 400.4.4.7  (excuse the security xxxx)

Identity: XXXXSERVER\12\60
Subject: test 5
Internet Message ID: <AAC786AFAC112F43BCA8F09F54DFADF7022602F1@xxxxSERVER.XXXXinst.local>
From Address: dgxxxa@xxxxinst.edu
Status: Ready
Size (KB): 4
Message Source Name: FromLocal
Source IP: 255.255.255.255
SCL: -1
Date Received: 2/23/2011 10:02:22 AM
Expiration Time: 2/25/2011 10:02:22 AM
Last Error: 400 4.4.7 Message delayed
Queue ID: xxxxSERVER\12
Recipients:  david@xxxa.com
0
 
LVL 76

Expert Comment

by:Alan Hardisty
Comment Utility
Okay - if both failed, your ISP or your firewall is blocking TCP port 25 outbound.

Check the firewall / router first please, then get on the phone and give your ISP a hard time until they unblock you!!
0
 

Author Comment

by:dgrenda
Comment Utility
So you are saying it could be the Linksys router?  And is there another port option or am I stuck with 25?

Can I change that somewhere in Exchange?  THANKS!!!!
0
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 450 total points
Comment Utility
Default port is port 25.  It could be the Router not allowing TCP port 25 outbound from the server (if you can't telnet to me on IP / FQDN on port 25 - something is blocking you - the fact it fails on both shows it is not a DNS issue).

If you use another port - you will have to use a smarthost and that will have to be your ISP's smarhost (mail server) and the port will be what they tell you to use.

Alternatively you need a 3rd party filtering service and their Smarthost / port combination.
0
 

Author Closing Comment

by:dgrenda
Comment Utility
Looks like it's port 25 and thanks for the tip on the queue check
0
Get up to 2TB FREE CLOUD per backup license!

An exclusive Black Friday offer just for Expert Exchange audience! Buy any of our top-rated backup solutions & get up to 2TB free cloud per system! Perform local & cloud backup in the same step, and restore instantly—anytime, anywhere. Grab this deal now before it disappears!

 

Author Comment

by:dgrenda
Comment Utility
Is there any way to change Exchange to use port 587 instead?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
Comment Utility
Yes - use the following command in the Exchange Management Shell:

Set-SendConnector -Identity "Send Connector Name" -port 587

Change the Send Connector Name to match your Send Connector
0
 
LVL 76

Expert Comment

by:Alan Hardisty
Comment Utility
You will have to send mail to a smarthost if you change the default port so you will need to modify the default Send Connector accordingly.
0
 

Author Comment

by:dgrenda
Comment Utility
Smarthost like my ISP's SMTP server?

I use port 587 on my stand alone outlook 2003 outgoing. I have to say it requires authentication, same as incoming.

Sorry if I seem so unclear
0
 
LVL 76

Expert Comment

by:Alan Hardisty
Comment Utility
No problems - it's a complicated beast Exchange!

Yes - a Smarthost is your ISP's SMTP server - if you change the port you will have to send ALL mail to a Smarthost for delivery.

Have you spoken to your ISP and asked them if they are blocking port 25?  Sometimes they will say No even when they are.  Tell them you can prove they are blocking you and then talk to someone in 2nd line / 3rd line support until you get some joy.

Using port 25 means you can send all mail out via DNS which is the normal method.
0
 

Author Comment

by:dgrenda
Comment Utility
I am actually configuring an exchange server to be installed eventually in a business location. So I'm hesitent to jump thru too many hoops to get it working in my home office.  I am surprised Exchange doesn't just allow you to change ports like Outlook and be happy.

I also have to get stupid BBerry Enterprise Express working on this beast.

Ah I understand the port 25 DNS relatiosnhip. Ok that makes sense. YOU sir, are a steely eyed missle man.

Thank you. You have helped me before.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
Comment Utility
: ) - Not been called that before!!

If you are on a home DSL service (Dynamic IP Address), chances are that Port 25 is blocked as standard.

Sounds like the server is configured happily - it usually works out of the box, so don't tweak it and when you move it - it should be fine.

Good luck with the BB - not a fan personally.
0
 

Author Comment

by:dgrenda
Comment Utility
One more question. Will it solve my problem to use a smarthost and not worry about the port? or is the port going to be a problem no matter what.
0
 

Author Comment

by:dgrenda
Comment Utility
You answered that. Thanks!

I hate BBerry too.
0

Featured Post

Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

Join & Write a Comment

Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
how to add IIS SMTP to handle application/Scanner relays into office 365.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now