This message has not been downloaded from the server

Customer has their iPhones setup to sync with their Exchange 2010 server.  Yesterday all email was downloading and readable on their iphones.  Today the iphones are saying "This message has not been downloaded from the server" when they click on an email.  The subject and sender comes through, but not the body.  

How can I resolve?

gk2incAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alan HardistyCo-OwnerCommented:
Is this a problem for all users or just the odd one or two?

If one or two - reboot the iPhones.

If All - check the services on the Exchange Server and worst case, reboot it.
0
gk2incAuthor Commented:
Its all users.
0
Alan HardistyCo-OwnerCommented:
Okay - can you please visit https://testexchangeconnectivity.com and run the Exchange Activesync test, specify manual server settings and if you have a self-signed certificate, please tick the Ignore Trust for SSL check box.

Then post the results (please hide your domain name / IP Address).
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

gk2incAuthor Commented:
ExRCA is testing Exchange ActiveSync.  
  Exchange ActiveSync was tested successfully.
   Test Steps
   Attempting the Autodiscover and Exchange ActiveSync test (if requested).
  Autodiscover was successfully tested for Exchange ActiveSync.
   Test Steps
   Attempting each method of contacting the Autodiscover service.
  The Autodiscover service was tested successfully.
   Test Steps
   Attempting to test potential Autodiscover URL https://domainname.com/AutoDiscover/AutoDiscover.xml 
  Testing of this potential Autodiscover URL failed.
   Test Steps
   Attempting to resolve the host name domainname.com in DNS.
  The host name resolved successfully.
   Additional Details
  IP addresses returned: IP ADDRESS
 
 Testing TCP port 443 on host domainname.com to ensure it's listening and open.
  The port was opened successfully.
 Testing the SSL certificate to make sure it's valid.
  The SSL certificate failed one or more certificate validation checks.
   Test Steps
   Validating the certificate name.
  Certificate name validation failed.
   Tell me more about this issue and how to resolve it
   Additional Details
  Host name domainname.com doesn't match any name found on the server certificate CN=spectrumwireless-com.com, OU=IT, O=VT, L=Jackson, S=Mississippi, C=US.
 
 
 
 
 
 
0
gk2incAuthor Commented:
Sorry, dont know how I got the above information:

ExRCA is testing Exchange ActiveSync.
 Exchange ActiveSync was tested successfully.
 Test Steps
 Attempting the Autodiscover and Exchange ActiveSync test (if requested).
 Autodiscover was successfully tested for Exchange ActiveSync.
 Test Steps
 Attempting each method of contacting the Autodiscover service.
 The Autodiscover service was tested successfully.
 Test Steps
 Attempting to test potential Autodiscover URL https://domainname.com/AutoDiscover/AutoDiscover.xml
 Testing of this potential Autodiscover URL failed.
 Test Steps
 Attempting to resolve the host name domainname.com in DNS.
 The host name resolved successfully.
 Additional Details
 IP addresses returned: IP ADDRESS

Testing TCP port 443 on host domainname.com to ensure it's listening and open.
 The port was opened successfully.
Testing the SSL certificate to make sure it's valid.
 The SSL certificate failed one or more certificate validation checks.
 Test Steps
 Validating the certificate name.
 Certificate name validation failed.
  Tell me more about this issue and how to resolve it
 Additional Details
 Host name domainname.com doesn't match any name found on the server certificate CN=spectrumwireless-com.com, OU=IT, O=VT, L=Jackson, S=Mississippi, C=US.





Attempting to test potential Autodiscover URL https://autodiscover.domainname.com/AutoDiscover/AutoDiscover.xml
 Testing of the Autodiscover URL was successful.
 Test Steps
 Attempting to resolve the host name autodiscover.dominanname.com in DNS.
 The host name resolved successfully.
 Additional Details
 IP addresses returned: IP ADDRESS

Testing TCP port 443 on host autodiscover.domainname.com to ensure it's listening and open.
 The port was opened successfully.
Testing the SSL certificate to make sure it's valid.
 The certificate passed all validation requirements.
 Test Steps
 Validating the certificate name.
 The certificate name was validated successfully.
 Additional Details
 Host name autodiscover.domainname.com was found in the Certificate Subject Alternative Name entry.

Testing the certificate date to confirm the certificate is valid.
 Date validation passed. The certificate hasn't expired.
 Additional Details
 The certificate is valid. NotBefore = 2/21/2011 6:59:58 PM, NotAfter = 2/12/2012 4:35:01 PM



Checking the IIS configuration for client certificate authentication.
 Client certificate authentication wasn't detected.
 Additional Details
 Accept/Require Client Certificates isn't configured.

Attempting to send an Autodiscover POST request to potential Autodiscover URLs.
 ExRCA successfully retrieved Autodiscover settings by sending an Autodiscover POST.
 Test Steps
 ExRCA is attempting to retrieve an XML Autodiscover response from URL https://autodiscover.domainname.com/AutoDiscover/AutoDiscover.xml for user myemail@address.com.
 The Autodiscover XML response was successfully retrieved.
 Additional Details
 Autodiscover Account Settings
XML response:
<?xml version="1.0"?>
<Autodiscover xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
<Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/mobilesync/responseschema/2006">
<Culture>en:us</Culture>
<User>
<DisplayName>My Name</DisplayName>
<EMailAddress>myemail@address.com</EMailAddress>
</User>
<Action>
<Settings>
<Server>
<Type>MobileSync</Type>
<Url>https://remote.domainname.com/Microsoft-Server-ActiveSync</Url>
<Name>https://remote.domainname.com/Microsoft-Server-ActiveSync</Name>
</Server>
</Settings>
</Action>
</Response>
</Autodiscover>









Validating Exchange ActiveSync settings.
 Exchange ActiveSync URL https://remote.domainname.com/Microsoft-Server-ActiveSync was validated successfully.
Attempting to resolve the host name remote.domainname.com in DNS.
 The host name resolved successfully.
 Additional Details
 IP addresses returned: IP ADDRESS

Testing TCP port 443 on host remote.domainname.com to ensure it's listening and open.
 The port was opened successfully.
Testing the SSL certificate to make sure it's valid.
 The certificate passed all validation requirements.
 Test Steps
 Validating the certificate name.
 The certificate name was validated successfully.
 Additional Details
 Host name remote.domainname.com was found in the Certificate Subject Common name.

Testing the certificate date to confirm the certificate is valid.
 Date validation passed. The certificate hasn't expired.
 Additional Details
 The certificate is valid. NotBefore = 2/21/2011 6:59:58 PM, NotAfter = 2/12/2012 4:35:01 PM



Checking the IIS configuration for client certificate authentication.
 Client certificate authentication wasn't detected.
 Additional Details
 Accept/Require Client Certificates isn't configured.

Testing HTTP Authentication Methods for URL https://remote.domainname.com/Microsoft-Server-ActiveSync.
 The HTTP authentication methods are correct.
 Additional Details
 ExRCA found all expected authentication methods and no disallowed methods. Methods found: Basic

An ActiveSync session is being attempted with the server.
 Testing of an Exchange ActiveSync session completed successfully.
 Test Steps
 Attempting to send the OPTIONS command to the server.
 The OPTIONS response was successfully received and is valid.
 Additional Details
 Headers received: Allow: OPTIONS,POST
MS-Server-ActiveSync: 14.1
MS-ASProtocolVersions: 2.0,2.1,2.5,12.0,12.1,14.0,14.1
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,Search,Settings,Ping,ItemOperations,Provision,ResolveRecipients,ValidateCert
Public: OPTIONS,POST
Content-Length: 0
Cache-Control: private
Date: Fri, 25 Feb 2011 01:30:54 GMT
Server: Microsoft-IIS/7.5
X-AspNet-Version: 2.0.50727
X-Powered-By: ASP.NET



Attempting the FolderSync command on the Exchange ActiveSync session.
 The FolderSync command completed successfully.
 Additional Details
 Number of folders: 13

Attempting the initial sync to the Inbox folder. This initial sync won't return any data.
 The Sync command completed successfully.
 Additional Details
 Status: 1

Attempting to test the GetItemEstimate command for the Inbox folder.
 ExRCA successfully received the GetItemEstimate response from the server.
 Additional Details
 Estimate: 16 messages
0
gk2incAuthor Commented:
Rebooted the server, did not resolved.

Removed/added exchange accounts back to iPhone did not resolve.

Checked date/time on iphones to make sure they were correct with the server, and they are to the minute identical to the server.

Hard reset on the iPhone, still not resolved.

What could this be?

0
gk2incAuthor Commented:
SO I found this article http://social.technet.microsoft.com/Forums/en/exchangesvrmobility/thread/321eae51-9cbd-4a5e-85c1-68d8f7b523c3?prof=required which seems to help most people. I am unable to follow the directions because:

When I try the above using my information, I get a identity "cannot be found on servername".

When I go into the exchange management console, I cannot remote the default accepted domain name because a email address policy is tied to it.  When I try and remove the email policy, I don't have an option to remove the default policy.

We have updated our server with every hotfix, patch, etc from windows update site.  I need help with is affected 40 users and executives of a company.
0
gk2incAuthor Commented:
I removed the entry to the default email address policy, which allowed me to remove the default accepted domain name, rebooted server but still not working.
0
gk2incAuthor Commented:
http://social.technet.microsoft.com/Forums/en/exchangesvrmobility/thread/321eae51-9cbd-4a5e-85c1-68d8f7b523c3?prof=required

Microsoft said the above article was in fact the right steps to follow to resolve my issue.  We had to go one step further and remove the default policies as they were correct, but there was some CACHED information stored causing this.  Once default policies were removed and created, exchange services restarted issues were resolved.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gk2incAuthor Commented:
This resolved my issues.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.