Solved

Need guidance to correct a wireless access point setting.

Posted on 2011-02-23
10
773 Views
Last Modified: 2013-12-27

Here is the scenario.
I have a car dealership that I use a SonicWall TZ200 to manage the network.  All workstations have a static ip address and gateway address pointing to the SW TZ200.  When technicians use a pc that has a static IP address, they are able to login to their manufacture's service website and click on a link that gives them information about a specific vehicle's history, etc..
I have a Linksys Wireless G WRT54G2 that I have configured on the network to provide wireless access to 3 laptops in the service bay.
The laptops are taken home at night and do not have static ip addresses.  I assigned a static IP address to the Linksys router, disabled dhcp server and changed the setting from gateway to router.  The technicians who use these laptops can login to the secure car dealer website but when they click on the vehicle history, to get these reports: a new browser window opens and the page starts to load and eventually it times out.  I have tried a new access point, same settings, same result.  Do I need to port forward in the linksys?  I did call Linksys and the tech suggested redoing the wireless security, which I did, ( I turned off the wireless security), same result, no joy.  ANy ideas?
0
Comment
Question by:mtk4590
  • 4
  • 2
  • 2
  • +2
10 Comments
 
LVL 118
ID: 34966644
"a new browser window opens and the page starts to load and eventually it times out."

how long has this been happening?

can you access the website correctly on your network elsewhere, not using these laptops?

you should have to port forward anything. this would seem like a website issue or browser related problem.
0
 

Author Comment

by:mtk4590
ID: 34966796
Evidently it's been going on for a while but they were assuming the problem was with their laptop's browser settings.  You can access the website and the subsequent links from any desktop that is not going through the wireless access point.
0
 
LVL 26

Expert Comment

by:akahan
ID: 34966919
I guess I'm missing something.

When the laptops connect to the wireless network, how do they get an IP address?
You say that they do NOT have static IP's set, because they are taken home at night, but if I understand correctly you have turned off DHCP completely  on both the SonicWall (because the machines that connect to it have static IP's, and don't need DHCP) and you've also disabled DHCP on the Linksys.  Is that right?

If you could provide a little more clarity on this, it shouldn't be too hard to figure out what's going on.

But I *think* the way you want to configure things is:

Set the Linksys up as a router.

Give the Linksys' WAN port a static IP address in the range of LAN addresses handed out by the SonicWall, making sure it's not already taken.  So, if the SonicWall gives out LAN addresses in the range 10.0.0.X, you could give it 10.0.0.25, for example.

Set the Linksys' Gateway address to the LAN address of the SonicWall; so, this would be 10.0.0.1, if we're continuing with the numbering scheme described above.

Turn DHCP Server ON in the Linksys, and make sure that the addresses it's handing out are not in the same range as the addresses handed out by the SonicWall.  So, for example, you could use 10.0.1.X.

Put universally accessible DNS servers (like 4.2.2.3 and 4.2.2.6) in the Linksys.  (You have to do this, since it's got a static IP address, and isn't querying for an IP address, or for DNS settings, from the SonicWall.)

Now, let the laptops connect to the  Linksys should get their IP addresses via DHCP from the Linksys.  Anytime they seek an IP address that's not in the 10.0.1.X range, the Linksys will hand it off to the Sonicwall out the Linksys' WAN port, since the Linksys' gateway address is the Sonicwall's address.

ALTERNATIVELY...

Turn DHCP off in the Linksys (making sure, though, that it has the SonicWall's LAN IP address as its gateway address, and that the Linksys has a static IP address that's within the range of LAN addresses handed out by the SonicWall) and, in each of the laptops (assuming they're running Windows XP), do this:

Go into Control Panel / Network Settings  and select Properties on the Wireless card.

scroll down to Internet properties (tcp/ip), and press the Properties button.

On the "General" tab, pick Obtain IP address automatically, and obtain DNS server addresses automatically.  This way, these machines will work fine when taken home and connected to a network that's handing out addresses through DHCP.

But now, click the Alternate Configuration tab, and, on the alternate configuration page, pick User configured, and set these machines up EXACTLY as the desktops are set up, only each with their own IP address in the same range as the desktops, but not with the same exact IP address. Then "OK" your way out.

Now what happens with the laptops is that when they're connected to a network with DHCP, they get their addresses through DHCP.  When they're connected to a network with no DHCP (like your dealership), they TRY, but FAIL, to get an address via DHCP (since there's no DHCP server.)  When that happens, they then use the static ip address information on the "Alternate configuration" page.  If you set that up the same as the desktops, then if the desktops will work, so will these.


0
 
LVL 1

Expert Comment

by:Furyan
ID: 34966960
You need to set your Linksys Wireless G WRT54G2 in access point mode.The SonicWall TZ200 and the Linksys Wireless G WRT54G2  are both gateways/routers, and they conflict with each other over the ip adress. Thats why you get a web page time out.

Here is a how to:
To convert your WRT54Gs to a wireless access point:
1. Disconnect it from everything except one computer that is wired to it.
2. Give it a fixed IP address (one that is not the same as the wired router). So, find the wired router's IP address and add one. Example: if the wired router is 192.168.1.1, you are going to set your WRT54GL as 192.168.1.2.
3. Disable the WRT54G2's DHCP server.
4. Save the settings.
5. Connect any (yes, any) LAN port (not WAN, LAN) on the wired router to any LAN port (not WAN, LAN) on the WRT54G2.
6. Is the WRT54G2's WAN or "Internet" port empty? It should be! If it isn't re-read step 5 9 more times.
7. Now, you have a LAN port on your wired router connected to another LAN port on the WRT54G2. If you don't, re-read step 5.
8. Set the wired router to be the DHCP server. Make sure that 192.168.1.2 is not within the DHCP range -- you wouldn't want a conflict.
9. Done.

I hope this will solve your problem.

Regards Furyan
0
 

Author Comment

by:mtk4590
ID: 34966970
Thank you for the info.  Let me clarify a bit regarding the DHCP.
The SonicWall is controlling the DHCP but upon advice from SonicWall, I excluded the numbers that I had used for static ips from the DHCP range and any other devices that are not static receive their Ip automatically from the SonicWall.  
The linksys setup does not allow for a default gateway number.  
I set the Lan IP address and I get to put in the subnet of 255.255.255.0
I also disabled the DHCP server on the setup page of the Linksys.
I like the idea of the alternate configuration, I will try that this week.  Thanks.
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 
LVL 26

Expert Comment

by:akahan
ID: 34967034
If the Sonicwall is handing out DHCP addresses, then (under my first proposed solution), you wouldn't need to give the Linksys a gateway address...it'll just get it from the SonicWall.

Furyan's suggestion to use the WRT54G as an access point is also a worthwhile approach.
0
 
LVL 33

Expert Comment

by:digitap
ID: 34970238
do you have the linksys connected to it's own interface on the sonicwall or do you have it connected to the network switch that connects to the sonicwall LAN (x0) interface?  if on the switch, then the access point should be bridging the wireless to the wired network and handing out IPs for the LAN network.
0
 

Accepted Solution

by:
mtk4590 earned 0 total points
ID: 35281104
Sorry everybody but it turned out to be an issue with the website itself. All is well. Thanks for your interest and my apologies for not getting to back to you soon.
0
 
LVL 33

Expert Comment

by:digitap
ID: 35324851
no worries. thanks for the feedback.
0
 

Author Closing Comment

by:mtk4590
ID: 35360823
It was a problem with the website.
0

Featured Post

Network it in WD Red

There's an industry-leading WD Red drive for every compatible NAS system to help fulfill your data storage needs. With drives up to 8TB, WD Red offers a wide array of solutions for customers looking to build the biggest, best-performing NAS storage solution.  

Join & Write a Comment

Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now