Solved

deploying hotfix KB953760 with GPO and VBS too long !

Posted on 2011-02-24
13
2,086 Views
Last Modified: 2012-08-13
Hello,
I want to deploy an hotfix KB953760 (not possible with WSUS)
when i install it manually, it takes about 30 sec to install and ask to reboot = OK
so i made a GPO with a vbs to deploy it on about 100 PCs, during the startup (or shutdown) of the PCs
The GPO is working fine, but it takes about 7 to 8 minutes to finish,
Do you have an explaination ?

Thank!
0
Comment
Question by:Mathias75000
  • 5
  • 4
  • 4
13 Comments
 

Author Comment

by:Mathias75000
ID: 34969507
in fact it takes 10 minutes, the installation is ok but i've got an event like " GPO script execution too long and has been stopped"
i don't think it comes from the VBS script cause i tried with a simple .bat script and it's the same problem.

thanks for help
0
 
LVL 22

Expert Comment

by:Adam Leinss
ID: 34970165
What command line are you using?  Sounds like it is trying to show a GUI to the user, but there is no user, so it's waiting forever for a response.

You probably want something like msiexec /i somefile.msi /quiet /forcerestart
0
 

Author Comment

by:Mathias75000
ID: 34970209
it's not an msi file but an exe, i must say that i'm not an expert in scripting ...


here is the vbs :


Set objShell = CreateObject("WScript.Shell")
Set objFSO = CreateObject("Scripting.FileSystemObject")
 
strComputer = "."
Set objWMIService = GetObject("winmgmts:\\" & strComputer & "\root\cimv2")
Set colItems = objWMIService.ExecQuery("SELECT * FROM Win32_OperatingSystem WHERE Name LIKE '%Microsoft Windows XP%'")
For Each objItem In colItems
   If objItem.CSDVersion = "Service Pack 3" Then
      If objFSO.FolderExists("C:\WINDOWS\$NTUninstallKB953760$")=False Then
         objShell.Run "\\server\WindowsXP-KB953760-x86-FRA_FIX_SSO_FARM.exe /quiet", ,TRUE
      End If
   End If
Next



i tried as well a simple bat with :

\\server\WindowsXP-KB953760-x86-FRA_FIX_SSO_FARM.exe /quiet
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 
LVL 22

Expert Comment

by:Adam Leinss
ID: 34970412
Hmm, that does look fine.  I would try adding /forcerestart /forceappsclose from http://support.microsoft.com/kb/262841.  If that doesn't work, I would add /v /log:C:\windows\temp and take a look at the last lines of the log to see what is says.
0
 
LVL 47

Expert Comment

by:Donald Stewart
ID: 34970495
Have you tried using  "Local Updates Publisher" I use it and have good success with it.


http://www.localupdatepublisher.com/

http://sourceforge.net/apps/mediawiki/localupdatepubl/index.php?title=Main_Page


0
 
LVL 22

Expert Comment

by:Adam Leinss
ID: 34970522
Wow, that's a nice tip dstewartjr!  Bookmarked!
0
 
LVL 47

Expert Comment

by:Donald Stewart
ID: 34970567
It even allows you to see which clients have installed, failed or still needed just like in WSUS.
0
 

Author Comment

by:Mathias75000
ID: 34970755
yeah really good tip !
i'll use for sure ... but not in this case ;)

I can't use at all WSUS (I'm doing IT consulting for another company, i'm not allowed to touch the wsus)
I'll tried to log some informations and keep in touch.

Thx !
0
 
LVL 47

Accepted Solution

by:
Donald Stewart earned 250 total points
ID: 34970868
OK ;)

Here's a script that I have used:


sExePath = "\\server\WindowsXP-KB953760-x86-FRA_FIX_SSO_FARM.exe"
sSwitches = "/u /q /z"
Set oShell = CreateObject("WScript.Shell")
sRegKey = "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate"

' suppress error in case values does not exist
On Error Resume Next

' check for marker
sRegMarkerValue = ""  ' init value
sRegMarkerValue = oShell.RegRead( sRegKey & "\WindowsXP-KB953760-x86-FRA_FIX_SSO_FARM.exe")
On Error Goto 0

' to be sure update is installed only once, test on marker
If sRegMarkerValue <> "yes" Then


   oShell.Run Chr(34) & sExePath & Chr(34) & " " & sSwitches, 1, True


   ' create marker
   oShell.RegWrite sRegKey & "\WindowsXP-KB953760-x86-FRA_FIX_SSO_FARM.exe", "yes"
End If
0
 

Author Comment

by:Mathias75000
ID: 34971236
Wouh it works !
thanks !
Can you tell me basically why your script install the hotfix in 1 minute and mine in 10 ?? :)
0
 
LVL 47

Expert Comment

by:Donald Stewart
ID: 34971324
Maybe the WMI query takes some time ???
0
 
LVL 22

Expert Comment

by:Adam Leinss
ID: 34971577
My guess is that his script correctly parses "/quiet" whereas your script doesn't.  VBScript is funny with escaping special characters and spaces
0
 

Author Comment

by:Mathias75000
ID: 34971616
hmmm ... don't know

i tried my script with /passive instead of /quiet
it works again, i can see the installation during the shutdown (no pb, 30 sec to install) and after 10 minutes to shutdown...

Anyway, thanks both of you !
0

Featured Post

VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
This article outlines the process to identify and resolve account lockout in an Active Directory environment.
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question