Solved

Autodiscover + Out of Office

Posted on 2011-02-24
21
328 Views
Last Modified: 2012-05-11
A continuation to this thread http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_26835943.html

I thought it was all sorted but now the there are 2 other clients who are unable to use Out of Office. These 2 clients are part of the same company/domain as the ones I mention in the first question, but in a different office.

Test Email Config works in Outlook 2007 and finds the autodiscover URL fine. They can also ping the cname autodisover.theirdomain.com (as it resolves to autodiscover.mydomain.com)

Cant figure out why now they cant access it?
0
Comment
Question by:hongedit
  • 12
  • 9
21 Comments
 
LVL 1

Expert Comment

by:RussTre
ID: 34971152
Does this happen on other pcs? Or just the one at their desks?  

It could be that the Outlook profile on the PC has been "corrupt" (for lack of a beeter word) and needs to be deleted and recreated on those PCs.  
0
 
LVL 1

Author Comment

by:hongedit
ID: 34971349
It happens for all 3 users at the same site.

Re-created one profile anyway, no joy, same error "The Server is unavailable"
0
 
LVL 1

Expert Comment

by:RussTre
ID: 34971515
Have you deleted and recreated the Autodiscover Virtual Directory for there exchange server?

I had a similar problem. I deleted and recreate the Autodiscover Virtual Directory and that corrected my autodiscovery/out of office problem
0
 
LVL 1

Author Comment

by:hongedit
ID: 34971547
I dont think its the server, becuase it works everywhere else!
0
 
LVL 1

Expert Comment

by:RussTre
ID: 34971588
Something is blocking communication.  Is the firewall turned on on those PC?
0
 
LVL 1

Author Comment

by:hongedit
ID: 34971669
Nope.

Here is some history - lets call the current problem site office1 and the other site (which works and is part of the same company and domain) office2.

Put clients in office1 on my Exchange, Out of Office did not work
Added CNAME entry into DNS, OOF works
Introduce office2, OOF does not work (hence linked Question)
Re-checked and CNAME had been deleted. Re-added, office2 OOF now works.
office1 calls up to say they are going to be away and that OOF is not working again.
Re-checked CNAME, still there and can ping from office1.

Nothing has changed at the sites, no config or anything!
0
 
LVL 1

Author Comment

by:hongedit
ID: 34971715
....wow.

Just re-checked office2 and that is not working either now.

Works on Outlook when either not connected to my domain or on the PC's within my domain.

Going round in circles!
0
 
LVL 1

Expert Comment

by:RussTre
ID: 34971892
What about the free/busy in the calendar? Is that showing the information? (the answer to this may indicate my mext step/solution for you)
0
 
LVL 1

Author Comment

by:hongedit
ID: 34971899
Sorry - you mean are calendar's working?
0
 
LVL 1

Expert Comment

by:RussTre
ID: 34971930
Yes, when you set up a meeting request and use 'scheduling assistant'; it shows whether those you intend to invite are busy or free.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 1

Author Comment

by:hongedit
ID: 34971999
Ok - I'll test. Wont be able to do it til later tonight after eveyrone has gone home though.
0
 
LVL 1

Author Comment

by:hongedit
ID: 34973609
Seems to be working.

I created a dummy meeting on one user, then tried to invite them to another meeting of the same date/time. Outlook showed the conflicts.
0
 
LVL 1

Author Comment

by:hongedit
ID: 34973641
Another interesting thing I have just discovered.

All users in Office1 use Outlook 2007.
All user bar one in Office2 use Outlook 2007.

The one user that doesn't use Outlook 2007 (2010 instead) works now. It didnt a few hours ago, and all that has happened since then is me creating those dummy meetings. The Outlook 2007's in Office2 still dont work.

How bizarre?
0
 
LVL 1

Author Comment

by:hongedit
ID: 35016848
Bump
0
 
LVL 1

Expert Comment

by:RussTre
ID: 35016863
Are the email profiles cached on the PC's or not?
0
 
LVL 1

Accepted Solution

by:
hongedit earned 0 total points
ID: 35017123
I finally figured it out, just this second (I think).

Started by me jumping on one of their PC's and testing it.It worked.

Tried on another and it didnt work.

Compared configs and noticed the one that did work had cache mode OFF. So I did the same on the other, but no difference. At this point the configs were identical, on the same site using the same network. Baffled.

Then, a security prompt came up - domain mismatch becuase their outlook's are looking for autodiscover.theirdomain.com, while my cert is for mydomain.com.

Clicked Yes to accept, tried again and it worked!

Asked around and apparently they had been clicking "No"....
0
 
LVL 1

Expert Comment

by:RussTre
ID: 35017243
Ahh .. the infamous user clicking no becuase they think its better to not to install something. This is why I always try to notify the end-users of any changes ink our network settings, especially when it comes to email that if there are any pop-ups/requests to install something to let us in the IT Dept know. We do try make all "installs" run in the background so there are no user "help" needed.

That said, its interesting because all my users (400+) are cache mode OFF and the certs installed w/o prompting.  
0
 
LVL 1

Author Comment

by:hongedit
ID: 35017347
Yeah - I didnt even realise! I had told them in passing to just click yes, and assumed they did.

Are your users configured for the same domain as the SSL Cert on the Exchange Server?

I understand why they are being prompted, but I'm not sure of a way round it.

My Exchange Server has a UCC cert for mydomain.com, but becuase they are on their own separete AD domain, Outlook automatically looks for autodiscover.theirdomain.com.

While I have a CNAME to resolve that to my IP, the certificate will not match becuase of the different domains.

Maybe it's possible to install a 2nd cert to Exchange for their domain, though I have not looked into it yet. Plus they are so tight I think they'd rather click Yes for the whole 6 users rather than pay the minimal £ for a 3rd party SSL!
0
 
LVL 1

Expert Comment

by:RussTre
ID: 35017562
We did cough up the scratch for a 3rd party SAN/SSL. So my set up is a little bit different than yours.

Try putting in a DNS alias on thier domain that points to your autodiscover.yourdomain.com and that resolves to the CNAME/IP have. You may have have to create an new zone.  I read that in my search for my autodiscover issue.  Give a bit and I'll see if I can find the page again.
0
 
LVL 1

Expert Comment

by:RussTre
ID: 35017620
Try putting in a DNS alias on thier domain that points to your autodiscover.yourdomain.com and that resolves to the CNAME/IP have.

Sorry no edit button.  Let me try explaining/retyping that.  On their DNS, type in HOST name that is your IP address as well the alias/cname. You may have to create a new zone that is called "autodiscover.yourdomain.com" and those ips piont to your alias and IP. Make sense?

Again, give a bit to find the page/links.
0
 
LVL 1

Author Closing Comment

by:hongedit
ID: 35067669
As above.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
If you don't know how to downgrade, my instructions below should be helpful.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now