Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 859
  • Last Modified:

Fatfreecrm Installation on Windows or Linux PC

Can you Please help me to Install FatfreeCRm Installation On Windows XP PC

we have downloaded the Fatfreecrm application

From URL: https://github.com/michaeldv/fat_free_crm/downloads

And its system requirements are  Ruby / Rubyonrails / Mysql applications to configure
so as per this Provided URL:https://github.com/michaeldv/fat_free_crm


Firstly installed the Ruby1.9.1
Then installed the one click installer using http://railsinstaller.org/
But in this rails version is 3.0.3,
then i have installed mysql version5.1 separately.

Also Installed the gem install mysql
to connect the mysql server using database.yml file

After all this above setup when i run the command

c:\sits\fat_free_crm>rake db:create

then its giving the error:

C:\sites\fat_free_crm>rake db:create
(in C:/sites/fat_free_crm)
rake aborted!
C:/sites/fat_free_crm/lib/tasks/fat_free_crm.rake:81: syntax error, unexpected t
LSHFT, expecting keyword_end
<<<<<<< HEAD
  ^
C:/sites/fat_free_crm/lib/tasks/fat_free_crm.rake:83: syntax error, unexpected t
EQQ, expecting keyword_end
=======
   ^
C:/sites/fat_free_crm/lib/tasks/fat_free_crm.rake:87: syntax error, unexpected t
RSHFT, expecting keyword_end
>>>>>>> 105f8e0d8f907662bdd45fc5d9378f0e4857b455
  ^
C:/Ruby192/lib/ruby/gems/1.9.1/gems/activesupport-3.0.3/lib/active_support/depen
dencies.rb:235:in `load'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/activesupport-3.0.3/lib/active_support/depen
dencies.rb:235:in `block in load'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/activesupport-3.0.3/lib/active_support/depen
dencies.rb:225:in `block in load_dependency'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/activesupport-3.0.3/lib/active_support/depen
dencies.rb:596:in `new_constants_in'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/activesupport-3.0.3/lib/active_support/depen
dencies.rb:225:in `load_dependency'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/activesupport-3.0.3/lib/active_support/depen
dencies.rb:235:in `load'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.0.3/lib/rails/engine.rb:131:in `b
lock in load_tasks'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.0.3/lib/rails/engine.rb:131:in `e
ach'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.0.3/lib/rails/engine.rb:131:in `l
oad_tasks'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.0.3/lib/rails/application.rb:141:
in `load_tasks'
C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.0.3/lib/rails/application.rb:77:i
n `method_missing'
C:/sites/fat_free_crm/Rakefile:7:in `<top (required)>'
C:/Ruby192/lib/ruby/1.9.1/rake.rb:2373:in `load'
C:/Ruby192/lib/ruby/1.9.1/rake.rb:2373:in `raw_load_rakefile'
C:/Ruby192/lib/ruby/1.9.1/rake.rb:2007:in `block in load_rakefile'
C:/Ruby192/lib/ruby/1.9.1/rake.rb:2058:in `standard_exception_handling'
C:/Ruby192/lib/ruby/1.9.1/rake.rb:2006:in `load_rakefile'
C:/Ruby192/lib/ruby/1.9.1/rake.rb:1991:in `run'
C:/Ruby192/bin/rake:31:in `<main>'

Can you please assist me to install fatfreecrm on windows xp PC or on Linux also...?
Also have checked with this URL: http://groups.google.com/group/fat-free-crm-dev/browse_thread/thread/91a0c634dc1eef65

But not solved.
0
kadadi_v
Asked:
kadadi_v
  • 2
1 Solution
 
kadadi_vAuthor Commented:
OK I found the Solution :

It require the gem install mysql2 and libmysql.dll file require in Ruby/bin path and also require the gem install test-unit 1.2.3 version.

Then I RUN the command > rake db:create

and it created the DB'S.....No prob.


Regards,
vijay kadadi
0
 
kadadi_vAuthor Commented:
Yes Please Close the Question , Got the solution and no one put the single comment as a Answer...
No Prob...:)
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now