Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2068
  • Last Modified:

"Paste" function disabled on Windows Server 2008 R2 / Citrix server

Dear experts,

We installed a new Windows Server 2008 R2 Xenapp terminal server.

All works fine now but I still have a minor issue: Users cannot paste anything on their Desktop. Administrators can however.

- Users CAN create new items on their desktop (e.g. right click on desktop new->text document)
- Several policy's are set to restrict their desktop but I cannot link one of them to this problem
- Desktop Experience Feature is installed on this server

I have no idea where to look now but it has to be some option somewhere. Hopefully one of you recognizes this?

Thanks
0
Supracom
Asked:
Supracom
  • 2
1 Solution
 
Carl WebsterCommented:
Make sure Clipboard functionality has not been disabled in either a GPO or Citrix policy.
0
 
SupracomAuthor Commented:
Hi CarlWebster,

I did look at that but could not find anything. I've attached a report of the GPO policy to this post FYI.
Desktop-Restriction-2.htm
0
 
Jackie ManCommented:
According to the comment of Reg1145, it says:-

"I locked down the user session pretty tight and I didn't want the user to have access to the A, B, C, and D drives on the Terminal Server. Within "User Configuration \ Administrative Templates \ Windows Components \ Windows Explorer" I had the following two settings enabled:

1) Hide these specified drives in My Computer (preventing access to the A, B, C, and D drives)

2) Prevent access to drives from My Computer (preventing access to the A, B, C, and D drives)

The second setting was the one that caused the problem. With this setting enabled, I was able to right-click on a desktop icon and select "copy", but I was not able to paste to the desktop because I had prevented the user access to the C: drive."

Source: http://community.spiceworks.com/topic/80625

In your GPO policy above, you have also done the following:-

Under User Configuration -> Policies -> Administrative Templates

-> Windows Components/Windows Explorer
   Prevent access to drives from My Computer Enabled  
    Pick one of the following combinations Restrict A, B, C and D drives only


So, you can copy, but not able tp paste on the desktop in terminal session.

 
 

0
 
SupracomAuthor Commented:
Hi jackieman

That was it! Thanks for your solution.

It would like to give users normal access to their own desktop but I also want to prevent browsing through the system drives on the server... Does someone know if this can be done or do I have to choose between the one or the other? The strange thing is that with the restriction enabled, users can create files on their desktop only not by copy/pasting....
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now