Solved

/// <summary></summary> by default please

Posted on 2011-02-24
5
409 Views
Last Modified: 2012-06-27
I'm using VS 2010, and the default for adding the XML comments are like this:
/// <summary>
///
/// </summary>

I would like them to default to this:
/// <summary></summary>

manually setting this is not the end of the world, but it does get tedious.

Reason for this preference:
 - When you minimize the XML Comments, it reduces to this:
/// <summary> [...]
 - If it is on one line, you get it to minimize to this:
/// <summary>Used to process data :(</summary> [...]

0
Comment
Question by:hpdvs2
  • 3
5 Comments
 
LVL 3

Expert Comment

by:kraiven
ID: 34971990
If you're happy to lose all of the automatically produced parameter and return values that the expanded comment gives you then I would suggest writing your own code snippet. It's really easy and would give you exactly the functionality you want.

See http://msdn.microsoft.com/en-us/library/ms165394%28VS.80%29.aspx
0
 
LVL 8

Author Comment

by:hpdvs2
ID: 34972154
While that does provide a partial solution, the key purpose of this is to reduce some of the overhead while still allowing the minimized XML comment to be easily read.

In my opinion, having to rewrite the additional comments portions would require more work than altering the initial line.

Thanks.
0
 
LVL 11

Accepted Solution

by:
Sudhakar Pulivarthi earned 500 total points
ID: 34978510
Hi,
It is good to use GhostDoc Plugin for VS 2010/2005 which writes the standard comments automatically. quite interesting one!!!
U can download it from below link.
http://submain.com/download/ghostdoc/
0
 
LVL 8

Author Comment

by:hpdvs2
ID: 34980375
Sudhakar, your answer worked.  I was able to use to free edition to do this.  One additional note, by default, Ghost doc is not setup like this.  I had to go in to the Tools=>Ghost Doc=>Options, then from the Ghost doc config window, select the "Options" tab, and check "Keep single line...";
0
 
LVL 8

Author Closing Comment

by:hpdvs2
ID: 34980389
Just adding this line, to get this behavior out of the program, you need to go in to the menu Tools=>Ghost Doc=>Options, then from the Ghost doc config window, select the "Options" tab, and check "Keep single line...";
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Check my code out(2) 2 53
Please explain "Multi-Tenant Services" 5 62
Resolve Dependency Issues 4 44
Anyway to make "All" the default in the dropdown? 6 34
This article introduced a TextBox that supports transparent background.   Introduction TextBox is the most widely used control component in GUI design. Most GUI controls do not support transparent background and more or less do not have the…
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
In this video I am going to show you how to back up and restore Office 365 mailboxes using CodeTwo Backup for Office 365. Learn more about the tool used in this video here: http://www.codetwo.com/backup-for-office-365/ (http://www.codetwo.com/ba…
Video by: Mark
This lesson goes over how to construct ordered and unordered lists and how to create hyperlinks.

912 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now