Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Netbackup Error "Network Read Failed(42)" When Backing up Exchange 2010

Posted on 2011-02-24
6
Medium Priority
?
6,243 Views
Last Modified: 2012-05-11
We have just implimented Exchange 2010 on two Windows 2008 R2 servers in a DAG cluster.  The servers are at different sites, the server at our main site is connected to our Equallogic iSCSI SAN while the server at our other site has local SCSI disks.  

We are using Netbackup 7.0.1 and when I initially setup the backups of Exchange with Netbackup it worked fine.  We have recently migrated our mail into Exchange and now we are having problems with the backup of the server at our main site, the backups are failing with a "network read failed(42)" error.

If anyone has any ideas on what may be causing this I would apprecaite them.

Thanks

Here is the information from Netbackup:

First Job (that creates the snapshot):
19/02/2011 1:04:18 PM - requesting resource Windows-DDR1
19/02/2011 1:04:18 PM - requesting resource cypress.NBU_CLIENT.MAXJOBS.EMPIRE
19/02/2011 1:04:18 PM - requesting resource cypress.NBU_POLICY.MAXJOBS.Exchange
19/02/2011 1:04:19 PM - granted resource cypress.NBU_CLIENT.MAXJOBS.EMPIRE
19/02/2011 1:04:19 PM - granted resource cypress.NBU_POLICY.MAXJOBS.Exchange
19/02/2011 1:04:19 PM - granted resource MediaID=@aaaam;Path=\\192.168.1.10\backup\Netbackup\Windows;MediaServer=cypress
19/02/2011 1:04:19 PM - granted resource Windows-DDR1
19/02/2011 1:04:20 PM - estimated 0 Kbytes needed
19/02/2011 1:04:20 PM - begin Parent Job
19/02/2011 1:04:20 PM - begin Unknown Type, Step By Condition
Status 0
19/02/2011 1:04:20 PM - end Unknown Type, Step By Condition; elapsed time: 00:00:00
19/02/2011 1:04:20 PM - begin Unknown Type, Read File List
Status 0
19/02/2011 1:04:20 PM - end Unknown Type, Read File List; elapsed time: 00:00:00
19/02/2011 1:04:20 PM - begin Unknown Type, Create Snapshot
19/02/2011 1:04:20 PM - started
19/02/2011 1:04:21 PM - started process bpbrm (16260)
19/02/2011 1:04:25 PM - begin Create Snapshot
19/02/2011 1:05:00 PM - Info bpbrm(pid=16260) from client EMPIRE: TRV - snapshot preparation successful    
19/02/2011 1:32:35 PM - Error bpbrm(pid=16260) from client EMPIRE: ERR - Send bpfis state from cypress failed. status = 25
19/02/2011 1:32:35 PM - end Create Snapshot; elapsed time: 00:28:10
19/02/2011 1:32:38 PM - end writing
Status 0
19/02/2011 1:32:38 PM - end Unknown Type, Create Snapshot; elapsed time: 00:28:18
19/02/2011 1:32:38 PM - begin Unknown Type, Policy Execution Manager Preprocessed
Status 42
19/02/2011 1:38:26 PM - end Unknown Type, Policy Execution Manager Preprocessed; elapsed time: 00:05:48
19/02/2011 1:38:26 PM - begin Unknown Type, Stop On Error
Status 0
19/02/2011 1:38:26 PM - end Unknown Type, Stop On Error; elapsed time: 00:00:00
19/02/2011 1:38:26 PM - begin Unknown Type, Delete Snapshot On Exit
19/02/2011 1:38:26 PM - begin Unknown Type, Delete Snapshot On Exit
19/02/2011 1:38:26 PM - started process bpbrm (18212)
19/02/2011 1:38:49 PM - end writing
Status 0
19/02/2011 1:38:49 PM - end Unknown Type, Delete Snapshot On Exit; elapsed time: 00:00:23
Status 42
19/02/2011 1:38:49 PM - end Unknown Type, Delete Snapshot On Exit; elapsed time: 00:00:23
network read failed(42)

Second Job (that performs the backup and is called by the first job):
19/02/2011 1:38:02 PM - requesting resource Windows-DDR1
19/02/2011 1:38:02 PM - requesting resource cypress.NBU_CLIENT.MAXJOBS.EMPIRE
19/02/2011 1:38:02 PM - requesting resource cypress.NBU_POLICY.MAXJOBS.Exchange
19/02/2011 1:38:02 PM - granted resource cypress.NBU_CLIENT.MAXJOBS.EMPIRE
19/02/2011 1:38:02 PM - granted resource cypress.NBU_POLICY.MAXJOBS.Exchange
19/02/2011 1:38:02 PM - granted resource MediaID=@aaaam;Path=\\192.168.1.10\backup\Netbackup\Windows;MediaServer=cypress
19/02/2011 1:38:02 PM - granted resource Windows-DDR1
19/02/2011 1:38:02 PM - estimated 0 Kbytes needed
19/02/2011 1:38:02 PM - started process bpbrm (16644)
19/02/2011 1:38:09 PM - connecting
19/02/2011 1:38:12 PM - connected; connect time: 00:00:03
19/02/2011 1:38:18 PM - Warning bptm(pid=16556) could not set TCP_NODELAY on socket 532, h_errno = 10038  
19/02/2011 1:38:19 PM - Warning bptm(pid=17804) could not set non-blocking on socket 532, An operation was attempted on something that is not a socket.
19/02/2011 1:38:19 PM - Error bptm(pid=17804) socket operation failed - 10038 (at child.c.1294)      
19/02/2011 1:38:19 PM - Error bptm(pid=17804) unable to perform read from client socket, connection may have been broken
19/02/2011 1:38:19 PM - begin writing
19/02/2011 1:38:26 PM - end writing; write time: 00:00:07
network read failed(42)
0
Comment
Question by:Shane0
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
6 Comments
 
LVL 5

Expert Comment

by:ccns
ID: 34974285
i know it may be a pain, but have your tried uninstalling and resinstalling netbackup?
could be soem corrupted files..
someone had the smae issue you were having here is the resolution :


I uninstalled the client completely. Deleted all references to NetBackup in the registry, and re-installed the client. I rebooted the box between each step to keep it clean. It now works perfectly.
0
 

Author Comment

by:Shane0
ID: 34974782
I haven't tried that yet, I'll give it a try.
0
 

Author Comment

by:Shane0
ID: 34975455
Uninstalling and reinstalling the client didn't work unfortunately.
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 

Accepted Solution

by:
Shane0 earned 0 total points
ID: 35010378
I was able to fix this by removing two registry keys on my Netbackup server:

Remove the following registry keys from, [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AFD\Parameters],
"DefaultSendWindow"=dword:00040000
"DefaultReceiveWindow"=dword:00040000
The AFD key specifies parameters for the kernel mode driver Afd.sys which is used to support Windows socket applications.  
The "DefaultSendWindow" and "DefaultReceiveWindow" keys are not in the registry of the client, Empire.
0
 

Author Comment

by:Shane0
ID: 35010397
Backup is now successful
0
 

Author Closing Comment

by:Shane0
ID: 35045631
I worked with Support to solve this problem.
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam® is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to deal with a specific error when using the Enable-RemoteMailbox cmdlet to create a mailbox in the cloud-based service, for an existing user in an on-premises Active Directory.
"Any files you do not have backed up in at least two [other] places are files you do not care about."
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question