• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 787
  • Last Modified:

Connection to SQL Server 2005 fails randomly

We have a clientside program, residing on a user’s local machine that runs multiple read-only queries against an MS SQL Server 2005 database running on an internet server running Windows Server 2008.  The connection fails at random delivering up this error message.

[DBNETLIB][ConnectionWrite(send()).]General network error.  Check your network documentation.

We tried mounting the database on a secondary server running Windows Server 2003 and SQL Server 2000 and the problem disappeared.  

Feeling the problem related to the server configuration, we disabled the chimney, thus:

netsh int  tcp set global chimney=disabled

When that failed to fix the problem, we turned off the SynAttackProtect feature by altering the setting in the Windows registry.  

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\SynAttackProtect=00000000

That didn’t solve the problem.

We are open to any suggestions at this point.

Thank you,

Eric Wilson
0
cerebrumconsulting
Asked:
cerebrumconsulting
  • 3
2 Solutions
 
robertg34Commented:
make sure you have gone through this procedure of opening the ports on the windows 2008 server.  SQL ports are closed by default:
http://support.microsoft.com/kb/968872

0
 
cerebrumconsultingAuthor Commented:
We have opened port 1433 and we do get a connection often. The failure is random.  It just pops up after we have already run queries successfully.  Are there other ports that we need to open? Would closed ports cause a random or occasional error like this?

Thanks,

Eric
0
 
upalakshithaCommented:
try this
1. Click Start, click Run, type regedit, and then click OK.
2. Locate and then click the following registry subkey:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

3. In the right pane, make sure that the DisableTaskOffload registry
entry exists. If this entry does not exist, follow these steps to add the entry:

a. On the Edit menu, point to New, and then click DWORD Value.
b. Type DisableTaskOffload, and then press ENTER.

4. Click DisableTaskOffload.
5. On the Edit menu, click Modify.
6. Type 1 in the Value data box, and then press ENTER.
7. Exit Registry Editor.

[note]DisableTaskOffload is by default set to 0 on 2003 Systems and on 2008 Server it is set to 0xff = 255 which is neither 0 nor 1 , basically, vista or 2k8 systems TCP/IP stack does not configure this setting, hence stopping all applications which depend on this flag to ignore it.
0
 
cerebrumconsultingAuthor Commented:
Thanks.  We'll try this today.  Since it's a randomly occuring situation, it will require a period of testing before we can be sure that the problem has been fixed.

 
0
 
cerebrumconsultingAuthor Commented:
Thanks.  We haven't had a recurrence of the error since applying this solution, so it seems this was the solution we'd been looking for.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now