• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1093
  • Last Modified:

IIS 6 grabing all IPs

I have 4 websites in IIS6, and I've bound them to a specific IP address.  But I have another applicattion Campaign Enterprise that I've bound on a different IP address, but when I start both services, IIS Admin and CE, IIS is still somehow grabing all IP addresses.
0
Dan
Asked:
Dan
  • 6
  • 2
  • 2
1 Solution
 
rawinnlnx9Commented:
Is each IP assigned in the NIC? If not then I suppose IIS would. I seem to recall that when you create a site it listens to "all IP port 80" or something like that. You have to replace that with the LANIP you wish it to listen on.
0
 
rawinnlnx9Commented:
Yeah, it listens to "All unassigned port 80". So you'd have to add the IP's to the network adapter and then set up each of your sites on each IP using IIS.
0
 
DanNetwork EngineerAuthor Commented:
Yes, I assigned all 3 IPs on the NIC. I made sure that each website used only 1 IP address, and not all assigned. I did that already.
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
Dave_DietzCommented:
Under Windows Server 2003 http.sys will grab all IP addresses on Port 80 unless explicitly told not to. Under IIS 5 this was controlled by an entry in the metabase, with IIS 6 it is actually a registry setting.

With IIS 6 /Server 2003 you can change this behavior using the httpcfg.exe utility (part of the Support Tools you can install from the OS CD or download from Microsoft).  

Once you have the utility you would use a command line similar to this:

httpcfg set iplisten /i aaa.bbb.ccc.ddd

Do this once for each IP address you want IIS to listen on and leave out the IP you want to use for your CE application.

Full documentation on this utility can be found here:
http://technet.microsoft.com/en-us/library/cc787508(WS.10).aspx

Dave Dietz
0
 
DanNetwork EngineerAuthor Commented:
Thanks, I tried that, but it doesn't work.  Now how do I reverse that command, because my IIS now is not working.
0
 
DanNetwork EngineerAuthor Commented:
the error message I got when I typed the httpcfg set iplisten ....
The error message is:
hpptinialize failed with 2.

What does that mean?
0
 
DanNetwork EngineerAuthor Commented:
here's the error message I'm getting when trying to start IIS, it just doesn't work.
iis.JPG
0
 
Dave_DietzCommented:
httpcfg query iplisten
will show the current value of the setting

httpcfg /delete /i aaa.bbb.ccc.ddd
will remove a specific entry from the list

Can you post the exact command lines you used to set the IPListen table?

Dave Dietz
0
 
DanNetwork EngineerAuthor Commented:
I tried the comand you said "httpcfg query iplisten" and I get the following:
HttpInitialize failed with 2.

I just restarted the server and my websites work fine now, so that's good, I'm happy.

I will try your commands again on Monday, as we're closed tomorrow.
I'll let you know on Monday how it went.

Thanks, Dan
0
 
DanNetwork EngineerAuthor Commented:
Thanks for the answer, that did the trick, I needed to get IIS to listen only on those IP addresses. Thanks again so much!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

  • 6
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now