Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3013
  • Last Modified:

Chrome can't browse my HTTPS sites - all other browsers has no problems

Hi all,

Chrome has problem browsing my HTTPS sites. First time I browse my site, it never gets loaded - Chrome just spins. If I try again a minute later, Chrome loads it fine. If I let it be for half an hour, problem starts all over again.

I've tested on several Pc/Macs with Chrome 9.0.597.98 (on XP x86 and Win7 x64) and 10.0.648.82 (Mac) - all have the problem. I've also tested on different networks.

If I use IE, FireFox and Safari I have no problems.

My websites is on IIS 7.5 (Windows Server 2008 R2) behind a Forefront TMG 2010 server.

Any idea why Chrome is "freezing" on my HTTPS sites?

Thanks!

Mojo
0
M_O_J_O
Asked:
M_O_J_O
  • 5
  • 5
  • 2
1 Solution
 
Glen KnightCommented:
If you do plain old HTTP does it still freeze?


Is there anything "special" about the site?
0
 
M_O_J_OAuthor Commented:
@demazter

No problems with HTTP sites at all.

No - nothing special.

I'm really puzzled by this.
0
 
Glen KnightCommented:
Does the same site with http instead of https work OK?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
M_O_J_OAuthor Commented:
@demazter:

Spooky ... if I remove "Notify HTTP users to use HTTPS instead" on my TMG 2010 Webpublishing rule, then site works fine with HTTP.

So to answer your question - yes it works fine on HTTP but not HTTPS.

Thanks.
0
 
Glen KnightCommented:
Interesting.

And if you access it directly without using FTMG does that work?
0
 
kevp75Commented:
check the certificate.  is it from a reputable source?
0
 
M_O_J_OAuthor Commented:
Ok I found the problem...

http://social.technet.microsoft.com/Forums/en-US/Forefrontedgegeneral/thread/fb615e18-9cf8-48c3-92b9-94d459bd69aa/

It seams like Google has implemented something called "SSL False Start" and that is on by default and it doesn't work with TMG 2010 ... HMMMMMMM!!!!!

After I added the switch ... -disable-ssl-false-start ... to the chrome shortcut everything is fine.

Microsoft says they doen't want to make TMG compatible with "SSL False Start" since it's not a "standard".

Wtf? So Google is implementing a technology that Microsoft doesn't support and my customers (using google Chrome) can't see my sites.

:((((((

What do you think guys? Is it Google or Microsoft to blame???

Thanks all for your help!

Mojo
0
 
Glen KnightCommented:
I would say they are both to blame.

They are direct competitors in the browser, search & OS markets.  They are not likely to help each other.
0
 
M_O_J_OAuthor Commented:
Well this has caused me 5 days/nights of trouble and a bill of €360 to Microsoft for finding this solution. Hmmmm.
0
 
Glen KnightCommented:
Well, thank you for sharing it with us.  Others will benefit from your findings.
0
 
kevp75Commented:
i agree with demazter, they are definately both to blame
0
 
M_O_J_OAuthor Commented:
Because I was the one to solve the problem.
0

Featured Post

Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

  • 5
  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now