Solved

ASA 5505, one VPN group not able to ping

Posted on 2011-02-24
3
1,446 Views
Last Modified: 2012-05-11
I have a group Vendor_Limited, they can connect to the VPN, get assigned an IP, but not able to ping 10.41.109.10 (The only IP I want them to access.) (VPN user ip pool 192.168.4.0)

I am not well versed on Cisco.. so I'm missing something, but not sure what.

What Access list is used for the Vendor_Limited users?
What do I have wrong preventing them to ping/connect to the node 10.41.109.10?

Thanks for any help!!

 
: Saved
:
ASA Version 8.3(2)4 
!
hostname sanjoseasa1
enable password xxxxxx encrypted
passwd xxxxx encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.41.109.241 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address xx.xx.xx.210 255.255.255.xx 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa832-4-k8.bin
ftp mode passive
clock timezone PST -8
clock summer-time PDT recurring
object network obj_any 
 subnet 10.41.109.0 255.255.255.0
object network Chico 
 subnet 10.254.157.0 255.255.255.0
object network Bryan 
 host 10.41.109.150
object network NETWORK_OBJ_192.168.3.0_24 
 subnet 192.168.3.0 255.255.255.0
object network NETWORK_OBJ_10.41.109.0_24 
 subnet 10.41.109.0 255.255.255.0
object network Webserver 
 host 10.41.109.97
object network cymphonix 
 host 10.41.109.242
object-group network DM_INLINE_NETWORK_1
 network-object 10.41.109.0 255.255.255.0
 network-object object Chico
object-group network DM_INLINE_NETWORK_2
 network-object 10.28.31.0 255.255.255.0
 network-object object obj_any
object-group network DM_INLINE_NETWORK_3
 network-object 10.28.31.0 255.255.255.0
 network-object 10.41.109.0 255.255.255.0
object-group network DM_INLINE_NETWORK_4
 network-object 10.28.31.0 255.255.255.0
 network-object 10.41.109.0 255.255.255.0
 network-object 192.168.3.0 255.255.255.0
access-list outside_access_in extended permit ip any any log 
access-list outside_access_in extended permit ip 10.254.157.0 255.255.255.0 object-group DM_INLINE_NETWORK_3 
access-list inside_access_out extended permit ip any any log notifications 
access-list outside_1_cryptomap extended permit ip object-group DM_INLINE_NETWORK_2 object Chico 
access-list outside_1_cryptomap extended permit ip any 10.254.157.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip 10.41.109.0 255.255.255.0 192.168.3.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip 10.28.31.0 255.255.255.0 192.168.3.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip host 10.41.109.10 192.168.4.0 255.255.255.0 log 
access-list inside_nat0_outbound extended permit ip host 10.41.109.1 192.168.3.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip host 10.41.109.10 192.168.3.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip host 10.41.109.1 192.168.4.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip 10.41.109.0 255.255.255.0 10.254.157.0 255.255.255.0 
access-list Anderson_splitTunnelAcl standard permit 10.41.109.0 255.255.255.0 
access-list Anderson_splitTunnelAcl standard permit 10.28.31.0 255.255.255.0 
access-list Anderson_splitTunnelAcl standard permit 192.168.3.0 255.255.255.0 
access-list inside_access_in extended permit ip any any log debugging interval 600 
access-list dmz_access_in extended permit ip any any 
access-list test_splitTunnelAcl standard permit 10.41.109.0 255.255.255.0 
access-list outside_1_cryptomap_1 extended permit ip object-group DM_INLINE_NETWORK_4 object Chico 
access-list Vendor standard permit host 10.41.109.10 
access-list Vendor standard permit host 10.41.109.12 
access-list outside_access_in_1 extended permit tcp any object Webserver log notifications 
access-list outside_access_in_1 extended deny udp any object Webserver log notifications 
pager lines 24
logging enable
logging asdm notifications
logging from-address bryan@courtesychevrolet.com
logging recipient-address bryan@courtesychevrolet.com level alerts
mtu inside 1500
mtu outside 1500
ip local pool vpn_usr 192.168.3.1-192.168.3.200 mask 255.255.255.0
ip local pool vpn_usr_vendor 192.168.4.1-192.168.4.20 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-641.bin
no asdm history enable
arp timeout 14400
nat (inside,outside) source static any any destination static Chico Chico
nat (inside,outside) source static DM_INLINE_NETWORK_1 DM_INLINE_NETWORK_1 destination static NETWORK_OBJ_192.168.3.0_24 NETWORK_OBJ_192.168.3.0_24
nat (inside,outside) source static NETWORK_OBJ_10.41.109.0_24 NETWORK_OBJ_10.41.109.0_24 destination static Chico Chico
nat (inside,outside) source static DM_INLINE_NETWORK_4 DM_INLINE_NETWORK_4 destination static Chico Chico
!
object network obj_any
 nat (inside,outside) dynamic interface
object network Bryan
 nat (inside,outside) static xx.xx.xx.214 dns
object network Webserver
 nat (inside,outside) static xx.xx.xx.211 dns
object network cymphonix
 nat (inside,outside) static xx.xx.xx.213 dns
access-group outside_access_in_1 in interface outside
route outside 0.0.0.0 0.0.0.0 12.205.160.209 1
route inside 10.28.31.0 255.255.255.0 10.41.109.254 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.41.109.0 255.255.255.0 inside
http 192.168.3.0 255.255.255.0 inside
http redirect outside 80
http redirect inside 80
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set Vendors esp-3des esp-md5-hmac 
crypto ipsec transform-set Vendors mode transport
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs 
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 60 set pfs 
crypto dynamic-map outside_dyn_map 60 set transform-set ESP-3DES-SHA
crypto map outside_map 1 match address outside_1_cryptomap_1
crypto map outside_map 1 set peer 173.14.72.53 
crypto map outside_map 1 set transform-set ESP-AES-256-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 5
 authentication pre-share
 encryption aes-256
 hash md5
 group 5
 lifetime 86400
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 11
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 86400
crypto isakmp policy 20
 authentication rsa-sig
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 30
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 40
 authentication crack
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 50
 authentication rsa-sig
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 60
 authentication pre-share
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 70
 authentication crack
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 80
 authentication rsa-sig
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 100
 authentication crack
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 110
 authentication rsa-sig
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 65535
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
no crypto isakmp nat-traversal
client-update enable
telnet 10.41.109.0 255.255.255.0 inside
telnet 192.168.3.0 255.255.255.0 inside
telnet 172.16.10.0 255.255.255.0 outside
telnet 0.0.0.0 0.0.0.0 outside
telnet timeout 30
ssh 10.41.109.0 255.255.255.0 inside
ssh 192.168.3.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
management-access inside
dhcpd auto_config outside
!
dhcpd address 10.41.109.245-10.41.109.254 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
 enable outside
group-policy DfltGrpPolicy attributes
 banner value Get in, do what is needed.  Then LOG OUT!
 dns-server value 12.127.17.71 12.127.17.72
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value Anderson_splitTunnelAcl
 webvpn
  svc dpd-interval client none
  svc dpd-interval gateway none
  deny-message value Login was successful, but because certain criteria have not
group-policy Vendor_Limited internal
group-policy Vendor_Limited attributes
 vpn-simultaneous-logins 3
 vpn-idle-timeout 30
 vpn-tunnel-protocol IPSec l2tp-ipsec 
 group-lock value Vendor_Limited
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value Vendor
group-policy GroupPolicy1 internal
group-policy GroupPolicy1 attributes
 vpn-tunnel-protocol IPSec 
group-policy Anderson internal
group-policy Anderson attributes
 dns-server value 12.127.17.71 12.127.17.72
 vpn-simultaneous-logins 5
 vpn-idle-timeout 60
 vpn-tunnel-protocol IPSec l2tp-ipsec webvpn
 group-lock value Anderson
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value Anderson_splitTunnelAcl

SNIP

 vpn-group-policy Anderson
tunnel-group DefaultL2LGroup ipsec-attributes
 pre-shared-key *****
tunnel-group Anderson type remote-access
tunnel-group Anderson general-attributes
 address-pool (inside) vpn_usr
 address-pool vpn_usr
 default-group-policy Anderson
tunnel-group Anderson ipsec-attributes
 pre-shared-key *****
tunnel-group Vendor_Limited type remote-access
tunnel-group Vendor_Limited general-attributes
 address-pool vpn_usr_vendor
 default-group-policy Vendor_Limited
tunnel-group Vendor_Limited ipsec-attributes
 pre-shared-key *****
tunnel-group 173.14.72.xx type ipsec-l2l
tunnel-group 173.14.72.xx ipsec-attributes
 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
  inspect icmp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:4f1fbe98fdbf9901f60aa894970dcaa9
: end
asdm image disk0:/asdm-641.bin
no asdm history enable

Open in new window

0
Comment
Question by:Bryan_
  • 2
3 Comments
 
LVL 4

Accepted Solution

by:
ullas_unni earned 500 total points
ID: 34975730
object network VPN_POOL
 range 192.168.4.1 192.168.4.20
!
object network SERVER
 host 10.41.109.10
!
nat (inside,outside) source static SERVER SERVER destination static VPN_POOL VPN_POOL
0
 

Author Comment

by:Bryan_
ID: 34976465
The response when I tried the commands:

 
Result of the command: "object network VPN_VENDOR"

The command has been sent to the device


Result of the command: "range 192.168.4.1 192.168.4.20"

Addresses overlap with existing localpool range


Result of the command: "object network ADP"

The command has been sent to the device


Result of the command: "host 10.41.109.10"

The command has been sent to the device


Result of the command: "nat (inside,outside) source static ADP ADP destination static VPN_VENDOR VPN_VENDOR"

ERROR: empty object/object-group(s) detected. NAT Policy is not downloaded

Open in new window


I am guessing the VPN object created is overlapping another object?

I added the server object,

Then...

nat (inside,outside) source static SERVER SERVER destination static object network NETWORK_OBJ_192.168.4.0_24 object network NETWORK_OBJ_192.168.4.0_24

Now I can ping!!

Thank you.
0
 

Author Closing Comment

by:Bryan_
ID: 34976472
Was just off by an object, but was the answer I needed
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Suggested Solutions

Juniper VPN devices are a popular alternative to using Cisco products. Last year I needed to set up an international site-to-site VPN over the Internet, but the client had high security requirements -- FIPS 140. What and Why of FIPS 140 Federa…
I've written this article to illustrate how we can implement a Dynamic Multipoint VPN (DMVPN) with both hub and spokes having a dynamically assigned non-broadcast multiple-access (NBMA) network IP (public IP). Here is the basic setup of DMVPN Pha…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now