Solved

crystal reports server 2008

Posted on 2011-02-24
6
387 Views
Last Modified: 2012-05-11
I have just downloaded and install crystal reports 2008 on a 32 windows 2003 server.  After installing i have added some reports to CMC and try to run them.  i always get failures when running these reports

Error in File ~tmp102467f6625dae0.rpt: Failed to load database information.

I have added ODBC connections to our sql 2005 databases and also to our account software MAS200.  I doesn't seem to matter what i use for settings in the database config area of CR CMC it still doesn't work.  The same report will give me the correct data while in preview mode from the CR designer if i refresh.  Please help.  I am a newbie at Crystal reports server and I appreciate any info you experts can provide.  Again much thanks!
0
Comment
Question by:IKtech
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 100

Expert Comment

by:mlmcc
ID: 34976249
Are you using 2 different databases?

mlmcc
0
 
LVL 26

Accepted Solution

by:
Kurt Reinhardt earned 500 total points
ID: 34980430
Do you have Crystal Reports installed on the same machine that's running the Crystal Reports Server software? If so, can you run the report successfully from Crystal Reports on the server machine?  If so, then there's a configuration problem with Crystal Reports Server itself.  If not, then there's a problem with the actual server configuration.

In regards to the server, you stated "I have added ODBC connections to our sql 2005 databases and also to our account software MAS200". Did you do this through the ODBC Administrator or do you mean that you simply tried to connect to them through the CMC? They need to be created in the ODBC Administrator, typically as System DSNs, and they need to be the exact same name and case as you have on your development machine.  If your DNS is named "MyDSN" on your development machine then it needs to be identical on the server - "mydsn" won't cut it.

In regards to the data configuration for each report in the CMC, it should look like the attached screenshot. Depending how your ODBC connection was created, the connection may also specify a database owner.

~Kurt
databaseconfig2.jpg
0
 
LVL 3

Author Comment

by:IKtech
ID: 34981138
mlmcc

For the report i am running i am only using one database on a sql 2005 machine.  CMS Database is also on another server.

I have report designer running on the same machine as the crystal reports server and i can open the report in designer and refresh the data no problem.

I will verifiy the case on the dsn connections and yes i have created system dsn from the odbc administrator (they show tested successfully after i created them).  I will try to play with the DB config from CMC to see if i can get a different error or perhaps a report that works.

Also could either of you tell me why i can't get infoview .NET to launch?  i always get a 404 error page can't be displayed.
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 26

Assisted Solution

by:Kurt Reinhardt
Kurt Reinhardt earned 500 total points
ID: 34981522
There could be a number of reasons by .net infoview won't work, but it's most likely related to .net and/or asp.net not being properly configured for IIS.  You said it's installed on a 32-bit Windows 2003 server?  Most folks don't realize you basically have to prep the server to make sure it's ready for the install - Crystal Reports Server is an application server and requires a web server, too.

Can you verify .asp.net support is installed for the Web Server role in Server Manager?

~Kurt
0
 
LVL 3

Author Comment

by:IKtech
ID: 35009698
before i started the install for crystal i went to add remove programs and clicked add windows components.  I went through the steps to install IIS.  Is there an additional step for ASP.Net that i missed?

In Server manager IIS\ASP.net is configured (or so it states).
0
 
LVL 3

Author Comment

by:IKtech
ID: 35018995
I reinstalled from scratch and now all the items open including .net infoview.  I haven't set up any system DSNs yet but when i add a report from a users laptop, i have an item under data sources in the database configuration for the report.  Apparently this is info that is part of the report itself.  Should i see other datasources added to the list when i add system DSNs?  Is there any configuration within the CMC for adding other data sources?
0

Featured Post

Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Today is the age of broadband.  More and more people are going this route determined to experience the web and it’s multitude of services as quickly and painlessly as possible. Coupled with the move to broadband, people are experiencing the web via …
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question