What is the DNS and IIS prerequisite for Outlook Anywhere 2007 ?

Hi,

I just would like some clarification about which External hostname / DNS entries
that I need to publish in my external facing DNS server to enable Outlook Anywhere on my Exchange Server 2007 for external user:

1. ExCAS01.domain.com - Exchange CAS A Record
2. Autodiscover.domain.com - Autodiscover CNAME to the CAS Server above
3. _autodiscover._tcp.domain.com - SRV type record

and do I have to expect anything by typing this address in bowser "https://autodiscover.domain.com/AutoDiscover/AutoDiscover.xml" ?
because i get request time out at the moment.

here are the error log from https://testexchangeconnectivity.com [in the box].


Host Excas01.domain.com couldn't be resolved in DNS Exception details:
	Message: The requested name is valid, but no data of the requested type was found
	Type: System.Net.Sockets.SocketException
	Stack trace:
	at System.Net.Dns.GetAddrInfo(String name)
	at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
	at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
	at Microsoft.Exchange.Tools.ExRca.Tests.ResolveHostTest.PerformTestReally()

	Host autodiscover.domain.com couldn't be resolved in DNS Exception details:
	Message: The requested name is valid, but no data of the requested type was found
	Type: System.Net.Sockets.SocketException
	Stack trace:
	at System.Net.Dns.GetAddrInfo(String name)
	at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
	at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
	at Microsoft.Exchange.Tools.ExRca.Tests.ResolveHostTest.PerformTestReally()

	Attempting to locate SRV record _autodiscover._tcp.domain.com in DNS.
		The Autodiscover SRV record wasn't found in DNS.

Open in new window

LVL 1
jjozAsked:
Who is Participating?
 
Hilal1924Connect With a Mentor Commented:
Here is a cool whitepaper which explains what I said above.

http://technet.microsoft.com/en-us/library/bb332063(EXCHG.80).aspx
0
 
Hendrik WieseInformation Security ManagerCommented:
You will need to have an MX Record setup at your service provider.
0
 
Hendrik WieseInformation Security ManagerCommented:
Go to https://www.testexchangeconnectivity.com and let me know if you get any errors?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Hilal1924Commented:
I don't think you need to go to that trouble. It clearly seems to be a problem with your certificate. Have you added autodiscover.yourdomain.com to your certificate and installed it ?

when adding the A record to point to the (subdomain) autodiscover.domain.com, Outlook could not verify the domain name because it was not included in the cert

A work around for single domain certs is to create a SRV recordand have it point to exchange.domain.com on port 443.  This resolved the issue, when connecting internally and helped resolve OWA site not being up.  

For reference:
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_26616022.html

Best Of Luck.
0
 
Hilal1924Commented:
@Hendrik: MX records have got nothing to do with AutoDiscover service in MS Exchange.
0
 
Hilal1924Commented:
Here is another great article whic illustrates how to enable and properly configure AutoDiscover service.

http://www.msexchange.org/tutorials/Uncovering-New-Outlook-2007-Discover-Service.html
0
 
Hendrik WieseInformation Security ManagerCommented:
Sorry my bad, cross posting confusion.
0
 
AkhaterConnect With a Mentor Commented:
For outlook anywhere you will need just one A record in your External DNS zone that is somehow mapped (443) to your CAS server you don't need anything else DNS wise.

However if you also want autodiscover to work you will need one more DNS record named autodiscover.domain.com also pointing to you CAS server.

This been said you need also to pay attention that, certificate wise, both the mail.domain.com (first requirement) and autodiscover.domain.com are included in your exchange SAN certificate or it will not work

0
 
jjozAuthor Commented:
@Hendrik: of course my MX has been set already, I'm now using it for my OWA and ActiveSync for iPhone and several WinMo as well.

the error message was from the result of remote analyzer -  https://www.testexchangeconnectivity.com website.
0
 
AkhaterCommented:
the error you got is because you have no autodiscover record which is not the same as having Outlook anywhere
0
 
jjozAuthor Commented:
@Hilal: "Have you added autodiscover.yourdomain.com to your certificate and installed it ?" yes I have added it to the SAN and it was working for internal, I guess I must create one entry for my external DNS and then test it from my home internet to check if I can reach / read the XML from the Autodiscover URL.
0
 
jjozAuthor Commented:
@Akhater: many thanks for your clarification so I'll try to create the following records to match whatever I've got in my SAN certificate:

1. ExCAS01.domain.com - Exchange CAS A Record
2. Autodiscover.domain.com - Autodiscover CNAME to the CAS Server above
3. _autodiscover._tcp.domain.com - SRV type record

only number two (Autodiscover.domain.com) that is listed in my SAN certificate, do I need to create SAN entry for my ExCAS01.domain.com as well ?
0
 
AkhaterCommented:
it is better to have your CAS server name in your SAN it makes the config easier I think there is something missing


do you have any external DNS record that is mapped (443) to your CAS server ?
0
 
jjozAuthor Commented:
it seems that i can only ping my ActiveSync.domain.com and the ExHub01.domain.com which is in the certificate, the rest is not ping able.
0
 
AkhaterCommented:
are you talking from inside ? what I am concerned with in your external DNS configuration

how do you use owa from outside?
0
 
jjozAuthor Commented:
no, the OWA is only for inside only but not outside enabled, only activesync that is working both.

no I ping it from my home now for those two addresses (ActiveSync and the ExHub01) i can only get the external IP address but not the ping reply. (not even request timed out).
0
 
AkhaterCommented:
ok so if i get it correct you have in your external records

ActiveSync.domain.com pointing to the a real IP mapped to your CAS server
ExHub01.domain.com pointitn to the same real ip as active sync ??


It is normal not be able to ping from outside your firelwall will not allow it
0
 
jjozAuthor Commented:
yes for the ActiveSync as it is the CAS server, but in this case do i must create another record with the exact server name as above ?

ActiveSync.domain.com - A Record - Public IP - Yes already done
ExcCAS01.domain.com - A Record - Public IP (same as above) - not yet
Autodiscover.domain.com - A Record - Public IP (same as above) - not yet
_autodiscover._tcp.domain.com - SRV type record to port 443 as above IP - should I ?
0
 
AkhaterCommented:
Wow no there is no need to create excCAS01 nor the srv just create the autodisciver.... However there is still a lot of config to get outlook anywhere working
0
 
Hilal1924Connect With a Mentor Commented:
Here are the positives for you:

1. Bought a SAN and included the necessary domain names in it.
2. Public DNS configured.

Just start over:with this article and see if you have missed a step:

http://www.msexchange.org/tutorials/Uncovering-New-Outlook-2007-Discover-Service.html 

Best of Luck,
Hilal
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.