Solved

Url Routing in IIS 7 hosting environment : ASP.NET

Posted on 2011-02-25
2
1,073 Views
Last Modified: 2013-12-14
Hi

I am trying to implement ASP.NET URL routing using the System.Web.Routing. And this seems to work fine on my localhost however when I go live I am getting an IIS 7's 404 error (File not found). FYI the hosting uses Windows Server 2008 IIS7 and It has .NET Framework 3.5 SP1

I think this is making some difference in handling the routing mechanism. But I am not able to figure out whats exactly happening.

In Web.Config HttpModules  i have added the below setting

 <add name="UrlRoutingModule" type="System.Web.Routing.UrlRoutingModule, System.Web.Routing, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

Can anybody suggest how to resolve this.


 
0
Comment
Question by:GouthamAnand
2 Comments
 
LVL 13

Accepted Solution

by:
agarwalrahul earned 250 total points
Comment Utility
Code:

In the application's Web.config file, add the ASP.NET routing assembly to the assemblies element, as shown in the following example:

<add assembly="System.Web.Routing, Version=3.5.0.0,
  Culture=neutral,
  PublicKeyToken=31BF3856AD364E35"/>

If the application runs under IIS 6.0 or IIS 7.0 Classic mode, add the UrlRoutingModule class to the httpModules element, as shown in the following example:

<httpModules>
  <add name="UrlRoutingModule"
       type="System.Web.Routing.UrlRoutingModule,
             System.Web.Routing,
             Version=3.5.0.0,
             Culture=neutral,
             PublicKeyToken=31BF3856AD364E35"/>
</httpModules>
If the application runs under IIS 7.0 Integrated mode, add the UrlRoutingModule class to the modules element, as shown in the following example:

<system.webServer>
  <modules>
    <remove name="UrlRoutingModule" />
    <add name="UrlRoutingModule"
         type="System.Web.Routing.UrlRoutingModule,
               System.Web.Routing,
               Version=3.5.0.0,
               Culture=neutral,
               PublicKeyToken=31BF3856AD364E35"/>
  </modules>
</system.webServer>
If the application runs under IIS 7.0 Integrated mode, add the UrlRoutingHandler class to the handlers element as shown in the following example:

<system.webServer>
  <handlers>
    <add name="UrlRoutingHandler"
         preCondition="integratedMode"
         verb="*"
         path="UrlRouting.axd"
         type="System.Web.HttpForbiddenHandler,
               System.Web, Version=2.0.0.0,
               Culture=neutral,
               PublicKeyToken=b03f5f7f11d50a3a" />
  </handlers>
</system.webServer>


also read link page for reference

http://msdn.microsoft.com/en-us/library/cc668202.aspx
0
 

Author Closing Comment

by:GouthamAnand
Comment Utility
Thank for a timely reply. It is working fine in the server enviroment.
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

This is an article about my experiences with remote access to my clients (so that I may serve them) and eventually to my home office system via Radmin Remote Control. I have been using remote access for over 10 years and have been improving my metho…
Let’s list some of the technologies that enable smooth teleworking. 
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now