Solved

Exchange 2003 to Exchange 2010 Mail Issue

Posted on 2011-02-25
23
1,495 Views
Last Modified: 2012-05-11
We are having a problem with coexistence of exchange 2003 and 2010. Emails are working from 2003 to 2010 but when emailing a user in the exchange 2003 environment mails just sit in the Unreachable queue and say there is no route to the mailbox database?

The routing group conenctor is there between our front end and back end 2003 servers. I have removed and recreated a couple of times but the problem still exists.

What can i try?

Thanks
James
0
Comment
Question by:strat-col
  • 10
  • 5
  • 3
  • +2
23 Comments
 
LVL 4

Expert Comment

by:szichen
ID: 34978723
Hi James

Are you running your exchange 2010 server on windows server 2008?
0
 
LVL 21

Expert Comment

by:Hendrik Wiese
ID: 34978730
Have you setup another send connector to route emails to the exchange 2003 server?
0
 

Author Comment

by:strat-col
ID: 34978773
Hi,

Exchange 2010 is running on a Server 2008 R2 Server. I havent set up a send conenctor to the exchange 2003 server I have set up a send conenctor for * SMTP. Do i need to setup a send conenctor for internal? How would i do this to connect it to the 2003 server?

Thanks
James
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 
LVL 49

Expert Comment

by:Akhater
ID: 34978784
let me get this straight, you can email from 2k3 to 2k10 but not the other way around ?

Can you run
get-routinggroupconnector | fl and paste the results ?

thanks
0
 

Author Comment

by:strat-col
ID: 34978887
Yeah emails sent from exchange 2003 mailboxes are recieved by exchange 2010 mailboxes but exchange 2003 mailboxes do not recieve mail from exchange 2010 mailboxes.

Here is what running Get-RoutingGroupConenctor | fl gave:



RunspaceId                   : ff276b04-dad7-4224-898f-45b8e4d4f6ee
TargetRoutingGroup           : First Routing Group
Cost                         : 10
TargetTransportServers       : {VM-EXCHANGE, VM-WEBMAIL}
ExchangeLegacyDN             : /o=Stratford-upon-Avon College/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Con
                               figuration/cn=Connections/cn=Mail Connector
PublicFolderReferralsEnabled : True
SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
SourceTransportServers       : {VM-OWAMAIL}
HomeMTA                      : Microsoft MTA
HomeMtaServerId              : VM-OWAMAIL
MaxMessageSize               : unlimited
AdminDisplayName             :
ExchangeVersion              : 0.1 (8.0.535.0)
Name                         : Mail Connector
DistinguishedName            : CN=Mail Connector,CN=Connections,CN=Exchange Routing Group (DWBGZMFD01QNBJR),CN=Routing
                               Groups,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=St
                               ratford-upon-Avon College,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Strat-Co
                               l,DC=stratford,DC=ac,DC=uk
Identity                     : Mail Connector
Guid                         : a6924f80-3b17-46ed-b170-2734afa91777
ObjectCategory               : Strat-Col.stratford.ac.uk/Configuration/Schema/ms-Exch-Routing-Group-Connector
ObjectClass                  : {top, msExchConnector, msExchRoutingGroupConnector}
WhenChanged                  : 25/02/2011 10:32:48
WhenCreated                  : 25/02/2011 10:32:48
WhenChangedUTC               : 25/02/2011 10:32:48
WhenCreatedUTC               : 25/02/2011 10:32:48
OrganizationId               :
OriginatingServer            : VM-AD-02.Strat-Col.stratford.ac.uk
IsValid                      : True

RunspaceId                   : ff276b04-dad7-4224-898f-45b8e4d4f6ee
TargetRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
Cost                         : 10
TargetTransportServers       : {VM-OWAMAIL}
ExchangeLegacyDN             : /o=Stratford-upon-Avon College/ou=First Administrative Group/cn=Configuration/cn=Connect
                               ions/cn=Mail Connector
PublicFolderReferralsEnabled : True
SourceRoutingGroup           : First Routing Group
SourceTransportServers       : {VM-EXCHANGE, VM-WEBMAIL}
HomeMTA                      : Microsoft MTA
HomeMtaServerId              : VM-WEBMAIL
MaxMessageSize               : unlimited
AdminDisplayName             :
ExchangeVersion              : 0.1 (8.0.535.0)
Name                         : Mail Connector
DistinguishedName            : CN=Mail Connector,CN=Connections,CN=First Routing Group,CN=Routing Groups,CN=First Admin
                               istrative Group,CN=Administrative Groups,CN=Stratford-upon-Avon College,CN=Microsoft Exc
                               hange,CN=Services,CN=Configuration,DC=Strat-Col,DC=stratford,DC=ac,DC=uk
Identity                     : Mail Connector
Guid                         : 6886b1fb-96f0-4ce0-b462-1ae04703e5db
ObjectCategory               : Strat-Col.stratford.ac.uk/Configuration/Schema/ms-Exch-Routing-Group-Connector
ObjectClass                  : {top, msExchConnector, msExchRoutingGroupConnector}
WhenChanged                  : 25/02/2011 10:32:48
WhenCreated                  : 25/02/2011 10:32:48
WhenChangedUTC               : 25/02/2011 10:32:48
WhenCreatedUTC               : 25/02/2011 10:32:48
OrganizationId               :
OriginatingServer            : VM-AD-02.Strat-Col.stratford.ac.uk
IsValid                      : True



Thanks
James
0
 
LVL 21

Expert Comment

by:Hendrik Wiese
ID: 34978898
I suppose you used the following command to create the routing group:

New-RoutingGroupConnector -Name "Interop RGC" -SourceTransportServers "Ex2010Hub1.contoso.com" -TargetTransportServers "Ex2003BH1.contoso.com" -Cost 10 -Bidirectional $true -PublicFolderReferralsEnabled $true
0
 
LVL 49

Expert Comment

by:Akhater
ID: 34978899
ok you have routing groups from both sides, if you telnet ip of 2k3 25 from 2k10 what is the reply ??

what is the error in the queue ??


0
 
LVL 21

Expert Comment

by:Hendrik Wiese
ID: 34978902
Sorry did not refresh.
0
 

Author Comment

by:strat-col
ID: 34979278
I did create the conenctor using that command yes.

I get the following when using Telnet:

2003 Backend Server : 220 VM-Exchange.Strat-col.stratford.ac.uk Microsoft ESMTP MAIL Service Version: 6.0.3790.3959 ready at Fri, 25 Feb 2011 13:35:20 +0000

2003 Front End Server : 220 VM-WebMail.Strat-col.stratford.ac.uk SMTP Service Available BSC Fri, 25 Feb 2011 13:38:20 +0000

The errors in the Unreachable queue say 'There is currently no route to the mailbox database'. There are emails and PublicFolderDatabase objects in the queue


Thanks
James
0
 
LVL 16

Expert Comment

by:Auric1983
ID: 34979483
James,

A couple of things

1. Did you run the Exchange 2010 Best Practises Analyzer?? If you have a BES server in your environment it's highly likely that there are some security changes that need to be done.

2. Did you enable Anonymous on the receive connector on  your Exchange 2010?

Here is a really good transition guide for 2003 to 2010 http://milindn.files.wordpress.com/2010/01/rapid-transition-guide-from-exchange-2003-to-exchange-2010.pdf 
0
 

Author Comment

by:strat-col
ID: 34979532
Thanks for the reply.

We do have a BES server in our environment. I did run the Best practices analyzer but there wasnt any obvious errors. What security changes would need to be done?

Yes i did enable anonymous access.

That guide is the one ive been following its been very helpful indeed so far.

Thanks
James
0
 
LVL 49

Expert Comment

by:Akhater
ID: 34979551
James I suggest you follow this article for your error

http://technet.microsoft.com/en-us/library/cc411329(EXCHG.80).aspx

if you get stuck let me know
0
 
LVL 16

Expert Comment

by:Auric1983
ID: 34979560
James,

The security changes are related to permission inheritance on your Exchange 2003 information store.

In Exchange System Manager (2003) click on the properties & "security" tab of the server.  There is a checkbox in the advanced permissions section that says "Allow inheritable permission..."

With the BES this setting is usually unchecked.

Once that change has been done just restart your 2003 information store
0
 

Author Comment

by:strat-col
ID: 34979687
I have checked the security and the check box was ticked.

I am having a look at the microsoft article but the 3rd step of the procedure There are no listings for the recipient mailbox store on the 2003 server?

Thanks
James
0
 
LVL 49

Expert Comment

by:Akhater
ID: 34979758
proceed to step 4, if enheritable permissions is not checked check it
0
 

Author Comment

by:strat-col
ID: 34979830
I have moved on and inheritable permissions were ticked. Im now at step 7a of the 'Folder Hierarchie creation as the folder was missing. There is no storage group listed under the information store for the 2010 server am i missing something?

Thanks
James
0
 

Author Comment

by:strat-col
ID: 34980237
I have managed to follow the microsoft instructions. All security was fine and I setup the folder hierarchies etc but it still is not working

Thanks
James
0
 
LVL 4

Expert Comment

by:szichen
ID: 34984694
Hi James

Do you have a smart host on the 2003 SMTP virtual server? If so, remove it.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 34984706
did you restart your server after the changes ?
0
 
LVL 16

Expert Comment

by:Auric1983
ID: 34987888
You could also try removing and recreating the routing group connectors

0
 

Author Comment

by:strat-col
ID: 34995119
As far as I can tell there is no smart host on the 2003 SMTP virtual server how would i double check this? I have restarted all servers numerous times. I have also removed and recreated the connector numerous times but with no luck.

Thanks
James
0
 

Accepted Solution

by:
strat-col earned 0 total points
ID: 34998483
I have now managed to resolve this problem. I added the 2 2010 servers into the Exchange Domain Servers group in Active Directory. I then removed the routing group connector and created a new one. All objects in the queue then left the queue and were delivered.

Thanks
James
0
 

Author Closing Comment

by:strat-col
ID: 35042565
Solved by adding 2010 machine accounts into exchange domain servers in active directory
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
Read this checklist to learn more about the 15 things you should never include in an email signature.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question