Solved

Not able to create a site in wss 3.0 using custom site template

Posted on 2011-02-25
16
965 Views
Last Modified: 2012-05-11
Hi,
I want to create a site in wss 3.0 using custom site template.For achieving this , i followed the given below steps:
1.I have downloaded an stp file and uploaded it to the site template gallery.
Note: Also want to mention that the stp file which i have downloaded was present under the custom tab while creating the site.
2.After doing this i tried to create a site using this custom site template .
3. Even the site got created ,but i am not able open it.
I am getting an error saying that" The template you have chosen is invalid or cannot be found"

Please guide me on this and also  do let me know how to do it by using sharepoint designer 2007 ?
0
Comment
Question by:techgyan
  • 9
  • 6
16 Comments
 
LVL 38

Expert Comment

by:Justin Smith
Comment Utility
Where did you get the template?  Are you sure it's a WSS template and not MOSS?
0
 

Author Comment

by:techgyan
Comment Utility
Actually i have saved a site as a template from my hosted sharepoint.And now i want to use that site template on my On-premise sharepoint server which is WSS 3.0.Also i was able to add that stp file on my sharepoint server and it even got displayed under Custom tab which is visible while creating new site or subsite.This means that i  am able to add that stp file on my On-premise wss 3.0 server.
But the issue is that i am not able to open that site.I could see that site listed under my home site ,but not able to open it.
Everytime i am getting an error:The template you have chosen is invalid or cannot be found"
0
 
LVL 38

Expert Comment

by:Justin Smith
Comment Utility
0
 
LVL 38

Expert Comment

by:Justin Smith
Comment Utility
Also take a look at the features in both environments to see if they match.  

On the new site, can you access the settings page by adding /_layouts/settings.aspx to the end of the url?
0
 

Author Comment

by:techgyan
Comment Utility
As per your advice, I have made a note of Site features present on both environment of sharepoint.
On BPOS , the Site features present are  
1.Office SharePoint Server Standard Feature  
2.Team Collaboration List
3.Translation Management Library
Above 3 are Activated
4.Office SharePoint Server Publishing - Not Activated

And on On-Premise WSS 3.0 , the site feature present is
1.Team Collaboration List ,and it  is activated

So , now please help guide me on these on what needs to be done further to open my site.
0
 
LVL 38

Expert Comment

by:Justin Smith
Comment Utility
From what I can tell, moving from Online to local SharePoint is only possible by backing up and restoring sites with SP Designer.  I can't confirm that using a template created from the Online version is supported.
0
 

Author Comment

by:techgyan
Comment Utility
Also like to inform you that now i have tried to acheive my backup and restore using sharepoint designer 2007.Here, i opened my site in sharepoint designer,clicked on Site tab under which i got an option of taking Backup Website .Backup is done ok.I have created .cmp file of my BPOS team site.My back up is stored on my local machine.
After this i created an empty site on On-premise wss 3.0 with the help of sharepoint designer 2007, where i want to restore my back up file.Then i followed the same steps ,opened my destination site on SPD ,clicked on Restore Website,browsed the file which i want to restore and clicked ok,Uploading your archive file got diplayed on spd and then immediately after this process ,i got an error msg saying that :" No read/write access to import location".I don't no why i am getting this error because on WSS 3.0 i have logged in as Administrator i.e which means i have full control.

Please guide me on this as soon as possible.
0
Want to promote your upcoming event?

Attending an event? Speaking at a conference? Or exhibiting at a tradeshow? Easily inform your contacts by using a promotional banner in your email signature. This will ensure your organization’s most important contacts are in the know.

 
LVL 38

Expert Comment

by:Justin Smith
Comment Utility
Did you make yourself a site collection admin on the empty site?
0
 

Author Comment

by:techgyan
Comment Utility
Yes, i have added my self as a site collection admin.
On the home page of wss 3.0 under Site Action->Site Settings->User and Permission->Site collection Administrators,my user name is listed out .But under empty site which is created using SPD 2007 , i didn't get the option of Site Collection Administrator.Here i could see only two options, People and Group and the other one is Advanced permission.
0
 
LVL 38

Accepted Solution

by:
Justin Smith earned 500 total points
Comment Utility
Set it through Central Admin.
0
 

Author Comment

by:techgyan
Comment Utility
Thanks for your reply.
I want to inform you that i have already added my username under Site Collection Administrator on WSS 3.0.

And as per your reply, i could understand that for Empty site , created using SPD 2007 on WSS 3.0,i need to add my Username under Site collection Administrator.But the thing is ,i get only 2 option under USer and Permission
1) People and Group
2)Advanced Permission

Here, i don't get "Site Collection Administrator" option as it is there under Top level team site of mine.

And if your saying that for empty site on WSS 3.0, i need to set it through Central Administration.I don't know how to do it.So, please help me out.
Kindly waiting for your reply.
0
 
LVL 38

Expert Comment

by:Justin Smith
Comment Utility
So are you trying to restore a site collection into a sub site?  This will not work.  You have to restore the site collection backup, into a new site collection, NOT a sub site on an existing site collection.
0
 

Author Comment

by:techgyan
Comment Utility
close the ticket
0
 
LVL 38

Expert Comment

by:Justin Smith
Comment Utility
Why is this being closed
0
 
LVL 38

Expert Comment

by:Justin Smith
Comment Utility
I think multiple things were done wrong, but I'll say that 35035509 should get the points.
0

Featured Post

Don't lose your head updating email signatures!

Do your end users still have the wrong email signature? Do email signature updates bore you or fill you with a sense of dread? You can make this a whole lot easier on yourself by trusting an Exclaimer email signature management solution. Over 50 million users do...so should you!

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Sharepoint server slow 4 26
Exchange 2013 sending anonymous spam 2 24
cached or not 5 37
Circular Logging 2 23
Utilizing an array to gracefully append to a list of EmailAddresses
Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now