Solved

Why am I able to access my storage drive on Ubuntu but can't make any changes?

Posted on 2011-02-25
27
356 Views
Last Modified: 2012-05-11
I'm using Ubuntu 10.10 and have two hard drives.  One as the primary and the other a storage drive.  I'm unable to make any changes to the storage drive.  I can read the files from this drive but that's it.  I don't remember making any specific changes but as a noob to Ubuntu I most likely changed something fiddling.  Thanks in advance.
0
Comment
Question by:1namyln
  • 13
  • 6
  • 4
  • +2
27 Comments
 
LVL 2

Expert Comment

by:Robert Snow
ID: 34979690
Have you tried browsing as root?

Also, make sure you have write permissions for the drive (in properties)
0
 
LVL 3

Expert Comment

by:dkikalis
ID: 34979710
If your file system thinks it's in error or not closed down properly it will come up in read-only mode.  What file system did you select when you installed the machine.  If it's a NTFS file system you can download a Windows Vista recovery CD that will boot a systemand let you run a few  things, including CHKDSK, with no need for a Windows licence, installation media or anything.

From memory there is a linux equivient call chkfsk.
0
 
LVL 2

Expert Comment

by:Robert Snow
ID: 34979714
https://answers.launchpad.net/ubuntu/+source/gnome-terminal/+question/15239

You can also create a shortcut and put in the command either gksudo nautilus or sudo nautilus and whenever you click it, nautilus will open as root
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 
LVL 1

Author Comment

by:1namyln
ID: 34979743
When I look at the properties of the folder where all the files are save it says only root has permissions to make changes.  If I check the properties of the drive itself it says this information can't be determined.  Don't know how to browse the drive as root via GUI or terminal.
Screenshot.png
0
 
LVL 1

Author Comment

by:1namyln
ID: 34979763
@dkikalis, the file system is NTFS as this drive was moved from a MSFT environment.
0
 
LVL 4

Expert Comment

by:FastSi
ID: 34979873
Not sure about the newer versions of debian (Ubuntu) but you used to only be able to read NTFS partitions and not write to them, and would have to install and use something like ntfs-3g to be able to write to NTFS drives. Some distros will come pre installed with this.

http://www.tuxera.com/community/ntfs-3g-download/
0
 
LVL 1

Author Comment

by:1namyln
ID: 34979878
@dkikalis, file system for the drive in question is NTFS.  The primary drive is ext4
0
 
LVL 1

Author Comment

by:1namyln
ID: 34979902
@FastSi, everything worked great until approximately one week ago.  It has a gremlin or I made a change that is preventing me from making changes to the drive.  I'm guess its the latter.
0
 
LVL 4

Expert Comment

by:FastSi
ID: 34980027
Hmmm still I wouldnt rule out the gremlin, would you be able to post a copy of your /etc/fstab file.
0
 
LVL 1

Author Comment

by:1namyln
ID: 34980059
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc                                       /proc        proc  nodev,noexec,nosuid                    0  0  
/dev/sda1                                  /            ext4  errors=remount-ro                      0  1  
# swap was on /dev/sda5 during installation
UUID=393e1aaa-16aa-4f3c-8dc0-c567c6e5e79a  none         swap  sw                                     0  0  
/dev/sdb1                                  /media/sdb1  ntfs  nls=iso8859-1,ro,users,umask=000,user  0  0  
0
 
LVL 3

Expert Comment

by:dkikalis
ID: 34980488
As I said at the beginning your drive as an error Use sudo  ntfsfix
0
 
LVL 1

Author Comment

by:1namyln
ID: 34980589
@dkikalis, did this to no avail.  With the exception of being able to write to the drive it functions normally.
0
 
LVL 1

Author Comment

by:1namyln
ID: 34982108
@Soulflare3, OK.  I can explore as root.  To back up a moment though, my user is part of the root group.  When I check the permission of the drive in question I see that the root group has folder access = create and delete files.
Screenshot-1.png
0
 
LVL 2

Expert Comment

by:Robert Snow
ID: 34983609
can you change where it says file access?

also - when you browse as root, are you able to do what you need/ freely access files/folders?
0
 
LVL 1

Author Comment

by:1namyln
ID: 34983642
@Soulflare3, I can change it but when I exit its back to --- again.  When browsing as root, that's all I can do is browse.  Can't make any changes.
0
 
LVL 2

Expert Comment

by:Robert Snow
ID: 34985079
The only other thing I can think of is that somehow your drive became write-protected like dkikalis said earlier...

I found this: http://community.wdc.com/t5/My-Book-for-PC/How-to-remove-write-protection/m-p/15220 and some said that after they did the CHKDSK (windows cd) that it fixed the errors and everything was fine... so - try dkikalis' first comment?

One thing you can try: turn off the computer, make sure the drive is connected, then start your computer. Ubuntu has a chkdsk utility built-in that runs while ubuntu loads - try a few times and it may automatically run and fix your drive
0
 
LVL 4

Accepted Solution

by:
FastSi earned 500 total points
ID: 34986307
try changing your /etc/fstab

# nano /etc/fstab

change the line that reads
                                                                                                       *
/dev/sdb1                                  /media/sdb1  ntfs  nls=iso8859-1,ro,users,umask=000,user  0  0  

change to
                                                                                                        *
/dev/sdb1                                  /media/sdb1  ntfs  nls=iso8859-1,rw,users,umask=000,user  0  0  

and reboot.
0
 
LVL 12

Expert Comment

by:mccracky
ID: 34989345
If it's dual boot and you didn't shutdown Windows correctly (or only hibernated), Ubuntu will not let you make changes to it.  Boot back into Windows and shutdown completely and correctly.
0
 
LVL 1

Author Comment

by:1namyln
ID: 34989423
@FastSi, I'll try this on Monday as this computer is at work. This is not a dual boot. This system was loaded onto a bare drive.
0
 
LVL 12

Expert Comment

by:mccracky
ID: 34990291
But what about your second drive, sdb? Was it "bare" too?  (If so, "why ntfs?" would be another question).

If this system was loaded as a "bare" system, where did your second drive come from?  I would assume some Windows system.  Are you sure you shut down that Windows system well?

When you try to mount it from the command line, are there any messages that come back?  

Open up a terminal, then:

sudo umount /dev/sdb1
sudo mount /dev/sdb1

0
 
LVL 1

Author Comment

by:1namyln
ID: 34991630
@mccracky, the storage drive used to be in a WIndows machine.  This drive has been in this system for almost a year with no issues.

I'll have to try the mount commands tomorrow as this computer is at my work.  The drive appears to be mounted though as I can access it but just can't make changes.  I've never tried to mount it from terminal though.  I'll repost tomorrow.  Thank you.
0
 
LVL 4

Expert Comment

by:FastSi
ID: 34991640
Cool well I replicated with your the config in your fstab and it was Read Only as shown in the fstab, then after changing the RO to RW and saved and rebooted it worked.

remounting may work but will most likely change back to Read only after a reboot. fstab will automount on each start up.
0
 
LVL 1

Author Comment

by:1namyln
ID: 34991776
@FastSi, thank you. I will try that tomorrow and repost.
0
 
LVL 1

Author Closing Comment

by:1namyln
ID: 34999575
Thank you.  That worked wonderfully.  How did it get changed?  Any ideas?
0
 
LVL 2

Expert Comment

by:Robert Snow
ID: 35001627
could have been changed by an installer... or maybe if a drive was in use and disconnected the file changed it from Read+Write to Read Only...
0
 
LVL 1

Author Comment

by:1namyln
ID: 35001658
Thanks for the update.  Learning as I go.  
0
 
LVL 2

Expert Comment

by:Robert Snow
ID: 35001762
I've noticed that different computers treat different situations differently... lot of differences :D
One thing may work for one computer, but not for another - anything can happen.

Glad FastSi saw that change in the fstab - nice work
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Linux haproxy: stop temporary haproxy service 9 44
how can I get powershell to show the history of commands used ? 10 56
CENTOS DHCP Server / PXE/TFTP 14 80
number in printf 13 27
Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question