Solved

how to downgrade firefox 3.6 to 3.5 in Ubuntu 9.10?

Posted on 2011-02-25
6
902 Views
Last Modified: 2012-05-11
I just did a fresh install of Ubuntu 9.10 and it installed the latest firefox 3.6.13.  Now, 3.6 has a conflict with VMWare Server 2.0 and I need to downgrade from firefox 3.6 to 3.5.  I did remove  firefox "sudo apt-get remove firefox."  Then, I installed firefox 3.5 and put it in a folder in my home directory.  But the Executable doesn't launch.  

When I do sudo apt-get install firefox 3.5, it installs 3.6 again.  How can I get 3.5 to work on Ubuntu 9.10? Before I did the rebuild, it was using Firefox 3.5 and there were no problems with VMWare.

Also, I did the same thing on Ubuntu 10.10 on another machine.  I was able to uninstall firefox 3.6 and install 3.5 and it works, but not on 9.10.  Thanks.
0
Comment
Question by:thadley
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
6 Comments
 
LVL 6

Expert Comment

by:de2Zotjes
ID: 34985994
apt-get install firefox=3.5
0
 

Author Comment

by:thadley
ID: 34992170
I got this error:  
Reading State information...Done
E: Version 3.5 for firefox was not found

Do I have to move the unpacked 3.5 files to another folder somewhere?  What else do I need to do?  Thanks
0
 
LVL 6

Expert Comment

by:de2Zotjes
ID: 34992304
You can find out what versions of firefox your package database knows about either via aptitude or by using
apt-cache showpkg firefox

Open in new window


If you get only  version that are too new you could try adding repositories for older versions of ubuntu to the system
0
Monthly Recap

May was a big month for new releases from Linux Academy! Take a look at what our team built recently in our blog. You can access the newest releases from our blog.

 

Author Comment

by:thadley
ID: 34993850
It looks like 3.5 is in there but when I install it, it says installing 3.5,, but it installs 3.6.  Below is the output.

tony@Lab1Ubuntu:~$ apt-cache showpkg firefox
Package: firefox
Versions:
3.6.13+build3+nobinonly-0ubuntu0.9.10.1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_karmic-updates_main_binary-amd64_Packages) (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_karmic-security_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language:
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_karmic-updates_main_binary-amd64_Packages
                  MD5: b670b07084b5a79b912d14c4307acda4

3.5.3+build1+nobinonly-0ubuntu6 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_karmic_main_binary-amd64_Packages)
 Description Language:
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_karmic_main_binary-amd64_Packages
                  MD5: a57e2fa1e1733e6f717bc8e5b97d791a


Reverse Depends:
  firefox-3.0,firefox
  sun-java6-plugin,firefox
  flashplugin-installer,firefox
  xul-ext-flashblock,firefox
  xul-ext-all-in-one-sidebar,firefox
  useragentswitcher,firefox
  torbutton-extension,firefox
  scrapbook,firefox
  mozzemberek,firefox 3.6
  mozilla-openoffice.org,firefox
  mozilla-openoffice.org,firefox
  mozilla-nukeimage,firefox
  mozilla-noscript,firefox
  mozilla-beagle,firefox
  foxyproxy,firefox
  firefox-notify,firefox 3.7
  firefox-notify,firefox 1.0
  firefox-dom-inspector,firefox
  firefox-3.1,firefox
  firefox-3.0-venkman,firefox
  firefox-3.0-dom-inspector,firefox
  firefox-3.0,firefox
  xsane,firefox
  ubufox,firefox
  openoffice.org,firefox
  mozvoikko,firefox 3.6
  firefox-gnome-support,firefox 3.6.13+build3+nobinonly-0ubuntu0.9.10.1
  firefox-dev,firefox 3.6.13+build3+nobinonly-0ubuntu0.9.10.1
  firefox-dbg,firefox 3.6.13+build3+nobinonly-0ubuntu0.9.10.1
  firefox-branding,firefox
  firefox-branding,firefox 3.6.13+build3+nobinonly-0ubuntu0.9.10.1
  firefox-3.5,firefox
  firefox-2-libthai,firefox
  firefox-2-dom-inspector,firefox
  firefox-2,firefox
  abrowser-branding,firefox
  abrowser-branding,firefox 3.6.13+build3+nobinonly-0ubuntu0.9.10.1
  abrowser,firefox
  zekr,firefox
  tiemu,firefox
  sun-java6-plugin,firefox
  mythbuntu-desktop,firefox
  lubuntu-desktop,firefox
  flashplugin-installer,firefox
  xubuntu-desktop,firefox
  xfig-doc,firefox
  wysihtml-el,firefox
  wmnetselect,firefox
  webhttrack,firefox
  useragentswitcher,firefox
  ubuntustudio-desktop,firefox
  torbutton-extension,firefox
  screenlets,firefox
  scrapbook,firefox
  rapache,firefox
  pytrainer,firefox
  nip2,firefox
  mozplugger,firefox
  mozilla-virt-viewer,firefox
  mozilla-venkman,firefox
  mozilla-stumbleupon,firefox
  mozilla-plugin-pcmanx,firefox
  mozilla-openoffice.org,firefox
  mozilla-openoffice.org,firefox
  mozilla-nukeimage,firefox
  mozilla-noscript,firefox
  mozilla-gtk-vnc,firefox
  mozilla-diggler,firefox
  mozilla-bonobo,firefox
  mozilla-biofox,firefox
  mozilla-beagle,firefox
  mediatomb,firefox
  lastfm,firefox
  itsalltext,firefox 3.0
  hunspell-vi,firefox 2.0.0.3-2
  hunspell-hu,firefox 2.0.0.3-2
  gosa-desktop,firefox
  gnome-do-plugins,firefox
  gears,firefox 3.5
  gcu-plugin,firefox
  foxyproxy,firefox
  flashblock,firefox
  firefox-showcase,firefox
  firefox-notify,firefox 3.6
  firefox-notify,firefox 1.0
  firefox-linky,firefox
  firefox-launchpad-plugin,firefox
  dhelp,firefox
  centerim-utf8,firefox
  centerim-fribidi,firefox
  centerim,firefox
  brdesktop-common,firefox
  bluefish,firefox
  ardour,firefox
  amsn,firefox
  all-in-one-sidebar,firefox
  xsane,firefox
  ubuntu-netbook-remix,firefox
  ubuntu-desktop,firefox
  ubufox,firefox
  openoffice.org,firefox
  libjibx-java-doc,firefox
  hunspell-uz,firefox 2.0.0.3-2
  hunspell-ne,firefox 2.0.0.3-2
  hunspell-gl-es,firefox 2.0.0.3-2
  hunspell-fr,firefox 2.0.0.3-2
  hunspell-eu-es,firefox 2.0.0.3-2
  hunspell-en-us,firefox 2.0.0.3-2
  hunspell-de-de,firefox 2.0.0.3-2
  hunspell-de-ch,firefox 2.0.0.3-2
  hunspell-de-at,firefox 2.0.0.3-2
  hunspell-da,firefox 2.0.0.3-2
Dependencies:
3.6.13+build3+nobinonly-0ubuntu0.9.10.1 - fontconfig (0 (null)) psmisc (0 (null)) lsb-release (0 (null)) debianutils (2 1.16) libasound2 (4 1.0.18) libatk1.0-0 (2 1.20.0) libc6 (2 2.7) libcairo2 (2 1.2.4) libdbus-1-3 (2 1.0.2) libdbus-glib-1-2 (2 0.78) libfontconfig1 (2 2.4.0) libfreetype6 (2 2.3.5) libgcc1 (2 1:4.1.1) libglib2.0-0 (2 2.16.0) libgtk2.0-0 (2 2.18.0) libnspr4-0d (2 4.8.6) libnss3-1d (2 3.12.6) libpango1.0-0 (2 1.14.0) libstartup-notification0 (2 0.10) libstdc++6 (2 4.1.1) libx11-6 (0 (null)) libxext6 (0 (null)) libxrender1 (0 (null)) libxt6 (0 (null)) zlib1g (2 1:1.1.4) firefox-branding (16 (null)) abrowser-branding (0 (null)) firefox-gnome-support (5 3.6.13+build3+nobinonly-0ubuntu0.9.10.1) latex-xft-fonts (0 (null)) libthai0 (0 (null)) ubufox (0 (null)) firefox-2 (3 3.6~) firefox-3.0 (3 3.6~hg20100117r33523) firefox-3.0-dom-inspector (3 3.1~) firefox-3.0-venkman (3 3.1~) firefox-3.1 (3 3.1~b4~hg20090317) firefox-3.5 (3 3.6~hg20100117r33523) firefox-3.6 (3 3.6~hg20100117r33523) firefox-3.6-gnome-support (3 3.6~hg20100117r33523) firefox-dom-inspector (3 3.1~) firefox-2 (0 (null)) firefox-3.0 (0 (null)) firefox-3.0-dom-inspector (3 3.1~) firefox-3.0-venkman (3 3.1~) firefox-3.1 (0 (null)) firefox-3.5 (0 (null)) firefox-3.6 (0 (null)) firefox-3.6-gnome-support (0 (null)) firefox-dom-inspector (3 3.1~)
3.5.3+build1+nobinonly-0ubuntu6 - firefox-3.5 (0 (null)) firefox-3.5-branding (0 (null))
Provides:
3.6.13+build3+nobinonly-0ubuntu0.9.10.1 - www-browser firefox-dom-inspector firefox-3.6 firefox-3.5 firefox-3.1 firefox-3.0-venkman firefox-3.0-dom-inspector firefox-3.0 firefox-2
3.5.3+build1+nobinonly-0ubuntu6 -
Reverse Provides:
abrowser 3.5.3+build1+nobinonly-0ubuntu6



tony@Lab1Ubuntu:~$ sudo apt-get install firefox-3.5
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following packages were automatically installed and are no longer required:
  binutils-static
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  firefox firefox-branding ubufox
Suggested packages:
  firefox-gnome-support
The following NEW packages will be installed:
  firefox firefox-3.5 firefox-branding ubufox
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/12.9MB of archives.
After this operation, 38.4MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Selecting previously deselected package firefox-branding.
(Reading database ... 127346 files and directories currently installed.)
Unpacking firefox-branding (from .../firefox-branding_3.6.13+build3+nobinonly-0ubuntu0.9.10.1_amd64.deb) ...
Selecting previously deselected package firefox.
Unpacking firefox (from .../firefox_3.6.13+build3+nobinonly-0ubuntu0.9.10.1_amd64.deb) ...
Selecting previously deselected package firefox-3.5.
Unpacking firefox-3.5 (from .../firefox-3.5_3.6.13+build3+nobinonly-0ubuntu0.9.10.1_all.deb) ...
Selecting previously deselected package ubufox.
Unpacking ubufox (from .../ubufox_0.9~rc2-0ubuntu0.9.10.1_all.deb) ...
Processing triggers for desktop-file-utils ...
Setting up firefox-branding (3.6.13+build3+nobinonly-0ubuntu0.9.10.1) ...
Setting up firefox (3.6.13+build3+nobinonly-0ubuntu0.9.10.1) ...
update-alternatives: using /usr/bin/firefox to provide /usr/bin/x-www-browser (x-www-browser) in auto mode.
Please restart all running instances of firefox, or you will experience problems.

Setting up firefox-3.5 (3.6.13+build3+nobinonly-0ubuntu0.9.10.1) ...
Setting up ubufox (0.9~rc2-0ubuntu0.9.10.1) ...

0
 
LVL 6

Accepted Solution

by:
de2Zotjes earned 250 total points
ID: 34994752
You used a hyphen iso an equals sign :)

apt-get install firefox=3.5.3

Open in new window

0
 

Author Comment

by:thadley
ID: 35003096
Every time I use the equal sign it gives me the following error:

Reading State information...Done
E: Version 3.5 for firefox was not found
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Fine Tune your automatic Updates for Ubuntu / Debian
In part one, we reviewed the prerequisites required for installing SQL Server vNext. In this part we will explore how to install Microsoft's SQL Server on Ubuntu 16.04.
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to moveā€¦
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question