Solved

Cisco AnyConnect SSL VPN won't connect Error: Host or network is 0

Posted on 2011-02-25
3
6,153 Views
Last Modified: 2012-05-11
I'm having trouble getting the AnyConnect SSL VPN to connect to an ASA 5510.
The error on the client is;

The Secure gateway has rejected the agent's VPN connect ot reconnect.......The following message was received from the secure gateway:Host or network is 0

The output of debug webvpn svc is;

webvpn_rx_data_tunnel_connect
CSTP state = HEADER_PROCESSING
http_parse_cstp_method()
...input: 'CONNECT /CSCOSSLC/tunnel HTTP/1.1'
webvpn_cstp_parse_request_field()
...input: 'Host: ##.##.##.242'
Processing CSTP header line: 'Host: ##.##.##.242'
webvpn_cstp_parse_request_field()
...input: 'User-Agent: Cisco AnyConnect VPN Agent for Windows 2.4.1012'
Processing CSTP header line: 'User-Agent: Cisco AnyConnect VPN Agent for Windows 2.4.1012'
Setting user-agent to: 'Cisco AnyConnect VPN Agent for Windows 2.4.1012'
webvpn_cstp_parse_request_field()
...input: 'Cookie: webvpn=4113240916@12288@1298649754@D366A4D5B8D0D87DC4246DB1F0DEE021E9DF6291'
Processing CSTP header line: 'Cookie: webvpn=4113240916@12288@1298649754@D366A4D5B8D0D87DC4246DB1F0DEE021E9DF6291'
Found WebVPN cookie: 'webvpn=4113240916@12288@1298649754@D366A4D5B8D0D87DC4246DB1F0DEE021E9DF6291'
WebVPN Cookie: 'webvpn=4113240916@12288@1298649754@D366A4D5B8D0D87DC4246DB1F0DEE021E9DF6291'
webvpn_cstp_parse_request_field()
...input: 'X-CSTP-Version: 1'
Processing CSTP header line: 'X-CSTP-Version: 1'
Setting version to '1'
webvpn_cstp_parse_request_field()
...input: 'X-CSTP-Hostname: ######'
Processing CSTP header line: 'X-CSTP-Hostname: #######'
Setting hostname to: 'Ian-Laptop'
webvpn_cstp_parse_request_field()
...input: 'X-CSTP-Accept-Encoding: deflate;q=1.0'
Processing CSTP header line: 'X-CSTP-Accept-Encoding: deflate;q=1.0'
webvpn_cstp_parse_request_field()
...input: 'X-CSTP-MTU: 1206'
Processing CSTP header line: 'X-CSTP-MTU: 1206'
webvpn_cstp_parse_request_field()
...input: 'X-CSTP-Address-Type: IPv6,IPv4'
Processing CSTP header line: 'X-CSTP-Address-Type: IPv6,IPv4'
webvpn_cstp_parse_request_field()
...input: 'X-DTLS-Master-Secret: #######'
Processing CSTP header line: 'X-DTLS-Master-Secret: #######'
webvpn_cstp_parse_request_field()
...input: 'X-DTLS-CipherSuite: AES256-SHA:AES128-SHA:DES-CBC3-SHA:DES-CBC-SHA'
Processing CSTP header line: 'X-DTLS-CipherSuite: AES256-SHA:AES128-SHA:DES-CBC3-SHA:DES-CBC-SHA'
webvpn_cstp_parse_request_field()
...input: 'X-CSTP-Protocol: Copyright (c) 2004 Cisco Systems, Inc.'
Processing CSTP header line: 'X-CSTP-Protocol: Copyright (c) 2004 Cisco Systems, Inc.'
Validating address: 0.0.0.0
CSTP state = WAIT_FOR_ADDRESS
webvpn_cstp_accept_address: 0.0.0.0/0.0.0.0
webvpn_cstp_accept_address: no address?!?
webvpn_cstp_accept_ipv6_address: No IPv6 Address
CSTP state = HAVE_ADDRESS
Host or network is 0: 0.0.0.0/0.0.0.0
webvpn_cstp_send_error: 503 Service Unavailable
CSTP state = ERROR

Open in new window


Running Config is;

: Saved
:
ASA Version 8.3(1) 
!
hostname #######
domain-name #######.co.uk
enable password ####### encrypted
passwd ####### encrypted
names
!
interface Ethernet0/0
 nameif outside
 security-level 0
 ip address ##.##.##.242 255.255.255.240 
!
interface Ethernet0/1
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/1.2
 vlan 2
 nameif inside
 security-level 100
 ip address 10.11.2.1 255.255.255.0 
!
interface Ethernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif tempmanage
 security-level 100
 ip address 10.0.5.115 255.255.255.0 
 management-only
!
interface Management0/0.1
 vlan 1
 nameif management
 security-level 100
 ip address 10.11.1.25 255.255.255.0 
 management-only
!
ftp mode passive
clock timezone GMT/BST 0
clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct 2:00
dns server-group DefaultDNS
 domain-name #######.co.uk
object network obj_any 
 subnet 0.0.0.0 0.0.0.0
object network AllInsideHosts 
 subnet 10.11.0.0 255.255.240.0
 description All Inside Hosts (VLANs  1-15)  
object network Servers 
 subnet 10.11.3.0 255.255.255.0
 description Servers (VLAN 3)  
object network VPNClients 
 subnet 10.11.10.0 255.255.255.0
access-list SplitTunnelList standard permit 10.11.2.0 255.255.255.0 
access-list nonat extended permit ip 10.11.2.0 255.255.255.0 10.11.10.0 255.255.255.0 
access-list nonat extended permit ip 10.11.10.0 255.255.255.0 10.11.2.0 255.255.255.0 
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu tempmanage 1500
mtu management 1500
ip local pool VPNClients 10.11.10.2-10.11.10.254 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm history enable
arp timeout 14400
nat (inside,outside) source static AllInsideHosts AllInsideHosts destination static VPNClients VPNClients
!
object network obj_any
 nat (inside,outside) dynamic ##.##.##.254
route outside 0.0.0.0 0.0.0.0 ##.##.##.241 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa local authentication attempts max-fail 16
http server enable
http 0.0.0.0 0.0.0.0 tempmanage
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics host number-of-rate 3
threat-detection statistics port number-of-rate 3
threat-detection statistics protocol number-of-rate 3
threat-detection statistics access-list
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
ssl server-version tlsv1-only
webvpn
 enable outside
 svc image disk0:/anyconnect-win-2.4.1012-k9.pkg 1
 svc enable
group-policy DfltGrpPolicy attributes
group-policy AdminVPN internal
group-policy AdminVPN attributes
 vpn-tunnel-protocol svc 
 webvpn
  svc keep-installer installed
  svc rekey time 30
  svc rekey method ssl
  svc ask none default svc
username test.user password ######### encrypted privilege 0
username test.user attributes
 vpn-group-policy AdminVPN
tunnel-group AdminVPN type remote-access
tunnel-group AdminVPN general-attributes
 address-pool VPNClients
 default-group-policy AdminVPN
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:4e82de4cf3d094b38b3dc0950af7409d
: end
asdm history enable

Open in new window


Any help is greatly appriciated.

Thanks,
Ian
0
Comment
Question by:skysys
  • 2
3 Comments
 
LVL 10

Accepted Solution

by:
lanboyo earned 500 total points
ID: 34981895

ciscoasa(config)#group-policy AdminVPN attributes
ciscoasa(config-group-policy)#address-pools value VPNClients
0
 
LVL 10

Expert Comment

by:lanboyo
ID: 34981934
From : http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a00808efbd2.shtml


You need to apply the internal ip pool to the webvpn...



ciscoasa(config)#group-policy AdminVPN attributes
ciscoasa(config-group-policy)#address-pools value VPNClients

Also, if you want it...

ciscoasa(config-group-policy)#dns-server value 192.168.50.5
!--- Specify the internal DNS server to be used.
ciscoasa(config-group-policy)#default-domain value web.local
!--- Define the default domain assigned to VPN users.
0
 

Author Closing Comment

by:skysys
ID: 34982038
Perfect!
Don't have any inside hosts to check it works fully but connection is up.

Thanks.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Wireless antenna advice/design 6 50
ACL Logging Optimization 7 31
DNS and NSLOOKUP 21 58
Using VLAN Interface in ASA 5 23
If you have an ASA5510 then this sort of thing would be better handled with a CSC Module, however on an ASA5505 thats not an option, and if you want to throw in a quick solution to stop your staff going to facebook during work time, then this is the…
Overview The Cisco PIX 501, PIX 506e, ASA 5505 and ASA 5510 (most if not all of this information will be relevant to the PIX 515e but I do not have a working configuration handy to verify the validity) are primarily used within small to medium busi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

26 Experts available now in Live!

Get 1:1 Help Now