Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Connection Time Out - LINUX

Posted on 2011-02-25
6
Medium Priority
?
465 Views
Last Modified: 2012-05-11
Hello Experts
I login to my server via putty. After exactly 180 sec I cannot access the server via putty as it gives me
"Network Error: Software connection abort". So where in the server should this be set. I am running RHEL4

-Steve
0
Comment
Question by:mnis2008
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 9

Expert Comment

by:jeremycrussell
ID: 34980978
Is it after 180 seconds idle, or will it disconnect after 180 seconds whether the connection is idle or not?
0
 
LVL 5

Expert Comment

by:balasundaram_s
ID: 34981605
Goto 'Putty configuration' --> 'connection' and change the value

"Seconds between keep alives" - 15 or 60 or any value ( 15 seconds or 60 seconds ).

This would prevent putty being closed by firewall due to being inactive.  

If the Linux server is configured with the TMOUT like below:

export TMOUT=180 ( it might be configured in the profile)

Then, the client sessions gets terminated being inactive for 180 seconds.

0
 

Author Comment

by:mnis2008
ID: 34983104
I dont have the TMOUT variable set. I think its something to do with the SSH configurations. I tried to change the putty configuration but it didnot work also one more strange thing.

When I open putty and give my DMZ server name its takes couple of sec to show the login and after typing my login it takes couple sec for the password....

Once I am in the server command executions are fast....

-Steve
0
Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 2

Expert Comment

by:maxalarie
ID: 34983283
Probably an  iptable rule that drops the connection after 180 seconds.

Can you  post the output of
iptables -L -n ?
0
 

Author Comment

by:mnis2008
ID: 34983332
Yes, Here is the output

Chain INPUT (policy ACCEPT)
target     prot opt source               destination
RH-Firewall-1-INPUT  all  --  0.0.0.0/0            0.0.0.0/0

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination
RH-Firewall-1-INPUT  all  --  0.0.0.0/0            0.0.0.0/0

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

Chain RH-Firewall-1-INPUT (2 references)
target     prot opt source               destination
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0
ACCEPT     icmp --  0.0.0.0/0            0.0.0.0/0           icmp type 255
ACCEPT     esp  --  0.0.0.0/0            0.0.0.0/0
ACCEPT     ah   --  0.0.0.0/0            0.0.0.0/0
ACCEPT     udp  --  0.0.0.0/0            224.0.0.251         udp dpt:5353
ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0           udp dpt:631
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:631
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           state RELATED,ESTABLISHED
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:5600
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:10010
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:10011
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:10012
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:10013
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:10014
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:10015
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:14141
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:20012
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:22
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:21
REJECT     all  --  0.0.0.0/0            0.0.0.0/0           reject-with icmp-host-prohibited
0
 
LVL 2

Accepted Solution

by:
maxalarie earned 2000 total points
ID: 34983441
I dont see any timouts. But you're accepting all ip adresses to log on your server..

I saw here: http://ocaoimh.ie/how-to-fix-ssh-timeout-problems/

that maybe it is set in your ssh config file.

Check your   /etc/ssh/sshd_config, and what  is the value of this parameter: ClientAliveInterval  ?
0

Featured Post

Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question