Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Exchange 2010 SP1 update fails (Cannot bind argument to parameter 'Identity' because it is null.)

Posted on 2011-02-25
5
Medium Priority
?
3,528 Views
Last Modified: 2012-05-11
When I attempted to upgrade my Exchange 2010 box to SP1, the Mailbox role fails to install. I am using an administrator account with all relevent permissions and groups.  I've tried the procedure to remove white space from my public folder names but this did not help.   The error message is below.  Any help would be appreciated.

Mailbox Role
Failed

Error:
The following error was generated when "$error.Clear(); if ($RoleCreatePublicFolderDatabase) { $publicDB = get-PublicFolderDatabase -Server:$RoleFqdnOrName -ErrorAction SilentlyContinue; $DB = get-MailboxDatabase -Server:$RoleFqdnOrName -ErrorAction SilentlyContinue; if ($publicDB -and $DB) { set-mailboxdatabase -Identity:$DB.Identity -publicFolderDatabase:$publicDB.Identity -DomainController $RoleDomainController } }" was run: "Cannot bind argument to parameter 'Identity' because it is null.".

Cannot bind argument to parameter 'Identity' because it is null.

0
Comment
Question by:caronimsguy
  • 4
5 Comments
 
LVL 74

Expert Comment

by:Glen Knight
ID: 34981083
Sounds like possibly a space in an alias for a user? Be worth checking.
0
 

Author Comment

by:caronimsguy
ID: 34982438
Thanks dematzer for your comment.

I checked but I didn't find any spaces in any user alias.  I did find one user that had a corrupt
mailbox.  I fixed the mailbox but the problem still exists.
0
 

Accepted Solution

by:
caronimsguy earned 0 total points
ID: 35021935
After 7 hrs. on the phone with Microsoft this case has been resolved.

The error message actually points in the wrong direction.  The problem is not with the Public Folders, mailboxes or user alias.  The issue is a missing registry key.  Please note editing the registry incorrectly can get you into trouble.  Proceed at your own risk.  In my case the following Registry value was missing

Under the key HKLM\Software\Microsoft\ExchangeServer\v14\MailboxRole, the REG_SZ  value ConfiguredVersion should be set to the current version of Exchange, in my case 14.0.639.21
0
 

Author Comment

by:caronimsguy
ID: 35021979
Accepted
0
 

Author Closing Comment

by:caronimsguy
ID: 35067690
Resolved the problem via support call to Microsoft.
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

With so many activities to perform, Exchange administrators are always busy in organizations. If everything, including Exchange Servers, Outlook clients, and Office 365 accounts work without any issues, they can sit and relax. But unfortunately, it…
Steps to fix error: “Couldn’t mount the database that you specified. Specified database: HU-DB; Error code: An Active Manager operation fail”
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

916 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question