Solved

Can't get relay to work on Exchange 2010 server

Posted on 2011-02-25
11
454 Views
Last Modified: 2012-05-11
Our web server sends password help to users who forgot their passwords. After upgrading to Exchange 2010 is no longer worked so I Googled how to set up relay service to work on Exchange 2010.

I cerated a send connector on the internal exchange server and when the I hit forgot password it sent me the password change email, great it worked. But the problem is once I enabled the new connector the regular connecters for external emal stopped working. Mail stopped flowing, the only mail that would flow was that being relayed from the web server.

 I followed this information http://www.lazynetworkadmin.com/knowledgebase-mainmenu-6/2-windows/149-exchange-2010-configure-anonymous-relay-to-external-domains 

I had to disable the new connector and reboot the to get mail flowing again. So I then created the send connector on the edge server following these instructions and nothing happened. It just didn't work.

http://technet.microsoft.com/en-us/library/bb232021.aspx 

I assume there must ba a way to create a new connector and keep the existing one working, any help on what I am doing wrong would be greatly appreciated.
0
Comment
Question by:chicagohistory
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
11 Comments
 
LVL 4

Expert Comment

by:RobertParten
ID: 34982590
I need a little more on your setup here. How many Exchange servers are in your organization? You have an Client Access and a Edge Transport server?

Let me ask you a few questions:

1. The web server, does it reside on the same LAN as the Exchange and does it access Exchange interally?

2. Is content filtering turned on Exchange?

3. in your send connector is it set to allow email to be relayed from the web server through Exchange?
0
 
LVL 12

Expert Comment

by:Mahmoud Sabry
ID: 34982915
0
 

Author Comment

by:chicagohistory
ID: 34983263
Robert,

The web server is on a different subnet as the mail server. Content filtering isn't on and the article i posted that I used to set this up said create a receive connector not a send connector. Like I said when I followed those instructions the relay worked but the rest of the regular mail stopped. I have narrowed it down to thet fact the two connectors can't use the same port number (25)

How can I work arround this issue?
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 

Author Comment

by:chicagohistory
ID: 34983284
msabry,

I can't do the first opetion because I don't have another NIC in the server to add a second IP address. I did configure like the second article but it doesn't address the port 25 issue. That seems to be the sticking point - can't have two connectors with the same port number. I treid substituting but I guess mail can only go out on 25.
0
 
LVL 4

Expert Comment

by:RobertParten
ID: 34983437
You can create an Alias IP for the server under the NIC cards TCP/IP settings. Then you can choose the ALIAS'd IP of the server to use for that connector.
0
 

Author Comment

by:chicagohistory
ID: 34983465
Never did that before - how do you cerate an alias IP?
0
 
LVL 4

Expert Comment

by:RobertParten
ID: 34987197
Go to the networls card properties (where you set ip and dns) and then click on advanced and you will see where you are able to add another ip address
0
 

Author Comment

by:chicagohistory
ID: 34998428
I tried this but everyone lost connectivity to the mail server. I am set up for dhcp with a reserved IP address. The option to enter an alias was grayed out so I switched from dhcp and entered the IP manually then went to advanced properties and entered an alias IP but after that everyone lost connectivity to exchange. Did I miss something?
0
 

Accepted Solution

by:
chicagohistory earned 0 total points
ID: 35001366
I called Microsoft and they made the settings exactly the same as I did for the relay connector. But he also added anomyous to the default connector, later he removed it from the default connector. It started working after he added it and continued after he removed it.

Making a change to the default connector must have shook something loose. I don't see any other explaination because it is working with the configuration I listed above.

The nice thing is they didn't charge me because it was resolved in a few minutes.

Thanks for your help - i hope this thread helps someone else sturggling like I did on this issue.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35331093
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question