Solved

Tomcat 7 Login

Posted on 2011-02-25
5
1,703 Views
Last Modified: 2012-05-11
This is my tomcat-users.xml file:

<?xml version='1.0' encoding='utf-8'?>
<tomcat-users>
<
  <role rolename="tomcat"/>
  <role rolename="manager-gui"/>
  <role rolename="manager-script"/>
  <user username="tomcat" password="tomcat" roles="tomcat"/>
  <user username="zozimos" password="orion" roles="manager-gui"/>
  <user username="tomcat" password="tomcat" roles="manager-script"/>
 >
</tomcat-users>

Using tomcat 7 when i enter http://localhost:8080 i get the '...successfully installed Tomcat...' and on the right side there are three buttons   (server status)  (manager app) (host manager)

When I click any of them I get the login/password prompt.  No combination of tomcat or zozimos allows me to log in.  What else do I need to do?
0
Comment
Question by:xoxomos
  • 3
  • 2
5 Comments
 
LVL 4

Expert Comment

by:FastSi
ID: 34983690
Looking at some example confs and they dont contain the extra < and > above and below the users.
0
 
LVL 4

Expert Comment

by:FastSi
ID: 34983713
Also a restart of tomcat will be required after any changes to this file.
0
 

Author Comment

by:xoxomos
ID: 34984438
I tried making that change:

<?xml version='1.0' encoding='utf-8'?>
<tomcat-users>
  <role rolename="tomcat"/>
  <role rolename="admin-gui"/>
  <role rolename="manager-gui"/>
  <role rolename="manager-status"/>
  <role rolename="manager-jmx"/>
  <role rolename="manager-status"/>
  <user username="tomcat" password="tomcat" roles="tomcat"/>
  <user username="tomcat" password="tomcat" roles="manager-gui"/>
  <user username="bobcat" password="bobcat" roles="admin-gui"/>
  <user username="both" password="tomcat" roles="tomcat,role1"/>
  <user username="role1" password="tomcat" roles="role1"/>
  <user username="zozimos" password="orion" roles="manager-gui"/>
  <user username="zozimos" password="orion" roles="manager-status"/>
</tomcat-users>

Now when clicking the buttons, i don't get a login/password prompt.  The server status immediately goes to that page, on the other two, i get a 401 UNAUTHORIZED or a 403 ACCESS DENIED?
0
 

Accepted Solution

by:
xoxomos earned 0 total points
ID: 35048141
Problem solved with reinstall.
0
 

Author Closing Comment

by:xoxomos
ID: 35106992
Problem solved with reinstall.
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

If your site has a few sections that need to be secure when data is transmitted between the server and local computer, such as a /order/ section for ordering or /customer/ which contains customer data, etc it would of course be recommended to secure…
Introduction This article is intended for those who are new to PHP error handling (https://www.experts-exchange.com/articles/11769/And-by-the-way-I-am-New-to-PHP.html).  It addresses one of the most common problems that plague beginning PHP develop…
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question