Solved

Tomcat 7 Login

Posted on 2011-02-25
5
1,697 Views
Last Modified: 2012-05-11
This is my tomcat-users.xml file:

<?xml version='1.0' encoding='utf-8'?>
<tomcat-users>
<
  <role rolename="tomcat"/>
  <role rolename="manager-gui"/>
  <role rolename="manager-script"/>
  <user username="tomcat" password="tomcat" roles="tomcat"/>
  <user username="zozimos" password="orion" roles="manager-gui"/>
  <user username="tomcat" password="tomcat" roles="manager-script"/>
 >
</tomcat-users>

Using tomcat 7 when i enter http://localhost:8080 i get the '...successfully installed Tomcat...' and on the right side there are three buttons   (server status)  (manager app) (host manager)

When I click any of them I get the login/password prompt.  No combination of tomcat or zozimos allows me to log in.  What else do I need to do?
0
Comment
Question by:xoxomos
  • 3
  • 2
5 Comments
 
LVL 4

Expert Comment

by:FastSi
ID: 34983690
Looking at some example confs and they dont contain the extra < and > above and below the users.
0
 
LVL 4

Expert Comment

by:FastSi
ID: 34983713
Also a restart of tomcat will be required after any changes to this file.
0
 

Author Comment

by:xoxomos
ID: 34984438
I tried making that change:

<?xml version='1.0' encoding='utf-8'?>
<tomcat-users>
  <role rolename="tomcat"/>
  <role rolename="admin-gui"/>
  <role rolename="manager-gui"/>
  <role rolename="manager-status"/>
  <role rolename="manager-jmx"/>
  <role rolename="manager-status"/>
  <user username="tomcat" password="tomcat" roles="tomcat"/>
  <user username="tomcat" password="tomcat" roles="manager-gui"/>
  <user username="bobcat" password="bobcat" roles="admin-gui"/>
  <user username="both" password="tomcat" roles="tomcat,role1"/>
  <user username="role1" password="tomcat" roles="role1"/>
  <user username="zozimos" password="orion" roles="manager-gui"/>
  <user username="zozimos" password="orion" roles="manager-status"/>
</tomcat-users>

Now when clicking the buttons, i don't get a login/password prompt.  The server status immediately goes to that page, on the other two, i get a 401 UNAUTHORIZED or a 403 ACCESS DENIED?
0
 

Accepted Solution

by:
xoxomos earned 0 total points
ID: 35048141
Problem solved with reinstall.
0
 

Author Closing Comment

by:xoxomos
ID: 35106992
Problem solved with reinstall.
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

Over the last year I have answered a couple of basic URL rewriting questions several times so I thought I might as well have a stab at: explaining the basics, providing a few useful links and consolidating some of the most common queries into a sing…
Hi, in this article I'm going to teach you how to run your own site, and how to let people in (without IP). I'll talk about and explain each step... :) By the way, everything in this Tutorial is completely free and legal. This article is for …
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now