Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2584
  • Last Modified:

SSL Certificate binding lost after IIS 7 restart

After restarting my IIS Server users got a Page cannot be displayed message when trying to access the https site. I had to eidt the Binding and and bind the site to the certificate. Now users can access the site but from within IIS when I try to browse to the site I get the "There is a problem with this website's security certificate." page. I didn't configure the websites certificates when we first brought it online, I am the developer and not very familiar with this whole certificate process but I would like to understand how or why this could have happened and what do I need to do to keep from getting the message I am getting from within IIS. Thanks for any help
0
AkAlan
Asked:
AkAlan
1 Solution
 
lanboyoCommented:
If the certificate in use is a self signed certificate then you just need to enable that certificate in your browser....
0
 
AkAlanAuthor Commented:
The certificate was purchased through Go Daddy
0
 
hermidaeCommented:
I assume that when you said "from within IIS" you mean from the IIS application, not from the browser in that server. I'm right? Then try from the browser and tell us if you obtained the same error message.

The certificate is assigned to a domain, for example www.example.com. If you are trying from the server itself, it is possible that you were connecting to the ip address (not the name) and then your browser don't identify the certificate with the ip.
0
 
AkAlanAuthor Commented:
I am only getting the certificate not trusted message from within IIS management studio or whatever the name is, im not able to get to the server now. On the eight side is an option to browse either .80 or .443. Anywhere else I hit the site from it opens the page just fine. Weird but not a show stopper. I need to have a better understanding of veers and iis server.
0
 
garrett_boarderCommented:
I would always use the URL on a browser instead of using things like IP or Localhost because of security settings that have been put in for good reasons.  Also you can configure your error logging so that detailed errors are displayed on the local server that you wouldn't want to advertise to other users because of the threat of hackers.  If you are uncertain about the cert you can use https://knowledge.verisign.com/support/ssl-certificates-support/index?page=content&id=AR1130&actp=search&viewlocale=en_US to check to make sure all 3 certificate chains are installed correctly.  Sometimes you will need to delete root or intermdiate certs and be weary of root cert updates from microsoft.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now