Solved

SimpleViewer Wordpress Plugin - Need to stop resizing window dynamically

Posted on 2011-02-25
5
504 Views
Last Modified: 2012-05-11
Hello,
I need the images in simpleviewer to display at their full, original size.  Right now they get scaled down when the window is resized.  My client wants the images to display full size, even if that means the end user has to scroll.
I looked in the professional settings and didn't see anything that worked.  Fixed layout doesnt work, cropping doesnt work.
Here is the link so you can see what I am referring to:  http://www.phoenixdigitalweb.com/Concep … rk/people/
Thank you!!!!!
0
Comment
Question by:RiemenDesign
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 14

Expert Comment

by:R-Byter
ID: 34989299
Its not a problem of the Wordpress plugin itself but rather the options you need to set for fancybox jquery part. That being said, here is how you can do it. In your document.ready part:

$(document).ready(function() { 
...

Open in new window


Find this line:

$("a#example4").fancybox(); 

Open in new window


And replace it with this for example:

$("a#example4").fancybox({
    'autoDimensions': false,
    'padding'       : 0,
    'width'         : 820,
    'height'        : 520,
    'autoScale'     : false,
    'type'          : 'iframe'
});

Open in new window


You can of course set the paramaters as you want.

Regards
0
 

Author Comment

by:RiemenDesign
ID: 34992376
But I need the height to be auto, so it will adjust automatically.
0
 
LVL 14

Expert Comment

by:R-Byter
ID: 34993452
Put auto to height property.

'height'        : auto,

Open in new window


Im trying that with this page at your site:

http://www.phoenixdigitalweb.com/portfolio.php

You need to give me exact link with the problem since link in your question is not complete.

Regards
0
 

Author Comment

by:RiemenDesign
ID: 34993541
0
 
LVL 14

Accepted Solution

by:
R-Byter earned 500 total points
ID: 34993673
It seems that page isnt working properly, distorted display viewed in Firefox and Chrome.
I see that you're using prettyPhoto in your code.
To disable resize for prettyPhoto you need to replace this:

$(document).ready(function(){
			$("a[rel^='prettyPhoto']").prettyPhoto({theme:'light_square'});
		});

Open in new window


with this:

$(document).ready(function(){
			$("a[rel^='prettyPhoto']").prettyPhoto({theme:'light_square', allow_resize: false});
		});

Open in new window


Regards
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

These days socially coordinated efforts have turned into a critical requirement for enterprises.
This article discusses how to implement server side field validation and display customized error messages to the client.
The purpose of this video is to demonstrate how to integrate Mailchimp with WordPress, by placing a Mailchimp signup form on a WordPress Page or Post. This will be demonstrated using a Windows 8 PC. Mailchimp will be used. Log into your Mailchi…
The purpose of this video is to demonstrate how to prevent comment spam on a WordPress Website. This will be demonstrated using a Windows 8 PC. Plugin Akismet will be used. Go to your WordPress login page. This will look like the following: myw…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question