• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 426
  • Last Modified:

Categories Pages/posts not working

I have several posts in different categories in wordpress, which show up in my archives, but when i click on the categories i only receive an error message that says "Sorry, but there aren't any posts in the blank category yet"  When i click on the individual posts, it even shows what categories they are under, but again, when i click on the url to bring me to all entries in that category, i get the same error message. I have not messed with any coding for query posts etc. It used to work, but stopped after i updated wordpress, updated some plugins, and made some new posts. Any ideas what could be wrong?
0
CCtech
Asked:
CCtech
  • 10
  • 3
1 Solution
 
CCtechAuthor Commented:
i can post any code i have if need be
0
 
Jason C. LevineNo oneCommented:
>> stopped after i updated wordpress

If you recently updated to WP 3.05 or 3.1, the database needs to be upgraded too.  

Try going to:

http://www.your site.com/wp-admin/upgrade.php
0
 
CCtechAuthor Commented:
i just updated it today. my wordpress database is up to date.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
CCtechAuthor Commented:
it is possible that it may not have worked prior to the update. the last time i used it it worked fine, but that was about a week ago. the only other person who has any rights to do anything has a user role of an editor to create and edit posts/pages. so i have no idea...
0
 
Jason C. LevineNo oneCommented:
So if you checked the update page and it reports your database is up to date, have you checked wp-admin to verify the posts show up there?

If everything checks out correctly, try to do something simple like switch the permalinks from however they are set now to Default and see if the content appears.  If it does, switch your permalinks back the way you had them...
0
 
CCtechAuthor Commented:
the posts work fine if i switch the permalinks. the website is mcsaac.com click on the categories on the side and no posts show up, but if you go through archives it shows up fine.
0
 
Jason C. LevineNo oneCommented:
But the category links in the menu are pointing to ?page_id= while the posts point (correctly) to ?p=

Check your navigation again?
0
 
CCtechAuthor Commented:
what should the correct navigation be?
0
 
CCtechAuthor Commented:
0
 
jamesakadamingoCommented:
This looks like a database upgrade went wrong.

Have you tried:
1. Remove all posts from their categories
2. Remove the categories (http://www.mcsaac.com/wp-admin/edit-tags.php?taxonomy=category)
3. Re assign posts to new categories (same name is fine), from the post properties


Plus I would set up a permalink setting before you go to far with your site.  Otherwise when you change it in the future all links will be broken.
0
 
CCtechAuthor Commented:
right now i have the permalinks on default. what kind of settings would you recommend?
0
 
CCtechAuthor Commented:
problem solved. category plugin incompatible with new version of wordpress... thanks for all the suggestions.
0
 
CCtechAuthor Commented:
*incompatible plugin
0
 
CCtechAuthor Commented:
the problem was that there was an in compatible with wordpress. i had to blow away my database and redo it before i realized what the actual issue was.
0

Featured Post

[Webinar] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

  • 10
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now