Solved

I cannot connect to SFTP server, CentOS

Posted on 2011-02-25
6
1,386 Views
Last Modified: 2012-05-11
I have my own SFTP server installed on Centos.
I could connect via Putty and filezilla  through port 22.
But I cannot connect to the server via Filezilla since yesterday.
Strange thing is I can connect to it via Putty.

I restart sshd and the server but still cannot.
Any suggestions?
Thank you in advance.



0
Comment
Question by:Ken_Kim
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
6 Comments
 

Author Comment

by:Ken_Kim
ID: 34985416
Error message in FIlezilla is below.

Error:      Fatal: unable to initialise SFTP on server: could not connect
Error:      Could not connect to server
0
 

Author Comment

by:Ken_Kim
ID: 34985421
No problem with Putty and FTP. With root and any other account.
0
 
LVL 1

Expert Comment

by:praveen_expert
ID: 34986874
Try to connect using passive mode in filezilla
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:Ken_Kim
ID: 34990183
Still not working, same error message. Even I reinstalled openssl.
0
 
LVL 6

Accepted Solution

by:
mohansahu earned 500 total points
ID: 34995798
Hi,

Set up your SFTP client.
If you are using Filezilla:

a. Open the program.
b. Click on Edit.
c. Click on Settings.
d. Open Connection tree.
e. Click on SFTP settings.
f. Leave Use Compression as default.
g. Choose to Use SSH2 (a more secure SSH connection).
h. Click OK.

i. Click on File.
j. Click on File Manager.
k. Click on New Site.
l. Enter your server SSH IP address in Host.
m. Choose SSH2 for ServerType - the port number should be 22.
n. Change the port number if you have a custom one for SSH.
o. Choose Normal for LogonType.
p. Enter your SSH username and password.
q. Click on Save and Exit.

Done! Try connecting to your server now via SSH2 using your SFTP client by clicking on the connect icon on the toolbar (most left). It should work. If it doesn't, check your Host SSH IP address again, Port number, Username and Password. Remember, it's the same settings as your SSH client (e.g. PUTTY).

Cheers,
MS
0
 

Author Closing Comment

by:Ken_Kim
ID: 36134841
no
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question