Solved

REDHAT5, Linux Mailserver

Posted on 2011-02-26
50
487 Views
Last Modified: 2013-12-18
We have installed linux redhat 5 server to for intranet mail service. I am facing a problem while pinging my router i.e. 196.146.43.129. on the other hand I am able to ping this ip from my laptop and other machine and also able to telnet. But when accessing from REDHAT5 we are not able to ping and status is "destination host unreachable..". this router is a getway to our second plant i.e. plant2 and we have got vpn between two network. From plant2 user is able to ping the router IP i.e. 196.146.43.129 and also able to ping my laptop ip ie. 196.146.43.198. our subnet mask is 255.255.255.0 Pl. help me to resolve this issue, thanks.
0
Comment
Question by:laveshverma
  • 24
  • 17
  • 8
  • +1
50 Comments
 
LVL 16

Expert Comment

by:santoshmotwani
ID: 34987005
can you please paste ouput of
route -n

from your redhat5 server
0
 

Author Comment

by:laveshverma
ID: 34994271
Forwaring the route info as require, pl. suggest what to do.

[root@localhost ~]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
196.146.43.0    0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0         196.146.43.250  0.0.0.0         UG    0      0        0 eth0
0
 
LVL 12

Expert Comment

by:asidu
ID: 34994298
<<We have installed linux redhat 5 server to for intranet mail service. I am facing a problem while pinging my router i.e. 196.146.43.129>
 >

For your linux machine the default gate way is pointing to 196.146.43.250

However, your mention the router ip is 196.146.43.129.
Change the default gateway of linux machine to 196.146.43.129

0
 
LVL 16

Expert Comment

by:santoshmotwani
ID: 34994364
route add default gw 196.146.43.129 eth0
0
 

Author Comment

by:laveshverma
ID: 34994503
it shows SIOCADDRT: File exists
what to do
0
 
LVL 16

Expert Comment

by:santoshmotwani
ID: 34994512
0
 
LVL 12

Expert Comment

by:asidu
ID: 34994516
0
 

Author Comment

by:laveshverma
ID: 34994518
This is for your info the out of ifconfig
[root@localhost sysconfig]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:07:E9:53:3B:89
          inet6 addr: fe80::207:e9ff:fe53:3b89/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:32808 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5993 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:2914866 (2.7 MiB)  TX bytes:909554 (888.2 KiB)

eth0:0    Link encap:Ethernet  HWaddr 00:07:E9:53:3B:89
          inet addr:196.146.43.125  Bcast:196.146.43.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1673 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1673 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3995968 (3.8 MiB)  TX bytes:3995968 (3.8 MiB)
0
 
LVL 12

Expert Comment

by:asidu
ID: 34994530
try
route add default gw 196.146.43.129 eth0:0
0
 

Author Comment

by:laveshverma
ID: 34994537
[root@localhost sysconfig]# sudo ip route delete 196.146.43.0/24 dev eth0

after deleting the route i tried to add the gw as per below it shows

[root@localhost sysconfig]# route add default gw 196.146.43.129 eth0
SIOCADDRT: Network is unreachable

pl. help thanks.lavesh
0
 
LVL 12

Expert Comment

by:asidu
ID: 34994551
If you have the graphics interface use it to configure the card.
It would be easier to change the parameters there..
0
 
LVL 16

Expert Comment

by:santoshmotwani
ID: 34994556
can you please output of

cat /etc/network/interfaces
0
 

Author Comment

by:laveshverma
ID: 34994568
I tried to cat it shows
[root@localhost etc]# cat /etc/network/interfaces
cat: /etc/network/interfaces: No such file or directory

0
 

Author Comment

by:laveshverma
ID: 34994569
I have installed redhat 5
0
 

Author Comment

by:laveshverma
ID: 34994578
Sir, forwarding the GUI setup screen shot, fyi
Screenshot.png
0
 
LVL 16

Expert Comment

by:santoshmotwani
ID: 34994592
cat /etc/sysconfig/network-scripts/ifcfg-eth0:0

It should look like this
====================================
DEVICE=eth0:0
BOOTPROTO=dhcp
IPADDR=196.146.43.125
NETMASK=255.255.252.0
BROADCAST=196.146.43.255
NETWORK=196.146.43.129
ONBOOT=yes
TYPE=Ethernet
0
 

Author Comment

by:laveshverma
ID: 34994593
Network configuration GUI
screen shot 2

Screenshot-1.png
0
 
LVL 16

Expert Comment

by:santoshmotwani
ID: 34994598
sorry i thought u r on ubuntu

once you have checked it then do  :

ifconfig eth0 down
ifconfig eht0 up
0
 

Author Comment

by:laveshverma
ID: 34994599

network GUI
screen shot 2
Screenshot-2.png
0
 

Author Comment

by:laveshverma
ID: 34994618
[root@localhost network-scripts]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Intel Corporation 82562EZ 10/100 Ethernet Controller
DEVICE=eth0:0
BOOTPROTO=none
TYPE=Ethernet
NETMASK=255.255.255.0
IPADDR=196.146.43.125
GATEWAY=196.146.43.129
USERCTL=no
IPV6INIT=no
ONPARENT=no
PEERDNS=yes
0
 
LVL 16

Expert Comment

by:santoshmotwani
ID: 34994724

just do vi or nano
/etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0  --- remove 0:0
BOOTPROTO=dhcp
IPADDR=196.146.43.125
NETMASK=255.255.252.0
BROADCAST=196.146.43.255
NETWORK=196.146.43.129
ONBOOT=yes
TYPE=Ethernet


0
 

Author Comment

by:laveshverma
ID: 34994859
is i have to add broadcast address too
is i have to change bootproto to dhcp
I have changed the file as per following

DEVICE=eth0
BOOTPROTO=none
TYPE=Ethernet
NETMASK=255.255.255.0
IPADDR=196.146.43.125
GATEWAY=196.146.43.129
USERCTL=no
IPV6INIT=no
ONPARENT=no
PEERDNS=yes


and restarted the network service
0
 
LVL 16

Expert Comment

by:santoshmotwani
ID: 34994881
BOOTPROTO=none ( static )
0
 

Author Comment

by:laveshverma
ID: 34994898
I have to change the parameter to

BOOTPROTO = static

or

BOOTPROTO = none (static)

Pl. clarify, thanks.
0
 
LVL 16

Expert Comment

by:santoshmotwani
ID: 34994905

BOOTPROTO = static

make sure you restart the service after you make change

or atleast
ifup eth0
ifdown eth0
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 

Author Comment

by:laveshverma
ID: 34994968
I have done the same and restarted the network service, but still i am not able to ping the ip 196.146.43.129
0
 
LVL 16

Expert Comment

by:santoshmotwani
ID: 34995114
can you please paste output of

 traceroute 196.146.43.129
0
 

Author Comment

by:laveshverma
ID: 34995164
Forwarding the output of trace route for your info

[root@localhost ~]# traceroute 196.146.43.129
traceroute to 196.146.43.129 (196.146.43.129), 30 hops max, 40 byte packets
 1   (196.146.43.125)  3000.285 ms !H  3000.272 ms !H  3000.253 ms !H
[root@localhost ~]#

waiting for your kind reply, thanks
0
 
LVL 16

Expert Comment

by:santoshmotwani
ID: 34995186
after adding
route add default gw 196.146.43.129 eth0

your route -n should give something like :

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
196.146.43.0    0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0         196.146.43.129  0.0.0.0         UG    0      0        0 eth0


Can you please confirm you r getting above output from roue -n
0
 
LVL 16

Expert Comment

by:santoshmotwani
ID: 34995200
sorry its route -n
0
 

Author Comment

by:laveshverma
ID: 34995234
result of route -n

[root@localhost ~]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
196.146.43.0    0.0.0.0         255.255.255.0   U     0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth0
0.0.0.0         196.146.43.129  0.0.0.0         UG    0      0        0 eth0
0
 
LVL 12

Expert Comment

by:asidu
ID: 34995254
If you have a patch cable. Try changing it.
Could it be that the connection is no good.
Can you see if the router can see the machine. Alos
is there any light on the LAN port on your machine.
Routing info seems to be okie now.

Check if you are running any firewall on the linux machine which blocks the ping packets.

Can you ping from other machine to the linux machine ??
0
 
LVL 16

Expert Comment

by:santoshmotwani
ID: 34995258
please do this

route del -net 169.254.0.0 netmask 255.255.0.0 gw 196.146.43.129 eth0

and

do route -n

and then

ifdown eth0
ifup eth0

and then try pinging
0
 
LVL 16

Expert Comment

by:santoshmotwani
ID: 34995289
after doing everything if still got a problem then try changing cable.
0
 

Author Comment

by:laveshverma
ID: 34995396
If I ping linux server from my laptop it pings i.e. from ip 196.146.43.189 to 196.146.43.125
secondly, if I ping 196.146.43.129 from my laptop i.e. from 196.146.43.189 router pings. router light and the cable attached is very must ok.

I tried to run the following command it shows the output as below for your info.

[root@localhost ~]# route del -net 169.254.0.0 netmask 255.255.0.0 gw 196.146.43
.129 eth0
SIOCDELRT: No such process

pl. suggest what to do..
0
 
LVL 16

Expert Comment

by:santoshmotwani
ID: 34995488
how abt your host file

can you please post cat /etc/hosts
0
 

Author Comment

by:laveshverma
ID: 34995497
If tried with below command it works and second line entry in route -n is now deleted
[root@localhost ~]# route del -net 169.254.0.0 netmask 255.255.0.0 gw 0.0.0.0 eth0

wait i will give you the result ..
0
 

Author Comment

by:laveshverma
ID: 34995590
After deleting the route add

[root@localhost ~]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
196.146.43.0    0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0         196.146.43.129  0.0.0.0         UG    0      0        0 eth0

Starting network service

[root@localhost ~]# /etc/init.d/network restart
Shutting down interface eth0:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:                                [  OK  ]

Tracerouted the ip

[root@localhost ~]# traceroute 196.146.43.129
traceroute to 196.146.43.129 (196.146.43.129), 30 hops max, 40 byte packets
 1   (196.146.43.125)  3000.426 ms !H  3000.411 ms !H  3000.392 ms !H
[root@localhost ~]# ping 196.146.43.129

STILL NOT ABLE TO PING
PING 196.146.43.129 (196.146.43.129) 56(84) bytes of data.

--- 196.146.43.129 ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2000ms

0
 
LVL 16

Expert Comment

by:santoshmotwani
ID: 34995608
can i please see output of cat /etc/hosts  

Its really strange
0
 
LVL 12

Expert Comment

by:asidu
ID: 34995621
Disconnect your linux lan cable and connect your laptop to it.
See if you are able to ping to the router from there.
0
 

Author Comment

by:laveshverma
ID: 34995643
Out put of /etc/hosts

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1               localhost.localdomain
::1             localhost6.localdomain6 localhost6
~
for your info..
0
 

Author Comment

by:laveshverma
ID: 34995650
JUST FOR YOUR INFORMATION

[root@localhost etc]# service iptables status
Firewall is stopped.
[root@localhost etc]# service ip6tables status
Firewall is stopped.
[root@localhost etc]#
0
 

Author Comment

by:laveshverma
ID: 34995663
As suggested I disconned the liunx server cable and connect it with liunx server situation remains the same, FYKI
0
 
LVL 16

Expert Comment

by:santoshmotwani
ID: 34995674
Can you please change you eth0 configuration



nano  /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=eth0
ONBOOT=yes
BOOTPROTO=dhcp


and then restart the service

ifdown eth0
ifup eth0

Can you please try this
0
 
LVL 12

Expert Comment

by:asidu
ID: 34995681
So issue is not due to packet filtering.
It could be an issue at the router itself.

Connect your LAPTOP to the cable form the linux machien.
Set the ip of the laptop to 196.146.43.125 the address of the linux machine and test.
That will confirm if the problem is with your machine or at another point.
0
 

Author Comment

by:laveshverma
ID: 34995786
I changed my laptop ip address to 196.146.43.125 and tried to ping the router it failed and output is timed out.

now what will the next step should I have to change the IP of the linux server to resolve the issue ?
0
 
LVL 12

Expert Comment

by:asidu
ID: 34995818
Just to confirm did you use the cable from the Linux machine ?
If yes, then the issue is not with your Linux machine.

If you use the same port and the original IP of your laptop can it work?
If you have other port at the router try swapping ports and test.

Looks like issue is not with your Linux machine. I guess the issue with the settings of router.
One last thing you could do is to reset the router and try if it helps.
0
 

Author Comment

by:laveshverma
ID: 34995865
Just to confirm did you use the cable from the Linux machine ? NO
If yes, then the issue is not with your Linux machine.

If you use the same port and the original IP of your laptop can it work? YES
If you have other port at the router try swapping ports and test. NO

Looks like issue is not with your Linux machine. I guess the issue with the settings of router.
One last thing you could do is to reset the router and try if it helps. WILL TRY

I TRIED TO CHANGE THE LAPTOP IP TO 196.146.43.132 AND TRIED TO PING THE ROUTER IT WORKS. ALSO I ALREADY STATED THAT IF I CHANGED THE LAPTOP IP TO SERVER IP THEN THE ROUTER IS NOT PINGED.  SHOULD I TRY WITH NEW IP I.E. 196.146.43.132 OR REBOOT THE ROUTER AND SEE ITS EFFECT, PL ADVISE, THANKS. WAITING FOR YOUR REPLY.

0
 
LVL 17

Accepted Solution

by:
Sikhumbuzo Ntsada earned 500 total points
ID: 35154738
Get another router and set up a new IP range and test.
0
 

Author Closing Comment

by:laveshverma
ID: 36163988
good, thanks.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

New-MailboxSearch Powershell Command and step by step approach to Search and Extract Emails form Exchange 2013 Journaling server.
Import PST to Exchange using Power Shell new-mailboximportrequest command, you can simply import the PST file into Exchange mailbox or archived. To know How to import PST into Exchange  2013 read the complete article.
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now