Solved

Exchange 2007 - Outlook 2007 AutoSetup showing wrong information (?)

Posted on 2011-02-26
20
1,014 Views
Last Modified: 2012-05-11
I setup SBS 2008, which includes Exchange 2007.  Everything appears to be setup properly for email (domain.com), including the Accepted Domains and the Email Address policy with "domain.local" nowhere in sight...  BUT.. when a domain computer goes to setup Outlook 2007, the Auto Setup displays the right user first name last name, but the wrong email address "user@domain.local".  When I setup the account under the ".local" address, everything works fine (sends email as domain.com, shows address book for everyone as domain.com) but in Account Settings it shows "user@domain.local" and the Welcome email shows as coming from a domain.local email address.

I have uninstalled Client Access Role from Exchange and reinstalled it, restarted the SBS server several times... and can't seem to figure it out. I just want emails to show up on AutoSetup and Settings as "user@domain.com" NOT "user@domain.local".  Do I need to re-install the server or is there something else I should try?  

Help!
0
Comment
Question by:erikandre
  • 8
  • 6
  • 2
  • +3
20 Comments
 
LVL 49

Expert Comment

by:Akhater
ID: 34987200
it is not related to exchange what you are seeing is the user UPN that is username@domain.local and that's different then your email address that is user@domain.com.

openn Active Direcoty users and computer -> find your user -> go to the account tab you will see in the UPN user@domain.local that is what you are seeing
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 34987203
Sounds like the SBS exchange parts have been configured manually instead of using the wizards in the SBS console?

You must run all the wizards in the console, if you don't then SBS will behave strangely.
0
 

Author Comment

by:erikandre
ID: 34987289
Akhater, I saw that earlier, but that isn't it as I have another SBS 2008 server, configured properly and that's setup the same.

Demazter, I think I did try to do a few things manually at first, but then ran all the wizards afterwards.  Perhaps that's where my trouble began.., but there's got to be something I can do to get this working fine instead of wiping everything and starting over (?)
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 34987315
Just re-run the internet address wizard, this should sort it out.
0
 

Author Comment

by:erikandre
ID: 34987360
Is that the same as the "Setup your Internet Address" wizard?  If so, I did try that and it's the same result.  I just can't seem to find what I'm missing.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 34987385
0
 

Author Comment

by:erikandre
ID: 34988416
Thanks... I tried running it but it is reporting "No Errors were found on your network"...
0
 

Author Comment

by:erikandre
ID: 34990453
Arg - Just Reinstalled everything, ran the wizards first and still the same thing.
0
 
LVL 12

Expert Comment

by:Navdeep
ID: 34991081
Hi,

Go to the EMC and open user's mailbox, go to it's properties and find out what is the user's primary smtp address. If you only have one primary smtp address i.e user@domain.local obviously that will show up that address.

Now what you need to do is to create a new Accepted domain, mark it as authoritative and apply the email address to the user and set it up as Primary SMTP address.  I hope this will address the issue.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 34991121
v-nas2 > it's SBS, running the wizards properly will do this.
Manually doing this with SBS will cause problems.
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Author Comment

by:erikandre
ID: 35004229
I wiped and started over starting the wizards first and it still continues.  I also have the Primary SMTP address set to .com as well as added to the accepted domain list and eliminated the .local address from each.  

I deployed it across the company anyway and noticed that on the AutoSetup it showed on half of them the .com and the other half the .local.  Strange.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35004390
And SBS is fully up to date?
0
 

Author Comment

by:erikandre
ID: 35007212
Yes, all the way up to date, including Exchange 2007 SP3
0
 
LVL 12

Expert Comment

by:Navdeep
ID: 35009101
Hi,

can you recycle ur  box and test again.

Use Online mode and try to create a new user and check what address the user gets when you create a new account. Setup a test profile.
0
 

Author Comment

by:erikandre
ID: 35039456
Tried what you suggested and some computers still show up as .local in the email address.  Odd thing is that it sends and receives as the .com so I guess I should just let it go and consider it a glitch with SBS 2008.
0
 
LVL 1

Accepted Solution

by:
pkerkhof earned 400 total points
ID: 35068151
Same problem here, i searched the internet and found that it was caused by the updates Outlook2010/KB2405793 (26/10/2010) and Outlook2007/KB2412171 (11/1/2011). Since those updates Outlook autoconfiguration displays the UPN instead of the emailadres.
Workarounds:
- deinstall the update or
- manually configure Outlook
0
 
LVL 1

Assisted Solution

by:stever1884
stever1884 earned 100 total points
ID: 35072543
Pkerkhof is correct.  This was our issue as well.  It isn't related to SBS or Exchange, but rather the Outlook client.

There are a few more workarounds/fixes as well:
-http://support.microsoft.com/kb/2475891 (If you look at the bottom, you will see this issue resolved with this hotfix)
-Add the local email address (or UPN) to all the accounts via the Default E-mail Address Policy
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35072561
aparently SBS 2008 Rollup 5 fixes this issue, can you confirm it's installed?
0
 

Author Comment

by:erikandre
ID: 35201119
Demazter, SBS 2008 Rollup 5 was installed at the time of the question.

Pkerkhof, I have already manually configured everyone's Outlook to work, but I do think it's a little silly that I would have to uninstall an update on everyone's computer in order to get this to work.  I'm sure it'll likely work, just can't understand why Microsoft do something that silly.  Actually, I guess not really surprised (it's Microsoft, afterall).  In any case, since steve confirmed it, I will award the answer to you (though I just don't have the time or patience to go through removing updates and removing, readding Outlook accounts).
0
 
LVL 1

Expert Comment

by:stever1884
ID: 35201166
As I stated in my previous comment, you can also add the local email address to all the accounts via the Default E-mail Address Policy.  

For example, if your domain is test.local and your user's current email is testuser@test.com, add a global email to everyone's account via the Default E-mail Address Policy as @test.local.  This should resolve your issue and, in my opinion, is the easiest resolution.
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now